blob: 8de0ecc4827d1708d3c9d846a8f902971255181d [file] [log] [blame]
Harald Welte640d72a2010-08-24 15:33:04 +02001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4#
5# This file was originally written by Joey Hess and Craig Small.
6# As a special exception, when this file is copied by dh-make into a
7# dh-make output file, you may use that output file without restriction.
8# This special exception was added by Craig Small in version 0.37 of dh-make.
9#
10# Modified to make a template file for a multi-binary package with separated
11# build-arch and build-indep targets by Bill Allombert 2001
12
13# Uncomment this to turn on verbose mode.
14#export DH_VERBOSE=1
15
16# This has to be exported to make some magic below work.
17export DH_OPTIONS
18
Harald Welteba439692010-08-25 13:54:58 +020019# this requires debhelper 7.0.50 or above, which lenny doesn't have yet!
20#override_dh_auto_configure:
21# dh_auto_configure -- --enable-nat --enable-osmo-bsc
22
23build: build-stamp
24build-stamp:
25 dh build --before configure
Harald Welte640d72a2010-08-24 15:33:04 +020026 dh_auto_configure -- --enable-nat --enable-osmo-bsc
Harald Welteba439692010-08-25 13:54:58 +020027 dh build --after configure
28 touch build-stamp
Harald Welte640d72a2010-08-24 15:33:04 +020029
30%:
31 dh $@