blob: 8aec381ed22b30ceb2fe6485fce6ab0cfb829b26 [file] [log] [blame]
Harald Welte41e7cf12019-01-22 16:02:11 +01001osmo-msc (1.3.1) unstable; urgency=medium
2
3 [ Neels Hofmeyr ]
4 * fix build: apply msgb_wrap_with_TL() rename
5
6 -- Harald Welte <laforge@gnumonks.org> Tue, 22 Jan 2019 16:02:11 +0100
7
Harald Welte811f6802019-01-21 00:16:26 +01008osmo-msc (1.3.0) unstable; urgency=medium
9
10 [ Philipp Maier ]
11 * vlr_access_req_fsm: use correct cause codes
12 * a_reset: cleanup + remove dead code
13 * mgcp: do not start connections in loopback mode
14 * mgcp: hack to keep IuUP working
15 * mgcp: use codec information returned with ASSIGNMENT COMPL.
16 * doc: update mgw settings in example config file
17 * mncc: fix byte ordering of IP-Address in mncc
18 * msc_mgcp: move mncc struct initalization to where its actually needed
19 * gsm_04_08_cc: Add global guard timer for MNCC
20 * cosmetic: remove forgotten debug printf
21 * vlr: drop unused is_ps parameter in vlr_subscr_req_lu()
22 * osmo_msc: remove unused parameter from msc_dtap()
23 * gsm_subscriber: make function msc_paging_request() static
24 * msc_vty: display subscriber flags
25 * msc_vty: display current RAN type
26 * msc_vty: also show IMEI and IMEISV
27 * gsm_04_08: Fix nullpointer deref
28
29 [ Stefan Sperling ]
30 * remove redundant unconditional PKG_CHECK_MODULES for libsmpp
31 * implement periodic Location Update expiry in the VLR
32 * VLR: reject overlong IMSIs in ID RESP messages
33 * fix a use-after-free in msc_mgcp.c:_handle_error()
34 * detach cancelled subscribers from VLR
35 * make gsup ipa name configurable in osmo-msc.cfg
36 * provide software version information to gsup peer
37 * require 'ipa-name' option to be set via config file
38 * use vty->type instead of local variable
39
40 [ Vadim Yanitskiy ]
41 * libmsc/ussd.c: FIX: properly indicate errors
42 * libmsc: properly name the MSC_CONN_USE token for SS
43 * libmsc/ussd.c: use connection ref-counting and transactions
44 * Use proper naming for GSM TS 09.11 implementation
45 * libmsc/gsm_04_08.c: expose gsm48_tx_simple()
46 * libmsc/gsm_09_11.c: properly indicate transaction errors
47 * libmsc/gsm_04_80.c: make the API abstract from ss_request struct
48 * .gitignore: ignore src/libgsupclient/gsup_test_client
49 * configure.ac: drop unused dependencies
50 * msc_vlr_tests: don't abuse USSD-request to conclude connections
51 * libvlr/vlr.c: forward unhandled GSUP messages towards MSC
52 * libmsc/gsm_09_11.c: forward SS/USSD messages to HLR over GSUP
53 * libmsc/gsm_09_11.c: implement network-initiated sessions
54 * libmsc/gsm_09_11.c: properly handle MS-initiated release
55 * libmsc/gsm_09_11.c: introduce rate counters for NC_SS sessions
56 * libmsc/gsm_09_11.c: introduce counter for active sessions
57 * msc/signal.h: use #pragma once include guard
58 * msc/rrlp.h: use #pragma once include guard
59 * libmsc/rrlp.c: add missing include
60 * libmsc/gsm_09_11.c: clean up the local GSM 04.80 API
61 * RRLP: properly name the init function
62 * RRLP: fix: actually init the RRLP signal handlers
63 * RRLP: migrate and share mode definitions from msc_vty.c
64 * RRLP: print log when sending a position request
65 * osmo-msc: free the VTY talloc context on exit
66 * osmo-msc: track the use of talloc NULL memory contexts
67 * libmsc/db.c: cosmetic: mark missing breaks in switch as intended
68 * msc/gsm_04_11.h: drop unused sms_next_rp_msg_ref()
69 * msc/gsm_04_11.h: use forward-declaration for _gsm411_sms_trans_free()
70 * msc_vlr_tests.c: drop duplicating DMM category definition
71 * libmsc/gsm_04_11.c: don't pass msgb to gsm411_rx_rp_{ack|error}
72 * libmsc/gsm_04_11.c: refactor RP-DATA header validation
73 * libmsc/transaction.c: cosmetic: fix typo
74 * libmsc/gsm_09_11.c: drop redundant assertion of stored msgb
75 * libmsc/gsm_04_11.c: refactor MT SMS message handling
76 * libmsc/gsm_04_11.c: fix: always use SAPI 3 for MT SMS
77 * libmsc/VTY: introduce kill-switch for routing SMS over GSUP
78 * libmsc/gsm_04_11.c: forward MO SMS messages over GSUP
79 * libmsc/gsm_04_11.c: accept MT SMS messages over GSUP
80
81 [ Pau Espin Pedrol ]
82 * msc_main: Fix typo in description of version param
83 * jenkins.sh: Use --enable-werror only when iu support is disabled
84 * osmo-msc: Improve shutdown due to signal and print talloc report on exit
85 * msc: Set talloc ctx for osmo_signal structures
86 * Install systemd services with autotools
87 * Install sample cfg file to /etc/osmocom
88 * msc: vty: Fix integer printf formatting
89
90 [ Daniel Willmann ]
91 * git-version-gen: Don't check for .git directory
92 * OsmoBSC/HLR/MSC: Fix default config file name
93
94 [ Harald Welte ]
95 * libmsc: move L3 call-control to separate C file (gsm_04_08_cc.c)
96 * migrate to oap_client in libosmogsm
97 * Remove local libgsupclient; Use libosmo-gsup-client from osmo-hlr
98 * gsm0407_is_duplicate(): Handle error ret of gsm0407_pdisc_ctr_bin()
99 * share chapters/gsup.adoc from OsmoSGSN to OsmoMSC + OsmoHLR
100 * vty-ref: Update URI of docbook 5.0 schema
101 * add SGs / CSFB related dot + msc files
102
103 [ Neels Hofmeyr ]
104 * vlr_access_req_fsm.c: use osmo_strlcpy and avoid compiler error
105 * Iu MGCP: no need to loopback on the cn side
106 * cosmetic: typos in log and comment
107 * use __FILE__, not __BASE_FILE__
108 * cosmetic: mute "COMPLETE_LAYER_3 not permitted"
109 * store classmark in vlr_subscr, not conn
110 * msc_vlr_tests: cosmetically tweak perm algo printing
111 * A5/n Ciph: request Classmark Update if missing
112 * fix Classmark Update without VLR subscriber
113 * vty: add SCCP related vty commands
114 * GSUP client: send CN domain IE on LU request
115 * lu_fsm: result cb: use proper cause type (warning/coverity)
116 * Importing history from osmo-gsm-manuals
117 * add OsmoMSC manual
118 * add OsmoHLR manual, OsmoHLR VTY reference
119 * refactor Makefile build rules, don't use the FORCE
120 * OsmoMSC: update VTY reference
121 * msc: update vty reference
122 * drop unused gsm_subscr_conn->mncc_rtp_bridge
123 * drop unused gsm_network->handover.active
124 * drop unused openbscdefines.h
125 * drop unused SUBSCR_CONN_E_INVALID
126 * drop unused gsm0408_allow_everyone() declaration
127 * drop unused tests/db/*
128 * cosmetic: subscr_conn_fsm_auth_ciph() should be static
129 * adjust copyright in subscr_conn.c
130 * populate gsm_subscriber_connection->encr during Ciph
131 * rename gsm_encr to geran_encr, it is only applicable on GERAN
132 * drop msc_compl_l3() return value
133 * rename gsm_subscriber_connection to ran_conn
134 * rename some RAN conn related stuff to ran_conn_*
135 * move subscr_conn.c to ran_conn.c
136 * move ran_conn declarations to new ran_conn.h
137 * combine several small .h in msc_common.h
138 * cosmetic: drop some unused opaque struct defs
139 * move gsm_auth_tuple to vlr.h as vlr_auth_tuple
140 * GSM_EXTENSION_LENGTH -> VLR_MSISDN_LENGTH
141 * drop cruft from gsm_subscriber.h
142 * move gsm_cbfn to gsm_subscriber.h, the only user
143 * python tests: use py shebang instead of $(PYTHON)
144 * make: prepare for adding transcript tests
145 * add test_nodes.vty transcript test
146 * cosmetic: msc_main.c: default args definition style
147 * msc_main: mncc: move mncc socket decision to after read_cfg
148 * vty: mncc cfg: separate the 'mncc' from 'mncc-guard-timeout'
149 * add VTY commands: mncc internal / external (== -M)
150 * ASS-COMPL: do not fire Sec Mode Compl event
151 * move ASS-COMPL MGCP handling out of a_iface_bssap.c
152 * drop gsm48 RR ciph mode compl from permitted initial messages
153 * LU: do not always invoke sub_pres_vlr_fsm_start()
154 * Revert "move ASS-COMPL MGCP handling out of a_iface_bssap.c"
155 * log: by default start with all categories on LOGL_NOTICE
156 * tweak comment to indicate sub_pres_vlr fsm as dead code
157 * vlr_lu_fsm: drop unused out_state INIT -> WAIT_IMEI
158 * comment: vlr: put the 'balancing' comment closer to the put()
159 * vty: show subscriber: put() before printing the use count
160 * fix msc_mgcp_fsm_evt_names: two missing events
161 * mgcp log tweak: say RAN, not BTS, like surrounding logging
162 * fix test_nodes.vty after libosmo-mgcp-client vty changes
163 * cosmetics in msc_mgcp_call_release()
164 * release RTP stream only for matching CC transaction
165 * fix vlr ops.subscr_assoc re-association
166 * remove code dup: add msc_mgcp_try_call_assignment()
167 * move trans->assignment_done to cc.assignment_started
168 * fix: incoming call during ongoing call
169 * abort assignment on Assignment Failure
170 * vlr: auth_fsm: make sure vsub->auth_fsm = NULL when it terminates
171 * vty cfg: move 'ipa-name' from 'msc' to 'hlr' section
172 * use osmo_rat_type from libosmocore
173 * use mgcp-client configured endpoint domain name
174 * use osmo_lu_type_name() from libosmocore
175 * add LOG_RAN_CONN() to use the conn->fi->id for context
176 * rx CM Service Req: reject double use sooner
177 * refactor log ctx for vlr_subscr and ran_conn
178 * mm_rx_id_resp(): use osmo_mi_name()
179 * tweak fsm_msc_mgcp FSM and FI name
180 * err log: fully log MS supported A5 algos on mismatch
181 * msc_vlr_tests: tweak logging in verbose mode
182
183 [ Keith ]
184 * libmsc/mncc_sock.c: Add lchan_type_offset in queue_hello()
185 * Make alert notifications vty configurable per ESME
186 * Cosmetic: Fix spelling in smpp vty
187
188 [ Max ]
189 * Properly parse cause in cipher mode reject
190 * Add counters for BSSMAP cipher mode messages
191 * vty: add command to show all known BSC
192 * msc_vlr_tests: tweak conn_exists()
193 * Fix build with latest libosmocore
194 * Use BSSAP-specific TLV parser from libosmocore
195 * Use libosmocore to function to parse cipher mode reject cause
196 * cosmetic: drop duplicated #include
197 * cosmetic: drop unused variable
198 * CC: log more details about unhandled message/state
199 * VLR tests: add logging macro with explicit value description
200 * VLR tests: avoid leaking LAC access details
201 * Use proper type for tch_rtp_connect() parameter
202 * VLR: drop unused struct members
203 * Remove redundancy in LAC processing
204 * MNCC: use log wrapper for call processing
205 * Constify transaction helpers parameters
206 * Use explicit protocol discriminator for NC SS/USSD session
207 * Fix trans_has_conn() doxygen description
208 * Enable SMS-related log in VLR tests
209 * MNCC: use explicit struct type in gsm_call
210 * SMS: remove code duplication in transaction init
211 * vty: make 'sh connect/transact' readable again
212
213 [ Keith Whyte ]
214 * libmsc: Don't send SMS STATUS REPORT locally if the ESME accepted it.
215
216 [ Alexander Couzens ]
217 * OsmoMSC: add rate counter documentation
218
219 [ Oliver Smith ]
220 * build manuals moved here from osmo-gsm-manuals.git
221 * Fix DISTCHECK_CONFIGURE_FLAGS override
222 * contrib/jenkins.sh: build and publish manuals
223 * contrib: fix makedistcheck with disabled systemd
224 * Cosmetic: msc_vty: remove redundant "0 =", "1 ="
225 * msc_vty.c: make check-imei-rqd configurable
226 * vlr_core.h: remove duplicate declarations
227 * VLR: vlr_subscr_{,msisdn_or_}name: const vsub arg
228 * VLR: send CHECK-IMEI to EIR/HLR
229
230 [ Ivan Kluchnikov ]
231 * libmsc/transaction: introduce trans_find_by_sm_rp_mr()
232
233 [ gsmevent admin ]
234 * gsm_04_08_cc.c: drop non-sensible error message
235
236 -- Harald Welte <laforge@gnumonks.org> Mon, 21 Jan 2019 00:16:26 +0100
237
Pau Espin Pedrolcb8c75b2018-05-03 18:52:03 +0200238osmo-msc (1.2.0) unstable; urgency=medium
239
240 [ Neels Hofmeyr ]
241 * msc_vlr_tests: fix rebuild: rebuild when src/ libs were rebuilt
242 * cosmetic: vlr: rename auth_tuple_max_use_count to _reuse_
243 * tests: add msc_vlr_test_authen_reuse
244 * vty: make auth tuple reuse configurable
245 * vty: drop deprecated 'logging level sms...'
246 * defaults: assign TMSI by default
247 * vty: skip installing cmds now always installed by default
248 * examples: apply mgcp_client vty rename from 'mgcpgw' to 'mgw'
249 * vlr: auth_fsm_start: check return value of fsm alloc
250 * add --enable-sanitize config option
251 * rate_ctr: don't use . as separator
252 * sub_pres_vlr_fsm_start: fix heap use after free
253 * vlr_gsupc_read_cb: fix use after free of GSUP msgb
254 * subscr_conn: don't close after conn timeout
255 * vlr_subscr_conn_timeout(): don't fire events to discarded fi
256 * cosmetic: msc_vlr_tests: add comment to show expected tallocs
257 * sms_queue_test: sanitize: clean up talloc contexts when done
258 * cosmetic: log: CC state transition: log trans id and subscr
259 * cosmetic: log: CC trans_alloc: log trans_id and subscr, not memory addrs
260 * cosmetic: debug log: mncc: detached subscr: show subscriber
261 * msc_vlr_tests: fix test nr arg: clear errno before strtol()
262 * msc_vlr_tests: set a valid lac for fake conns
263 * use only 0.23.1 as point code for both A and Iu
264 * subscr_conn: introduce usage tokens for ref error tracking
265 * cosmetic: log error when using a conn that's in release
266 * add msc_vlr_test_call to reproduce a sanitizer error
267 * fix use after free: missing conn_get on CC paging response
268 * sms db: don't attempt to query pending SMS for unset MSISDN
269 * sms db: properly quote MSISDN in various SQL queries
270 * sms.db: silence libdbi warnings on out-of-range index
271 * fix vty write: add missing 'authentication optional/required' output
272 * compiler warning: drop double 'const' in a_iface_tx_cipher_mode()
273 * debug log: a_iface_tx_cipher_mode(): log cipher and key
274 * cosmetic: msc_vlr_tests: log SMS details when invoked with -v
275 * vlr: debug log: log Ciphering Mode details
276 * fix BSSMAP Cipher Mode Cmd: properly set permitted algorithms
277 * cosmetic: move translation of vlr_ciph into msc_vlr_set_ciph_mode()
278 * cosmetic prep: publish vlr_use_umts_aka() decision
279 * cosmetic prep: tell vlr_ops.set_ciph_mode() whether UMTS AKA is used
280 * drop unused T* timers (BSC land, not MSC)
281 * cosmetic: msc_paging_request: drop obsolete comment
282 * fix GSM-Milenage in presence of 2G keys
283 * compiler warning: extend #if 0 to include unused array
284 * a_iface_bssap: compiler warning: cast const away from TLV val for l2h
285 * smpp_smsc: fix truncated string copy into bind_r.system_id
286 * log: a_iface.c: revisit logging, use LOGPCONN
287 * cosmetic: rename sccp_rx_udt and sccp_rx_dt to a_*
288 * fix paging: add timeout to discard unsuccessful paging
289 * fix: properly cancel all Paging on IMSI Detach
290 * a_iface_tx_assignment: fix log lvl for "Sending Assignment..."
291 * fix build: missing LIBOSMORANAP flags in libmsc
292 * drop unused libmsc/meas_feed.h
293 * cosmetic: gsm_network_init(): imply default 001-01 PLMN
294 * implement support for 3-digit MNC with leading zeros
295 * vlr: fix post-auth LU failure handling
296 * vlr_lu_fsm: guard against using the wrong fi
297 * msc_vlr_tests: revert IMSI parameter and test nr output
298 * msc_vlr_test_gsm_ciph: drop unused function
299 * msc_vlr_tests: make all test functions static
300 * msc_vlr_tests: improve cipher mode coverage
301 * fix: clear vlr_subscr->msc_conn_ref when the conn is discarded
302 * vty: drop unused commands
303 * vty: add 'msisdn' as alias for 'extension'
304 * vty: add 'subscriber ... paging' cmd
305 * msc_main: do not say 'osmo-nitb' in the usage
306 * silent call: clarify rc and error messages logged on vty
307 * msc_vlr_tests: clearly separate Ciph Mode from Security Mode checking
308 * msc_vlr_test_gsm_ciph: add test for GSM AKA in UMTS environment
309 * vlr: fix GSM AKA in a UMTS AKA capable environment
310 * vlr auth: gracefully reject malformed auth response
311 * gsm48_rx_mm_auth_resp(): pass is_r99 from classmark, not response size
312 * cosmetic: gsm48_rx_mm_auth_resp(): log 'UMTS AUTH', not 'R99 AUTH'
313 * msc_vlr_test_umts_authen: test response with too short RES
314 * msc_vlr_test_umts_authen: test response with too long RES
315 * msc_vlr_test_umts_authen: test response with only SRES half of RES
316 * cosmetic: vlr_auth_fsm: clarify decision on UMTS AKA or GSM AKA
317 * cosmetic: vlr_auth_fsm: log RAN and size along with SRES/RES
318 * msc_vlr_tests: add test_a5_3_not_supported
319 * configure: add --enable-werror
320 * vlr_ciph_result: fix use after free of imeisv
321 * trans_free: safeguard against a still running CC timer on free
322 * cosmetic: vlr_auth: log decision to send UMTS or GSM AKA challenge
323 * cosmetic: msc_vlr_tests: enable CC logging in debug
324 * cosmetic: rename conn_fsm "bump" event to "release_when_unused"
325 * msc_vlr_tests: add CC Release test and test to catch OS#2779
326 * cosmetic: gsm_04_08.c: drop unused struct gsm_lai
327 * trans_free: tear down conn when last transaction is done
328 * dissolve libcommon,libcommon-cs: clean up vty definitions
329 * cosmetic: msc_vty.c: use static gsmnet instead of gsmnet_from_vty()
330 * dissolve libcommon: drop unused bsc_version.c
331 * dissolve libcommon: drop debug.c
332 * dissolve libcommon: move talloc ctx into msc_main.c, drop talloc_ctx.c
333 * dissolve libcommon: drop gsm_subscriber_base.c, move vlr_subscr_* to vlr.c
334 * dissolve libcommon: drop gsm_data.c, move code to libmsc
335 * rename libcommon to libgsupclient
336 * dissolve libcommon-cs: mv a_reset.c to libmsc
337 * dissolve libcommon-cs: move gsm_network_init() to libmsc
338 * dissolve libcommon-cs: move gsm48_* code to libmsc, drop sms_next_rp_msg_ref()
339 * remove empty libcommon-cs
340 * gsup_test_client: gsupc_read_cb: fix uninitialized value 'io'
341 * use osmo_init_logging2() with proper talloc ctx
342 * drop some dead definitions (gsm_data.h, gsup_client.c)
343 * test_reject_concurrency: missing assert
344 * cosmetic: rx_bssmap: read message type once into local var
345 * cosmetic: rename gsm_subscriber_connection->conn_fsm to ->fi
346 * cosmetic: rename subscr_conn_from to complete_layer3_type
347 * subscr_conn: store complete_layer3_type in conn, not FSM event arg
348 * unify allocation of gsm_subscriber_connection
349 * trans_free: drop bad assertion
350 * msc_vlr_test_call: reproduce OS#3062
351 * CC: intentionally release T308 on BSSMAP Clear Request from BSC
352 * refactor subscr_conn and subscr_conn_fsm de-/alloc
353 * properly receive BSSMAP Clear Complete and Iu Release Complete
354 * fix BSC Clear Request
355 * cosmetic: embed compl_l3_type in FSM id
356 * refactor VLR FSM result handling
357 * msc conn ref counts: log human readable list of conn owners
358 * cosmetic: use enum ranap_nsap_addr_enc instead of int
359
360 [ Harald Welte ]
361 * sms_route_mt_sms: Don't return uninitialized variable
362 * MNCC: Add input validation
363 * Log difference between SETUP and EMERGENCY_SETUP
364 * Emergency Call: Set MNCC_F_EMERGENCY flag
365 * Refuse Emergency Calls by IMEI with proper CM SERVICE REJECT Cause
366 (Closes: #2866)
367 * Reject any CM SERVICE we don't support
368 * Remove traces of meas_feed
369 * Fix msc_vlr test results (.err) for new libosmocore GSM48_PDISC names
370 * Properly reject CM Re-Establishment Request
371 * msc_cipher_mode_compl: Handle CIPH MOD COMPL without L3 message
372 * remove unused paging.h and osmo_bsc_grace.h
373 * debug: Remove code for filters that don't exist in OsmoMSC
374 * remove traces of bsc_subscriber
375 * jenkins.sh: Don't depend on osmo-ggsn
376 * Massive removal of unused code/structs/headers
377 * remove unused ipaccess.h
378 * remove dead code in auth.h / auth.c
379 * remove dead header files bsc_msc.h, bsc_msc_data.h and bsc_rll.h
380 * signal.h: Remove unused/dead signal definitions
381 * remove dead ctrl.h header file
382 * debug: Remove dead log categories
383 * Shift ciphering algorithm selection from VLR to MSC
384 * Permit a set of multiple different A5 ciphers
385 * MSC: Intersect configured A5 algorithms with MS-supported ones
386 * Change GSUP re-connect interval to 1s
387 * Implement checks for duplicate uplink UL L3 message (Closes: #2908)
388 * VTY: Add 'show connections' and 'show transactions' commands
389 * a_reset: Add additional "a_reset_alloc" argument
390 * Don't answer to BSC-originated RESET with another RESET
391 * cosmetic: Use msgb_hexdump*() rather than manual osmo_hexdump() on msg
392 * a_iface: Reduce log levels
393 * a_iface_bssap.c: Use LOGPCONN() whenever possible
394 * a_sccp_rx_dt(): Don't print hexdump of message multiple times
395 * cosmetic: a_iface: Harmonize log statements
396 * cosmetic: No need for 'break' after 'return'
397 * a_iface: centralize lookup of subscriber_conn
398 * cosmetic: a_iface: More logging harmonization
399 * a_iface: Add copyright statement (after recent contributions)
400 * Introduce new BSSAP logging category/subsystem
401 * a_iface: Fix heap-use-after-free by cleaning up msgb ownership
402 * Add VTY command to configure destination MSISDN for emergency calls
403 * a_iface: Fix heap-use-after-free in a_clear_all()
404 * MGCP: Response code 250 is *not* an error for DLCX
405 * a_iface: s/Abis/L3/ for speech version/preference fields
406 * a_iface: Consistent and understandable function names
407 * MT Calls: Copy bearer capabilities from NNCC primitive to trans
408 * MNCC: Copy bearer_cap from MNCC to gsm_trans
409 * gsm_data: remove unused gsm_subscriber_connection members
410 * remove bsc_api.h and all users - they're all dead code
411 * dead code removal
412 * remove unused dyn_ts_allow_tch_f VTY option
413 * osmo-msc: Add talloc context introspection via VTY
414 * remove unused VTY command "location updating reject cause"
415 * remove unused "authorized-regexp" VTY command
416 * remove unused "auth policy" VTY command
417 * remove dead code (gsm_parse_reg)
418 * BSSAP: Return error code if COMPL L3 with no or too short L3 payload
419 * a_iface_bssap: Treat inbound RESET as implicit RESET ACK
420 * a_iface: If L3/DTAP returns error in COMPL L3, close SCCP connection
421 * DTAP: Ensure proper DLCI is used in MSC-originated DTAP
422 * Permit any Sender MSISDN when sending SMS from VTY
423 * smpp: Unset esme->acl on socket close
424 * sms_queue: fix use-after-free on 'pending'
425
426 [ Alexander Couzens ]
427 * debian/rules: remove doublicated project name in example files
428 * libmsc/vty: don't access old bsc rate counters
429
430 [ Philipp Maier ]
431 * reset: remove name variable from reset context
432 * cosmetic: move log message to else branch
433 * cosmetic: add missing spaces
434 * cosmetic: remove duplicate logging
435 * mncc: re-add lchan members to structs
436 * mncc: remove deprecated commandline option.
437 * a_iface: correct data type for a.conn_id in gsm_subscriber_connection
438 * mgcp: use osmo-mgw to switch rtp streams
439 * increase RAN timeout in MGCP FSM
440 * a_reset: Add FSM event names
441 * msc_mgcp: Add FSM event names
442 * a_iface: fix BSSMAP reset handling
443 * msc_mgcp: fix mgw timeout handling
444 * mgcp: be sure that pending mgcp transactions are canceled before free
445 * msc_mgcp: use more conceise error msg on truncation
446 * mcgp: let the MGW allocate the MGCP endpoint
447 * cosmetic: remove disabled (debug) code gsm_04_08.c
448 * msc_mgcp: to not access higher layers after release
449 * cosmetic: remove unused variable
450 * msc_mgcp.c: log endpoint name instead of pointer
451 * msc_mgcp: do not send wildcarded DLCX messages
452
453 [ Max ]
454 * Use osmo-ggsn instead of openggsn in jenkins tests
455 * Add basic CTRL test
456 * Remove obsolete ./configure option
457 * Remove unneeded .py scripts
458 * Enable sanitize for CI tests
459 * Migrate from OpenSSL to osmo_get_rand_id()
460 * VLR: remove unused parameter
461 * VLR: log subscriber update
462 * Add control command to expire subscriber
463 * VLR: constify GSUP-related function parameters
464 * cosmetic: log prim operation as text
465 * Remove unused code
466 * Wrap osmo_strlcpy() calls
467 * Fix whitespace issues
468 * Constify msc_subscr_conn_is_accepted() parameter
469 * Move IMSI into test parameters
470 * VLR tests: mark static test functions as such
471 * Expand VLR tests
472 * VLR tests: don't fail via assert
473 * VLR tests: remove weird code
474 * VLR tests: always print test parameters
475 * VLR tests: move network init into function
476 * GSUP: check osmo_gsup_encode() result
477 * VLR: fix potential NULL dereference
478
479 [ Alexander Huemer ]
480 * Add missing CFLAGS
481 * Remove utils imported from openbsc, fix building remaining util smpp_mirror
482
483 [ Pau Espin Pedrol ]
484 * libmsc: db.c: Replace dbi APIs marked as deprecated
485 * libmsc: msc_vty: Fix compilation warning
486 * libmsc: bssap: Fix typo in log message
487 * libmsc: bssap: Refactor rx paths to to avoid parse_tlv code duplication
488 * libmsc: bssap: Catch TLV parse failures
489 * libmsc: bssap: Remove fixme and properly update msgb tail
490 * msc_mgcp.c: Fix several wrong ptr printf fmt
491 * contrib: osmo-msc.service: Depend on osmo-mgw.service
492 * smpp_smsc_conf: Fix heap-use-after-free
493 * Remove unused GSM_PAGING_OOM
494 * setup_trig_pag_evt: Remove uneeded default case in switch statement
495 * setup_trig_pag_evt: Always log correct paging failure case
496 * setup_trig_pag_evt: Fix heap-use-after-free
497
498 [ the 34c3 gsm team ]
499 * smpp_smsc.c: don't talloc_strdup NULL pointers
500
501 [ Vadim Yanitskiy ]
502 * msc/gsm_04_80.h: clean up useless declarations
503 * msc/gsm_04_80.h: cosmetic: whitespace fix
504 * msc/gsm_04_80.h: use '#pragma once' instead of includes
505 * src/libmsc/ussd.c: drop useless forward declaration
506 * ussd.h: cosmetic: remove useless comment
507 * ussd.h: cosmetic: use '#pragma once' include guard
508 * libmsc/gsm_04_80.c: drop unused 'in_msg' argument
509 * libmsc/ussd.c: cosmetic: correct log level and message
510 * libmsc/ussd: don't overwrite rc if decoding failed
511 * tests/msc_vlr: fix expected SS message names
512
513 [ Stefan Sperling ]
514 * Improve an error message in db_init().
515 * Delete SMS from the database once they were sent successfully
516 * Store/retrieve SMS validity time in the SMS datebase
517 * Fix value of stored SMS validity time.
518 * Add a VTY command which deletes all expired SMS.
519 * Accept SMS for any receiver
520 * Delete expired SMS automatically.
521 * Make sending an SMS to an unknown subscriber B work over SMPP.
522 * enable osmo_fsm vty commands in osmo-msc vty
523 * Track libosmocore API change in osmo-msc.
524 * restore sending of optional MM info messages
525 * use libosmocom to parse cell identifier in bssmap_rx_l3_compl()
526
527 [ Daniel Willmann ]
528 * iucs: Add a function to return the connection ID for the IU SCCP conn
529 * libmsc: Add a function to return a unique ID of the subscriber conn
530 * libmsc: Pretend MNCC requested release in handle_error()
531
532 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 18:52:03 +0200
533
Harald Welte9a5b4742017-10-29 09:01:31 +0100534osmo-msc (1.1.2) unstable; urgency=medium
535
536 * Depend on both libosmo-sigtran-dev and libosmo-sccp-dev
537 * Debian: require minimum versions of packages we depend on
538
539 -- Harald Welte <laforge@gnumonks.org> Sun, 29 Oct 2017 09:01:30 +0100
540
Harald Welteaaa85802017-10-28 21:57:23 +0200541osmo-msc (1.1.1) unstable; urgency=medium
542
543 * Debian: Depend on libosmo-sigtran-dev, not libsomo-sccp-dev!
544
545 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 21:57:22 +0200
546
Harald Welte6a015682017-10-28 14:45:59 +0200547osmo-msc (1.1.0) unstable; urgency=medium
548
549 [ Alexander Couzens ]
550 * Initial release.
551 * debian/rules: show testsuite.log when tests are failing
552
553 [ Neels Hofmeyr ]
554 * build: check for -lgsm
555 * am: msc_vlr_tests: use AM_LDFLAGS instead of COMMON vars
556 * jenkins: fix build: osmo-mgw from master, not pre_release
557 * jenkins: drop unused build matrix vars, always --enable-smpp
558 * configure.ac: fix to "AC_INIT[osmo-msc]"
559 * rewrite README
560 * rename openbsc.pc to osmo-msc.pc
561 * debian: fix web and VCS links, tweak osmo-msc.install
562 * drop files unrelated to osmo-msc
563 * rename include/openbsc to include/osmocom/msc
564 * doc/examples: add detailed cs7 config examples
565 * use separated libosmo-mgcp-client, apply rename to mgcp_client_*
566 * ctrl: subscriber-list-active: list only attached subscribers
567 * debian: fix dependency to mgcp library
568 * main: remove cmdline args no longer available for osmo-msc
569 * vty: fix: missing default cmds at hlr node
570 * ctrl: remove unimplemented cmds subscriber-{modify,delete}
571 * fix build: remove obsolete header legacy_mgcp/mgcp.h
572 * fix debian: fix erratic doc/examples install path
573 * fix memory leak: vlr: vlr_gsupc_read_cb() must msgb_free()
574 * fix vty tests: long timeout due to unreachable STP address
575 * cosmetic: vlr: declare a struct in .h; drop unused header
576 * add ';' after OSMO_ASSERT()
577
578 [ Philipp Maier ]
579 * a_iface: fix memory leaks
580 * a_iface: fix typo
581
582 [ Max ]
583 * Remove rest_octets.h
584 * Remove SI-related code
585 * Remove BTS-specific attributes
586 * Remove unused osmo_bsc_rf.h header
587 * Remove pkg-config file
588
589 [ Harald Welte ]
590 * Update .gitignore for post-nitb-split
591 * remove further files and autotest/autoconf bits irrelevant to osmo-msc
592 * Rename osmo_fsm to avoid illegal space in name + more meaningful name
593 * Debian: remove obsolete Dependencies
594 * configure.ac: Depend on latest tagged/released libosmo-* versions
595 * Debian: Build with enabled SMPP support
596 * osmo-msc: Don't link against libasn1c
597 * Debian: Include systemd.service in package
598 * Debian: include all (not just one) example config files
599
600 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 14:45:58 +0200
601
Alexander Couzens4d1ee5e2017-08-07 08:36:36 +0000602osmo-msc (0.1.0) UNRELEASED; urgency=low
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200603
Alexander Couzens4d1ee5e2017-08-07 08:36:36 +0000604 * Initial release.
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200605
Alexander Couzens4d1ee5e2017-08-07 08:36:36 +0000606 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:13:01 +0000