blob: 2aeed06c9386e6066c959319a657afefdfd3f4c5 [file] [log] [blame]
Oliver Smithd6877eb2020-05-14 11:47:38 +02001#
2# spec file for package osmo-mgw
3#
4# Copyright (c) 2017, Martin Hauke <mardnh@gmx.de>
5#
6# All modifications and additions to the file contributed by third parties
7# remain the property of their copyright owners, unless otherwise agreed
8# upon. The license for this file, and modifications and additions to the
9# file, is the same license as for the pristine package itself (unless the
10# license for the pristine package is not an Open Source License, in which
11# case the license is the MIT License). An "Open Source License" is a
12# license that conforms to the Open Source Definition (Version 1.9)
13# published by the Open Source Initiative.
14
15# Please submit bugfixes or comments via http://bugs.opensuse.org/
16#
17
18Name: osmo-mgw
19Version: 1.7.0.13
20Release: 0
21Summary: Osmocom's Media Gateway for 2G and 3G circuit-switched mobile networks
22License: AGPL-3.0-or-later AND GPL-2.0-or-later
23Group: Hardware/Mobile
24URL: https://osmocom.org/projects/osmo-mgw
25Source: %{name}-%{version}.tar.xz
26BuildRequires: automake >= 1.9
27BuildRequires: libtool >= 2
28BuildRequires: pkgconfig >= 0.20
29BuildRequires: systemd-rpm-macros
30BuildRequires: pkgconfig(libosmo-netif) >= 0.6.0
31BuildRequires: pkgconfig(libosmocore) >= 1.0.0
32BuildRequires: pkgconfig(libosmoctrl) >= 1.1.0
33BuildRequires: pkgconfig(libosmogsm) >= 1.0.0
34BuildRequires: pkgconfig(libosmovty) >= 1.0.0
35BuildRequires: pkgconfig(libosmocoding) >= 1.0.0
36%{?systemd_requires}
37
38%description
39OsmoMGW is Osmocom's Media Gateway for 2G and 3G circuit-switched mobile networks.
40
41%package -n libosmo-mgcp-client6
42Summary: Osmocom's Media Gateway Control Protocol client library
43Group: System/Libraries
44
45%description -n libosmo-mgcp-client6
46Osmocom's Media Gateway Control Protocol client library.
47
48%package -n libosmo-mgcp-client-devel
49Summary: Development files for Osmocom's Media Gateway Control Protocol client library
50Group: Development/Libraries/C and C++
51Requires: libosmo-mgcp-client6 = %{version}
52
53%description -n libosmo-mgcp-client-devel
54Osmocom's Media Gateway Control Protocol client librarary.
55
56This subpackage contains libraries and header files for developing
57applications that want to make use of libosmo-mgcp-client.
58
59%package -n libosmo-mgcp-devel
60Summary: Development files for Osmocom's Media Gateway server library
61Group: Development/Libraries/C and C++
62
63%description -n libosmo-mgcp-devel
64Osmocom's Media Gateway Control Protocol server library.
65
66This subpackage contains libraries and header files for developing
67applications that want to make use of libosmo-mgcp.
68
69%prep
70%setup -q
71
72%build
73echo "%{version}" >.tarball-version
74autoreconf -fi
75%configure \
76 --disable-static \
77 --docdir=%{_docdir}/%{name} \
78 --with-systemdsystemunitdir=%{_unitdir}
79
80make %{?_smp_mflags}
81
82%install
83%make_install
84find %{buildroot} -type f -name "*.la" -delete -print
85
86%check
87make %{?_smp_mflags} check || (find . -name testsuite.log -exec cat {} +)
88
89%post -n libosmo-mgcp-client6 -p /sbin/ldconfig
90%postun -n libosmo-mgcp-client6 -p /sbin/ldconfig
91%preun
92%service_del_preun osmo-mgw.service
93
94%postun
95%service_del_postun osmo-mgw.service
96
97%pre
98%service_add_pre osmo-mgw.service
99
100%post
101%service_add_post osmo-mgw.service
102
103%files
104%license COPYING
105%doc AUTHORS README
106%dir %{_docdir}/%{name}/examples
107%dir %{_docdir}/%{name}/examples/osmo-mgw
108%{_docdir}/%{name}/examples/osmo-mgw/osmo-mgw.cfg
109%{_bindir}/osmo-mgw
110%{_unitdir}/osmo-mgw.service
111%dir %{_sysconfdir}/osmocom
112%config %{_sysconfdir}/osmocom/osmo-mgw.cfg
113
114%files -n libosmo-mgcp-client6
115%{_libdir}/libosmo-mgcp-client.so.6*
116
117%files -n libosmo-mgcp-client-devel
118%{_libdir}/libosmo-mgcp-client.so
119%{_libdir}/pkgconfig/libosmo-mgcp-client.pc
120%dir %{_includedir}/osmocom
121%dir %{_includedir}/osmocom/mgcp_client
122%{_includedir}/osmocom/mgcp_client/*.h
123
124%files -n libosmo-mgcp-devel
125%dir %{_includedir}/osmocom
126%dir %{_includedir}/osmocom/mgcp
127%{_includedir}/osmocom/mgcp/*.h
128
129%changelog