blob: d38898d816128c34df7e7b0c1d211f64f35c6c24 [file] [log] [blame]
Harald Welte640d72a2010-08-24 15:33:04 +02001#!/usr/bin/make -f
Alexander Couzensbf0ab742017-08-07 07:55:28 +00002# You must remove unused comment lines for the released package.
3# See debhelper(7) (uncomment to enable)
4# This is an autogenerated template for debian/rules.
5#
6# Output every command that modifies files on the build system.
7#export DH_VERBOSE = 1
Harald Welte640d72a2010-08-24 15:33:04 +02008
Alexander Couzensbf0ab742017-08-07 07:55:28 +00009DEBIAN := $(shell dpkg-parsechangelog | grep '^Version:' | cut -d' ' -f2)
Eric Butler010c9552012-08-14 21:01:20 -070010DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
11VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
12
Alexander Couzens32330aa2017-09-14 03:00:20 +000013CFLAGS += -g
14
Alexander Couzensbf0ab742017-08-07 07:55:28 +000015# main packaging script based on dh7 syntax
Harald Welte640d72a2010-08-24 15:33:04 +020016%:
Pau Espin Pedrole6866752018-09-10 12:46:47 +020017 dh $@ --with autoreconf
Eric Butlera73ca052012-08-14 17:40:58 -070018
Alexander Couzensbf0ab742017-08-07 07:55:28 +000019# debmake generated override targets
20# Set options for ./configure
21#CONFIGURE_FLAGS = <options for ./configure>
22#overrride_dh_configure:
23# dh_configure -- $(CONFIGURE_FLAGS)
24#
25# Do not install libtool archive, python .pyc .pyo
26#override_dh_install:
27# dh_install --list-missing -X.la -X.pyc -X.pyo
28
Alexander Couzensc5ecebb2017-10-11 06:05:33 +020029override_dh_auto_test:
30 dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
31
Pau Espin Pedrole6866752018-09-10 12:46:47 +020032override_dh_auto_configure:
Oliver Smithf6387dc2019-05-22 13:43:57 +020033 dh_auto_configure -- --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
34
35# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
36override_dh_compress:
37 dh_compress -X.pdf
Pau Espin Pedrole6866752018-09-10 12:46:47 +020038
Alexander Couzensbf0ab742017-08-07 07:55:28 +000039# See https://www.debian.org/doc/manuals/developers-reference/best-pkging-practices.html#bpp-dbg