blob: e2abd35d53e4f7d4ad824e4d6ddd168ede016ddf [file] [log] [blame]
Oliver Smith0e3a0272020-05-14 11:46:12 +02001#
2# spec file for package osmo-iuh
3#
4# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
5#
6# All modifications and additions to the file contributed by third parties
7# remain the property of their copyright owners, unless otherwise agreed
8# upon. The license for this file, and modifications and additions to the
9# file, is the same license as for the pristine package itself (unless the
10# license for the pristine package is not an Open Source License, in which
11# case the license is the MIT License). An "Open Source License" is a
12# license that conforms to the Open Source Definition (Version 1.9)
13# published by the Open Source Initiative.
14
15# Please submit bugfixes or comments via http://bugs.opensuse.org/
16#
17
18
19Name: osmo-iuh
20Version: 0.6.0.13
21Release: 0
22Summary: Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
23License: AGPL-3.0-or-later AND GPL-2.0-or-later
24Group: Hardware/Mobile
25URL: https://osmocom.org/projects/osmohnbgw/wiki
26Source: %{name}-%{version}.tar.xz
27BuildRequires: automake >= 1.9
28BuildRequires: libtool >= 2
29BuildRequires: lksctp-tools-devel
30BuildRequires: pkgconfig >= 0.20
31# python3 for asn1tostruct.py
32BuildRequires: python3
33BuildRequires: pkgconfig(libasn1c) >= 0.9.30
34BuildRequires: pkgconfig(libosmo-netif) >= 0.3.0
35BuildRequires: pkgconfig(libosmo-sigtran) >= 0.10.0
36BuildRequires: pkgconfig(libosmocore) >= 0.12.0
37BuildRequires: pkgconfig(libosmoctrl) >= 0.12.0
38BuildRequires: pkgconfig(libosmogb)
39BuildRequires: pkgconfig(libosmogsm) >= 0.12.0
40BuildRequires: pkgconfig(libosmovty) >= 0.12.0
41
42%description
43Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
44
45%package -n libosmo-ranap3
46Summary: Shared Library part of libosmo-ranap
47Group: System/Libraries
48
49%description -n libosmo-ranap3
50Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
51
52%package -n libosmo-ranap-devel
53Summary: Development files for Osmocom RANAP library
54Group: Development/Libraries/C and C++
55Requires: libosmo-ranap3 = %{version}
56
57%description -n libosmo-ranap-devel
58Osmocom code for the Iuh interface (HNBAP, RUA, RANAP)
59
60This subpackage contains libraries and header files for developing
61applications that want to make use of libosmoranap.
62
63
64%package -n libosmo-sabp0
65Summary: Shared Library part of libosmo-sabp
66Group: System/Libraries
67
68%description -n libosmo-sabp0
69Osmocom code for the SABP (service area broadcast protocol) interface
70
71%package -n libosmo-sabp-devel
72Summary: Development files for Osmocom SABP library
73Group: Development/Libraries/C and C++
74Requires: libosmo-sabp0 = %{version}
75
76%description -n libosmo-sabp-devel
77Osmocom code for the SABP (service area broadcast protocol) interface
78
79This subpackage contains libraries and header files for developing
80applications that want to make use of libosmo-sabp.
81
82
83%prep
84%setup -q
85
86%build
87echo "%{version}" >.tarball-version
88autoreconf -fi
89%configure \
90 --disable-static \
91 --docdir="%{_docdir}/%{name}" \
92 --with-systemdsystemunitdir=%{_unitdir}
93make %{?_smp_mflags}
94
95%install
96%make_install
97find %{buildroot} -type f -name "*.la" -delete -print
98
99%check
100make %{?_smp_mflags} check || (find . -name testsuite.log -exec cat {} +)
101
102%post -n libosmo-ranap3 -p /sbin/ldconfig
103%postun -n libosmo-ranap3 -p /sbin/ldconfig
104%post -n libosmo-sabp0 -p /sbin/ldconfig
105%postun -n libosmo-sabp0 -p /sbin/ldconfig
106%pre %service_add_pre osmo-hnbgw.service
107%post %service_add_post osmo-hnbgw.service
108%preun %service_del_preun osmo-hnbgw.service
109%postun %service_del_postun osmo-hnbgw.service
110
111%files
112%license COPYING
113%doc README.md
114%dir %{_docdir}/%{name}/examples
115%{_docdir}/%{name}/examples/osmo-hnbgw.cfg
116%{_bindir}/osmo-hnbgw
117%dir %{_sysconfdir}/osmocom
118%config %{_sysconfdir}/osmocom/osmo-hnbgw.cfg
119%{_unitdir}/osmo-hnbgw.service
120
121%files -n libosmo-ranap3
122%{_libdir}/libosmo-ranap.so.3*
123
124%files -n libosmo-ranap-devel
125%{_includedir}/*
126%{_libdir}/libosmo-ranap.so
127%{_libdir}/pkgconfig/libosmo-ranap.pc
128
129%files -n libosmo-sabp0
130%{_libdir}/libosmo-sabp.so.0*
131
132%files -n libosmo-sabp-devel
133%{_libdir}/libosmo-sabp.so
134%{_libdir}/pkgconfig/libosmo-sabp.pc
135
136%changelog