blob: 3b5a9fa97ebe3930b4fc80ab4c102aa67bfb9732 [file] [log] [blame]
Oliver Smith2f7fb2e2020-05-14 11:45:19 +02001#
2# spec file for package osmo-hlr
3#
4# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
5# Copyright (c) 2016, Martin Hauke <mardnh@gmx.de>
6#
7# All modifications and additions to the file contributed by third parties
8# remain the property of their copyright owners, unless otherwise agreed
9# upon. The license for this file, and modifications and additions to the
10# file, is the same license as for the pristine package itself (unless the
11# license for the pristine package is not an Open Source License, in which
12# case the license is the MIT License). An "Open Source License" is a
13# license that conforms to the Open Source Definition (Version 1.9)
14# published by the Open Source Initiative.
15
16# Please submit bugfixes or comments via http://bugs.opensuse.org/
17#
18
19
20Name: osmo-hlr
21Version: 1.2.0.48
22Release: 0
23Summary: Osmocom Home Location Register for GSUP protocol towards OsmoSGSN and OsmoCSCN
24License: AGPL-3.0-or-later AND GPL-2.0-or-later
25Group: Productivity/Telephony/Servers
26URL: https://projects.osmocom.org/projects/osmo-hlr
27Source: %{name}-%{version}.tar.xz
28BuildRequires: autoconf
29BuildRequires: automake
30BuildRequires: libtool
31BuildRequires: pkgconfig >= 0.20
32BuildRequires: python2
33BuildRequires: systemd-rpm-macros
34BuildRequires: pkgconfig(libosmoabis) >= 0.6.0
35BuildRequires: pkgconfig(libosmocore) >= 1.2.0
36BuildRequires: pkgconfig(libosmoctrl) >= 1.2.0
37BuildRequires: pkgconfig(libosmogsm) >= 1.2.0
38BuildRequires: pkgconfig(libosmovty) >= 1.2.0
39BuildRequires: pkgconfig(sqlite3)
40BuildRequires: pkgconfig(talloc) >= 2.0.1
41# only needed for populate_hlr_db.pl
42Requires: libdbi-drivers-dbd-sqlite3
43
44%description
45The GSUP HLR is a stand-alone HLR (Home Location Register) for SIM
46and USIM based subscribers which exposes the GSUP protocol towards
47its users. OsmoSGSN supports this protocol.
48
49osmo-gsup-hlr is still very simplistic. It is a single-threaded
50architecture and uses only sqlite3 tables as back-end. It is suitable
51for installations of the scale that OsmoNITB was able to handle. It
52also lacks various features like fine-grained control of subscribed
53services (like supplementary services).
54
55%package -n libosmo-gsup-client0
56Summary: Osmocom GSUP (General Subscriber Update Protocol) client library
57License: GPL-2.0-or-later
58Group: System/Libraries
59
60%description -n libosmo-gsup-client0
61This is a shared library that can be used to implement client programs for
62the GSUP protocol. The typical GSUP server is OsmoHLR, with OsmoMSC, OsmoSGSN
63and External USSD Entities (EUSEs) using this library to implement clients.
64
65%package -n libosmo-gsup-client-devel
66Summary: Development files for the Osmocom GSUP client library
67License: GPL-2.0-or-later
68Group: Development/Libraries/C and C++
69Requires: libosmo-gsup-client0 = %{version}
70
71%description -n libosmo-gsup-client-devel
72This is a shared library that can be used to implement client programs for
73the GSUP protocol. The typical GSUP server is OsmoHLR, with OsmoMSC, OsmoSGSN
74and External USSD Entities (EUSEs) using this library to implement clients.
75
76This subpackage contains libraries and header files for developing
77applications that want to make use of libosmo-gsup-client.
78
79%package -n libosmo-mslookup0
80Summary: Osmocom MS lookup library
81License: GPL-2.0-or-later
82Group: System/Libraries
83
84%description -n libosmo-mslookup0
85This shared library contains routines for looking up mobile subscribers.
86
87%package -n libosmo-mslookup-devel
88Summary: Development files for the Osmocom MS lookup library
89License: GPL-2.0-or-later
90Group: Development/Libraries/C and C++
91Requires: libosmo-mslookup0 = %{version}
92
93%description -n libosmo-mslookup-devel
94This shared library contains routines for looking up mobile subscribers.
95
96This subpackage contains libraries and header files for developing
97applications that want to make use of libosmo-mslookup.
98
99
100%package -n osmo-mslookup-client
101Summary: Standalone program using libosmo-mslookup
102License: GPL-2.0-or-later
103Group: Development/Libraries/C and C++
104
105%description -n osmo-mslookup-client
106Standalone program using libosmo-mslookup to easily integrate with programs
107that want to connect services (SIP, SMS,...) to the current location of a
108subscriber.
109
110%prep
111%setup -q
112
113%build
114echo "%{version}" >.tarball-version
115autoreconf -fi
116%configure \
117 --docdir="%{_docdir}/%{name}" \
118 --with-systemdsystemunitdir=%{_unitdir} \
119 --enable-shared \
120 --disable-static
121make V=1 %{?_smp_mflags}
122
123%install
124%make_install
125install -d "%{buildroot}/%{_localstatedir}/lib/osmocom"
126find %{buildroot} -type f -name "*.la" -delete -print
127
128%check
129make %{?_smp_mflags} check || (find . -name testsuite.log -exec cat {} +)
130
131%preun
132%service_del_preun %{name}.service
133
134%postun
135%service_del_postun %{name}.service
136
137%pre
138%service_add_pre %{name}.service
139
140%post
141%service_add_post %{name}.service
142
143%post -n libosmo-gsup-client0 -p /sbin/ldconfig
144%postun -n libosmo-gsup-client0 -p /sbin/ldconfig
145%post -n libosmo-mslookup0 -p /sbin/ldconfig
146%postun -n libosmo-mslookup0 -p /sbin/ldconfig
147
148%files
149%license COPYING
150%dir %{_docdir}/%{name}
151%dir %{_docdir}/%{name}/examples
152%{_docdir}/%{name}/examples/osmo-hlr.cfg
153%{_docdir}/%{name}/examples/osmo-hlr-dgsm.cfg
154%dir %{_docdir}/%{name}/sql
155%{_docdir}/%{name}/sql/hlr.sql
156%{_docdir}/%{name}/sql//hlr_data.sql
157%dir %{_sysconfdir}/osmocom
158%dir %{_localstatedir}/lib/osmocom
159%{_bindir}/osmo-hlr
160%{_bindir}/osmo-hlr-db-tool
161%dir %{_sysconfdir}/osmocom
162%config %{_sysconfdir}/osmocom/osmo-hlr.cfg
163%{_unitdir}/osmo-hlr.service
164
165%files -n libosmo-gsup-client0
166%{_libdir}/libosmo-gsup-client.so.0*
167
168%files -n libosmo-gsup-client-devel
169%{_bindir}/osmo-euse-demo
170%dir %{_includedir}/osmocom
171%dir %{_includedir}/osmocom/gsupclient
172%{_includedir}/osmocom/gsupclient/*.h
173%{_libdir}/libosmo-gsup-client.so
174%{_libdir}/pkgconfig/libosmo-gsup-client.pc
175
176%files -n libosmo-mslookup0
177%{_libdir}/libosmo-mslookup.so.0*
178
179%files -n libosmo-mslookup-devel
180%dir %{_includedir}/osmocom
181%dir %{_includedir}/osmocom/mslookup
182%{_includedir}/osmocom/mslookup/*.h
183%{_libdir}/libosmo-mslookup.so
184%{_libdir}/pkgconfig/libosmo-mslookup.pc
185
186%files -n osmo-mslookup-client
187%{_bindir}/osmo-mslookup-client
188
189%changelog