blob: aa95e280ee3959935b7ed9d574319b51b371e7c6 [file] [log] [blame]
Harald Weltee9168092010-08-24 15:23:33 +02001#!/usr/bin/make -f
Harald Weltee9168092010-08-24 15:23:33 +02002
3# Uncomment this to turn on verbose mode.
4#export DH_VERBOSE=1
5
Harald Welte367baa32017-08-13 09:41:33 +02006DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
7DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
8VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
9
Harald Weltee9168092010-08-24 15:23:33 +020010# This has to be exported to make some magic below work.
Holger Hans Peter Freyther0576f3b2015-03-14 20:17:19 +010011#export DH_OPTIONS
Max77168602016-12-21 17:57:40 +010012export DEB_BUILD_MAINT_OPTIONS = hardening=+all
Harald Weltee9168092010-08-24 15:23:33 +020013
Harald Weltee9168092010-08-24 15:23:33 +020014%:
Holger Hans Peter Freyther0576f3b2015-03-14 20:17:19 +010015 dh $@ --with autoreconf
Holger Hans Peter Freytherf97f58d2014-09-23 16:52:19 +020016
17override_dh_strip:
18 dh_strip --dbg-package=openggsn-dbg
Harald Welte23eea1d2017-08-11 13:47:24 +020019
20override_dh_autoreconf:
21 echo $(VERSION) > .tarball-version
22 dh_autoreconf