blob: 62f5236333c9f6620690f2d4f0858938fa3a531d [file] [log] [blame]
Harald Weltee9168092010-08-24 15:23:33 +02001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4#
5# This file was originally written by Joey Hess and Craig Small.
6# As a special exception, when this file is copied by dh-make into a
7# dh-make output file, you may use that output file without restriction.
8# This special exception was added by Craig Small in version 0.37 of dh-make.
9#
10# Modified to make a template file for a multi-binary package with separated
11# build-arch and build-indep targets by Bill Allombert 2001
12
13# Uncomment this to turn on verbose mode.
14#export DH_VERBOSE=1
15
16# This has to be exported to make some magic below work.
Holger Hans Peter Freyther0576f3b2015-03-14 20:17:19 +010017#export DH_OPTIONS
Holger Hans Peter Freytherf97f58d2014-09-23 16:52:19 +020018export DEB_BUILD_HARDENING=1
Harald Weltee9168092010-08-24 15:23:33 +020019
Harald Weltee9168092010-08-24 15:23:33 +020020%:
Holger Hans Peter Freyther0576f3b2015-03-14 20:17:19 +010021 dh $@ --with autoreconf
Holger Hans Peter Freytherf97f58d2014-09-23 16:52:19 +020022
23override_dh_strip:
24 dh_strip --dbg-package=openggsn-dbg