blob: 34ef3e7d94540472061fd261635466e9552c60f7 [file] [log] [blame]
Harald Welte95f42062010-08-24 15:33:04 +02001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4#
5# This file was originally written by Joey Hess and Craig Small.
6# As a special exception, when this file is copied by dh-make into a
7# dh-make output file, you may use that output file without restriction.
8# This special exception was added by Craig Small in version 0.37 of dh-make.
9#
10# Modified to make a template file for a multi-binary package with separated
11# build-arch and build-indep targets by Bill Allombert 2001
12
13# Uncomment this to turn on verbose mode.
14#export DH_VERBOSE=1
15
Eric Butlerf04324a2012-08-14 21:01:20 -070016DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
17DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
18VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
19
Harald Welte95f42062010-08-24 15:33:04 +020020%:
Eric Butler37074482012-08-14 17:40:58 -070021 dh --with autoreconf $@
22
23override_dh_auto_configure:
Eric Butlerf04324a2012-08-14 21:01:20 -070024 echo $(VERSION) > .tarball-version
Eric Butler37074482012-08-14 17:40:58 -070025 dh_auto_configure -- --enable-nat --enable-osmo-bsc
26
27override_dh_auto_test:
28# tests are broken...