blob: 54617450db7ec794c804726e043aa72e1787820f [file] [log] [blame]
Harald Weltee250eaa2019-01-23 18:32:41 +01001osmo-sgsn (1.4.0) unstable; urgency=medium
2
3 [ Alexander Couzens ]
4 * gprs_subscriber: gsup_auth_error: reject MS in all cases
5 * gprs_gmm: make functions relating to GMM Attach Request public
6 * gprs_gmm: make extract_subscr_msisdn extract_subscr_hlr public
7 * gprs_gmm: Cancel Location: use detach type IMSI
8 * vty: add cmd "reset sgsn state"
9 * tests: remove gmm unit tests
10 * gprs_gmm: introduce a GMM Attach Request FSM
11 * debian: add missing build dependencies
12 * sgsn: use gtp_clear_queues() when reset sgsn state
13 * vty: restart sgsn state: improve output message
14 * sgsn_ggsn_ctx_drop_pdp: protect against nullpointer when MM is gone
15 * gprs_sgsn.h: fix wrong type of re-attempts
16 * GTP: refactor the echo timer
17 * gprs_gmm: dont answer unknown IMSI/TMSI on Service Requests NET_FAIL
18 * gprs_gmm: Fix missing Security Command for 3G when attaching
19 * sgsn_libgtp: fix a potential memleak when the GGSN is not reachable
20 * gprs_llc: remove the FCS from the msgb by trim'ing the msgb
21 * OsmoSGSN: add rate counter documentation
22
23 [ Daniel Willmann ]
24 * gb_proxy: tallocate memory for gbproxy cfg so it can be a talloc ctx
25 * gb_proxy: Add ctrl interface and nsvc-state, gbproxy-state commands
26 * git-version-gen: Don't check for .git directory
27
28 [ Stefan Sperling ]
29 * add a test for OS#3178 (invalid unitdata message)
30 * finish gbproxy_parse_bssgp_unitdata test
31 * fix bogus assertion in encode_comp_field()
32 * fix bogus error check in gprs_sndcp_comp_create()
33 * use enums consistently instead of falling back to int
34 * update gbproxy test expected output
35 * consistently check the result of osmo_shift_v_fixed()
36 * remove pointless declaration of struct gsm_network
37 * make gsup ipa name configurable in osmo-sgsn.cfg
38
39 [ Pau Espin Pedrol ]
40 * jenkins.sh: Use --enable-werror only when iu support is disabled
41 * jenkins.sh: Remove non-existent configure options
42 * Drop all references of unused SMPP
43 * Drop all references of unused MGCP
44 * Drop unused common_vty.c
45 * sgsn_libgtp.c: Log pointer of deleted context
46 * Maintain per ggsn pdp ctx list
47 * osmo-sgsn: ping GGSN periodically and check for restart counter
48 * Disarm T3395 when dettaching mmctx from pdpctx
49 * examples: Enable by default echo req towards active GGSNs
50 * vty: Add cmd to disable echo loop explictly
51 * Add optional TearDownInd IE in PDP DEACT REQ towards PCU
52 * sgsn: Don't attempt to delete GTP pdp ctx if GGSN was restarted
53 * Forward GGSN originated DEACT PDP CTX REQ
54 * sgsn: Fix T3395 firing forever
55 * sgsn: subscriber: Avoid calling memcpy with NULL src
56 * sgsn: cdr: Fix uninitialized string access if ggsn is detached
57 * sgsn: gtp: Use new API to send PDP DEL CTX REQ without freeing ctx locally
58 * sgsn: Fix crash using new libgtp cb_recovery2 API
59 * gbproxy: Replace '.' in counter names with ':'
60 * Drop gprs_msgb_copy with libosmocore replacement
61 * Drop gprs_msgb_resize_area with libosmocore replacement
62 * Use osmo_clock_gettime from libosmocore
63 * gbproxy: Add VTY parameter: link stored-msgs-max-length
64 * gbproxy: Add new VTY-managed timer: link-list clean-stale-timer
65 * gbproxy: Replace '.' in counter names with ':'
66 * Add osmo-gtphub systemd service file
67 * debian: Fix typo in rules preventing build with IU support
68 * Install systemd services with autotools
69 * Install sample cfg file to /etc/osmocom
70 * Update wrong references to bsc in sgsn code
71 * Allocate sgsn_instance with talloc
72 * gbproxy: flag gbproxy_assign_imsi as static
73 * gbproxy: Fix abort during APN patch
74 * gbproxy: Remove unneeded parse_ctx param
75 * gbproxy: flush_stored_messages: Move comment to func description
76 * gbproxy: flush_stored_messages: Log and route using stored_msg info
77 * gbproxy: flush_stored_messages: Get rid of msg param
78 * Allow easily disabling GFDL references
79 * OsmoSGSN: configuration: Move pdp ctx specific CDR fields to its own table
80 * OsmoSGSN: configuration: Add missing pdp-periodic event
81 * OsmoSGSN: configuration: Document CDR CTRL interface
82 * OsmoSGSN: overview: Fix typo and reference OpenGGSN->OsmoGGSN
83
84 [ Harald Welte ]
85 * migrate to oap_client in libosmogsm
86 * remove libcommon
87 * gbproxy-legacy: Ensure well-formed config file
88 * Remove local libgsupclient; Use libosmo-gsup-client from osmo-hlr
89 * initial checkin of manuals to public repo
90 * Add link to Asciidoc source code of manual
91 * OsmoSGSN: Fix formatting/cross reference in CDR section
92 * Update GSUP chapter regarding UMTS AKA and other recent changes
93 * GSUP: Add ladder diagrams for protocol transactions / procedures
94 * share chapters/gsup.adoc from OsmoSGSN to OsmoMSC + OsmoHLR
95 * vty-ref: Update URI of docbook 5.0 schema
96
97 [ Neels Hofmeyr ]
98 * use __FILE__, not __BASE_FILE__
99 * vty: fix doc str for 'reset sgsn state'
100 * vty: add SCCP related vty commands
101 * fix build: remove unused variable
102 * Importing history from osmo-gsm-manuals.git
103 * add 'make check' target
104 * fix 'make clean': shell glob, ignore failure
105 * refactor Makefile build rules, don't use the FORCE
106 * OsmoSGSN: update VTY reference
107 * sgsn: update vty reference
108
109 [ Oliver Smith ]
110 * gtphub: Add --version cmdline option
111 * build manuals moved here from osmo-gsm-manuals.git
112 * Fix DISTCHECK_CONFIGURE_FLAGS override
113 * contrib/jenkins.sh: build and publish manuals
114 * contrib: fix makedistcheck with disabled systemd
115
116 [ Max ]
117 * Cleanup non-existent files from debian/copyright
118 * Use safer functions for IMSI ACL
119 * gbproxy: fix formatting in gbproxy-state command
120 * gbproxy: add number-of-peers ctrl command
121 * Revert "gbproxy: fix formatting in gbproxy-state command"
122 * Add OsmoSGSN control interface description
123 * Remove misleading comment
124 * Constify sgsn_acl_lookup() parameter
125 * Drop unused osmo-sgsn.pc
126 * Use explicit length check
127 * Use explicit parameter for sgsn_auth_init()
128
129 [ Jonathan Brielmaier ]
130 * fix various typos across all manuals
131
132 [ ikostov ]
133 * SGSN: add Auth. policy, NS Statistics and BSSGP state examples, tweaks
134 * GSUP, OAP: fix AUTS length to 14, not 16
135
136 [ Philipp Maier ]
137 * osmo-sgsn: Update VTY command reference
138 * osmo-sgsn: improve auth-policy explaination
139 * osmo-sgsn: Explain TCP/IP header compression
140 * osmo-sgsn: fix arrow tips in flow diagrams
141
142 [ Holger Hans Peter Freyther ]
143 * sgsn: Fix numbering of QoS and add basic description for APN
144 * sgsn: Add charging characteristics to GSUP
145
146 -- Harald Welte <laforge@gnumonks.org> Wed, 23 Jan 2019 18:32:41 +0100
147
Pau Espin Pedrol54936e92018-05-03 19:01:44 +0200148osmo-sgsn (1.3.0) unstable; urgency=medium
149
150 [ Neels Hofmeyr ]
151 * drop osmo_sgsn.cfg from src/gprs dir
152 * change default config filename to osmo-sgsn.cfg, not osmo_sgsn.cfg
153 * vty: skip installing cmds now always installed by default
154 * add --enable-sanitize config option
155 * use default point-code as listed on Point_Codes wiki page
156 * gprs_gmm: segfault: gracefully handle failure to alloc context
157 * gsm48_rx_gmm_att_req: fix error handling: don't clean up NULL llme
158 * gprs_llc: tx dl ud: make mismatching LLE not crash osmo-sgsn
159 * fix build: missing LIBGTP_CFLAGS in sgsn_test
160 * sgsn_test: guard against struct gprs_ra_id changing
161 * vty: absorb command explanations from osmo-gsm-manuals
162 * configure: add --enable-werror
163 * implement support for 3-digit MNC with leading zeros
164 * osmo-gbproxy: use 'osmo-gbproxy.cfg' as default config name
165 * compiler warnings: use enum ranap_nsap_addr_enc, constify local var
166 * use osmo_init_logging2(), fix regression test memleaks
167 * auth+ciph: log is_r99 and auth types
168 * log two RA Update Request failure causes
169 * GERAN: allow GSM SRES on UMTS AKA challenge
170
171 [ Alexander Couzens ]
172 * .gitignore: remove unneeded ignores of bsc/msc/nitb files
173 * tests/ctrl_test_runner.py: remove BSC/NAT TestRunner
174 * debian: remove doublicated project name in example files
175 * .gitignore: remove non-existent /src/utils exludes
176 * configure.ac: remove pcap check
177 * configure.ac: remove unused libcdk check
178 * .service: remove OpenBSC from service desription
179 * mandatory depend on libc-ares and libgtp
180 * GMM: dont reply to GMM_DETACH_REQ with POWER OFF when MS is unknown
181
182 [ Harald Welte ]
183 * Replace '.' in counter names with ':'
184 * Add talloc context introspection via VTY
185
186 [ Pau Espin Pedrol ]
187 * Replace '.' in counter names with ':'
188 * tests: Fix selection of python version
189 * sgsn_cdr: Split log formatting into a snprintf function
190 * Add vty cmd 'cdr trap' to send CDR through CTRL iface
191 * tests: sgsn_test: Define wrap APIs with correct parameters
192 * cosmetic: tests: sgsn_test: Use proper formatting and remove uneeded semicolons
193 * gprs_gmm: Remove unused variable
194 * cosmetic: gprs_gmm: Remove trailing whitespace
195 * gprs_gmm: Convert warning message to pragma message
196 * configure.ac: Enable Wall in CFLAGS
197 * .gitignore: Add m4 files
198 * sgsn_libgtp.c: Fix typos and whitespace
199
200 [ Max ]
201 * Fix display of GTP addresses
202 * Show GTP version for PDP context in vty
203 * Remove unneeded .py scripts
204 * Replace '.' in counter names with ':'
205 * Remove dead code
206 * Enable sanitize for CI tests
207 * cosmetic: use macro for gtphub plane iteration
208 * Use connection id when allocating rate counters
209 * Migrate from OpenSSL to osmo_get_rand_id()
210 * Remove obsolete ./configure option
211 * Fix RAI construction
212 * gtphub: make rate_ctr unique
213 * Remove unused bsc_version.c
214 * Use gsm48_encode_ra() for RAI encoding
215 * gtphub: check for gsn_addr_from_sockaddr() errors
216 * gtphub: check for gsn_addr_from_sockaddr() error
217
218 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 19:01:44 +0200
219
Harald Welte5641e9d2017-10-28 19:07:48 +0200220osmo-sgsn (1.2.0) unstable; urgency=medium
221
222 [ Neels Hofmeyr ]
223 * jenkins: fix build: remove unused dependencies
224 * debian: fix osmo-sgsn.install, tweak VCS link and descriptions
225 * drop files unrelated to osmo-sgsn
226 * rewrite README
227 * configure.ac: set name to osmo-sgsn, fix ML addr
228 * move openbsc.pc to osmo-sgsn.pc
229 * move include/openbsc to include/osmocom/sgsn
230 * jenkins.sh: fix echo string to say osmo-sgsn, not msc
231 * jenkins: use osmo-clean-workspace.sh before and after build
232
233 [ Alexander Couzens ]
234 * debian: fix paths of examples
235 * debian/rules: show testsuite.log when tests are failing
236
237 [ Max ]
238 * Remove rest_octets.h
239 * gbproxy: ensure peer allocation result
240 * jenkins: use osmo-ggsn for tests
241 * Cleanup configure checks
242 * Use extended logging for PDP contexts
243 * deb: fix copyright file issues
244 * Move P-TMSI alloc/update into separate function
245 * Check for correct P-TMSI allocation
246 * Use new FSF address in license header
247 * SGSN: uncomment BSSGP vty tests
248 * SGSN: print additional GTP-related info
249 * SGSN: check that GSN is created in proper mode
250 * Fix APN printing
251 * Fix build after recent rate_ctr patches
252 * gbproxy: don't link unnecessary
253 * Fix libosmo-sigtran dependency
254 * jenkins: check for IU properly
255 * Log GTP-U endpoints update
256 * Log address on GTP creation
257
258 [ Pau Espin Pedrol ]
259 * Remove unneeded dep libdbi
260
261 [ Philipp Maier ]
262 * log: fix default loglevels
263 * non-iu-build: guard vty libosmo-sigtran function calls.
264 * configure: fix libosmo-sigtran dependency
265
266 [ Harald Welte ]
267 * Debian: Add systemd service files for osmo-sgsn and osmo-gbproxy
268 * Debian: fix dh_strip rules for creating one -dbg per program
269
270 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 19:07:48 +0200
271
Alexander Couzensd040bab2017-08-07 09:48:18 +0000272osmo-sgsn (0.1.0) unstable; urgency=low
Holger Hans Peter Freytherb803b142016-05-24 23:15:12 +0200273
Alexander Couzensd040bab2017-08-07 09:48:18 +0000274 * Initial release.
Holger Hans Peter Freytherb803b142016-05-24 23:15:12 +0200275
Alexander Couzensd040bab2017-08-07 09:48:18 +0000276 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:13:05 +0000