blob: 06a570e616f4bb46558d6af4f6f85ee949e5ad2d [file] [log] [blame]
Oliver Smitha8fa5672021-02-15 12:07:24 +01001osmo-gbproxy (1:0.0.1) unstable; urgency=medium
Oliver Smith33855062021-02-05 11:42:48 +01002
3 [ Harald Welte ]
4 * Further clean-up in osmo-sgsn -> osmo-gbproxy migration
5 * Update README to cover osmo-gbproxy and not osmo-sgsn
6
7 [ Oliver Smith ]
8 * contrib/jenkins.sh: adjust to osmo-gbproxy split
9 * debian: fix installing pdfs for -doc package
10 * contrib/osmo-gbproxy.spec.in: fix config paths
11
12 -- Oliver Smith <osmith@sysmocom.de> Fri, 05 Feb 2021 11:42:48 +0100
13
Oliver Smitha8fa5672021-02-15 12:07:24 +010014osmo-gbproxy (1:0.0.0) unstable; urgency=medium
Pau Espin Pedrol379e75a2020-01-03 19:17:56 +010015
Oliver Smith29532c22021-01-29 11:13:00 +010016 [ Neels Hofmeyr ]
17 * manual: explain IuPS, add SCCP/M3UA section from common chapters
Pau Espin Pedrol379e75a2020-01-03 19:17:56 +010018
Oliver Smith29532c22021-01-29 11:13:00 +010019 [ Eric ]
20 * tests: dlopen does not imply availability of dlsym..
21 * configure.ac: fix libtool issue with clang and sanitizer
Pau Espin Pedrol379e75a2020-01-03 19:17:56 +010022
23 [ Harald Welte ]
Oliver Smith29532c22021-01-29 11:13:00 +010024 * gtphub_test: Fix compilation with gcc-10
Pau Espin Pedrol379e75a2020-01-03 19:17:56 +010025
26 [ Oliver Smith ]
Oliver Smith29532c22021-01-29 11:13:00 +010027 * contrib: import RPM spec
28 * contrib: integrate RPM spec
29 * Makefile.am: EXTRA_DIST: debian, contrib/*.spec.in
Pau Espin Pedrol379e75a2020-01-03 19:17:56 +010030
Oliver Smith29532c22021-01-29 11:13:00 +010031 [ Neels Hofmeyr ]
32 * gbproxy_test.c: fix mobile identity test data
33 * use new osmo_mobile_identity API everywhere
Pau Espin Pedroleab9d382019-08-08 16:46:31 +020034
35 [ Harald Welte ]
Oliver Smith29532c22021-01-29 11:13:00 +010036 * *.spec.in: Use %config(noreplace) to retain current config file
Pau Espin Pedroleab9d382019-08-08 16:46:31 +020037
38 [ Alexander Couzens ]
Oliver Smith29532c22021-01-29 11:13:00 +010039 * gtphub: rename sgsn's oww osmo_sockaddr into sgsn_sockaddr
40
41 [ Vadim Yanitskiy ]
42 * debian/control: change maintainer to the Osmocom team / mailing list
Pau Espin Pedroleab9d382019-08-08 16:46:31 +020043
44 [ Pau Espin Pedrol ]
Oliver Smith29532c22021-01-29 11:13:00 +010045 * configure.ac: Fix trailing whitespace
46 * doc: Update VTY reference xml file
47 * Support setting rt-prio and cpu-affinity mask through VTY
48
49 [ Daniel Willmann ]
50 * gbproxy-usermanual: Explain BSSGP/BVC handling
51
52 [ Alexander Couzens ]
53 * gtphub_test: fix compilation error on gcc 10.2.0
54
55 [ Pau Espin Pedrol ]
56 * contrib/jenkins: Enable parallel make in make distcheck
Pau Espin Pedroleab9d382019-08-08 16:46:31 +020057
58 [ Keith ]
Oliver Smith29532c22021-01-29 11:13:00 +010059 * VTY: Add gtp state-dir command
Pau Espin Pedroleab9d382019-08-08 16:46:31 +020060
Oliver Smith29532c22021-01-29 11:13:00 +010061 [ Alexander Couzens ]
62 * Port gbproxy to NS2
63
64 [ Daniel Willmann ]
65 * gbproxy: Whitespace fixes
66 * gbproxy: Add todo for BVC RESET logic
67 * gbproxy: Get the peer if paging by BVCI on SIG_BVC
68 * Let libosmocore handle VTY parent node tracking
69 * osmo-gbproxy: Free msgb in ns2 prim callback
70 * configure.ac: Require python3 for ext_tests
71 * osmo-gbproxy: Implement nsvc-state ctrl command
72
73 [ Harald Welte ]
74 * gbproxy: Properly implement paging to LAC/RAC
75 * gbproxy: Implement paging to entire BSS area
76
77 [ Pau Espin Pedrol ]
78 * gbproxy: generate coredump and exit upon SIGABRT received
79
80 [ Harald Welte ]
81 * gbproxy: Pass TLLI as LSP towards NS to facilitate load sharing
82 * gb_proxy_peer: Add some FIXMEs regarding invalid assumptions
83
84 [ Daniel Willmann ]
85 * gbproxy: Remove test testing NSVCI change
86 * gbproxy: Add NSE peer that can have multiple gbproxy_peers
87 * gbproxy: Ensure BVC0 is reset before handling PtP BVCs
88 * gbproxy: Only send paging to each matching NSE once
89 * gbproxy: Separate function to move gbproxy_peer to different nse
90
91 [ Harald Welte ]
92 * gb_proxy: More precise + readable log messages
93
94 [ Daniel Willmann ]
95 * gbproxy: Add logging macros for NSE and BVC
96 * gbproxy: Use LOG macros for NSE/BVC
97 * gbproxy: Change generic LOG messages so BVCI/NSEI fmt is consistent
98 * gbproxy: Add todos encountered while going through the code
99
100 [ Harald Welte ]
101 * gb_proxy: Broadcast SGSN-INVOKE-TRACE and OVERLOAD
102 * gbproxy: Move BSS-side BVC-RESET processing to its own function
103 * gb_proxy: Slightly restructure processing of BSS-originated BVC-RESET
104 * gbproxy: Cosmetics: use longer lines
105
106 [ Daniel Willmann ]
107 * gbproxy: Add BVC log filters
108 * gbproxy: Add newline to log message
109 * gbproxy: Allow gbproxy_nse_free(NULL)
110 * gbproxy: Delete gbproxy_nse in delete-gbproxy-peer VTY command
111
112 [ Harald Welte ]
113 * gbproxy: Send BVC-STATUS if BSS sends us BVC-RESET without mandatory IEs
114 * gb_proxy: Use TLVP_PRES_LEN instead of TLVP_PRESENT
115 * gb_proxy: Rename gbproxy_peer to gbproxy_bvc
116 * gbproxy: Rename gbproxy_cfg.nses to gbproxy_cfg.bss_nses
117 * gbproxy: convert bss_nses from llist_head to hashtable
118 * gbproxy: convert nse->bvcs from llist_head to hashtable
119 * gbproxy: Remove patching, TLLI-tracking and SGSN2 support
120 * gb_proxy: cosmetic: Use function rather than open-coding is_sgsn
121 * gbproxy: Delete gbproxy_test
122 * gb_proxy: Introduce more validation / constraint checks
123 * gbproxy: use gbprox_relay2peer() whenever possible
124 * gb_proxy: Use osmo_tlv_prot_parse() to validate mandatory IEs
125 * gbproxy: Log FSM timeouts
126 * migrate to DLBSSGP as log sub-system for BSSGP
127 * gbproxy major rewrite for SGSN pool support
128 * gbproxy: Use "(nsei << 16) | bvci" as rate_ctr_group index
129 * gbproxy: Introduce new DOBJ log category; log object allocation/release
130 * gbproxy: Don't create an extra msgb copy for SGSN DL SIG
131 * gbproxy: Implement handling of BVC Flow Control
132
133 [ Daniel Willmann ]
134 * gbproxy: Fix bvci check in gbprox_rx_ptp_from_*
135
136 [ Harald Welte ]
137 * gbproxy: Copy RA-ID from BSS side BVC to CELL and SGSN-side BVC
138 * gbproxy: (Re)allocate SGSN-side PTP BVC even if CELL already exists
139 * gbproxy: Fix segfault when receiving PAGING for unknown destination
140 * gbproxy: Add FSM related VTY commands
141 * gbproxy: Implement scaling of BVC flow control in SGSN pool
142 * gbproxy: Improve VTY state introspection
143 * gbproxy: rename vty command "show gbproxy ..." to "show gbproxy bvc ..."
144
145 [ Daniel Willmann ]
146 * osmo-gbproxy: Initialize all hash_maps
147 * gbproxy: Fix confusing log message in gbprox_relay2nse
148
149 [ Harald Welte ]
150 * gbproxy: Add "show gbproxy cell ..." VTY command
151
152 [ Daniel Willmann ]
153 * gbproxy: Add SGSN NRI configuration
154 * gbproxy: Add SGSN pooling support
155 * gbproxy: Add comments to sgsn functions
156
157 [ Harald Welte ]
158 * gbproxy: Fix build on Deiban 8
159
160 [ Alexander Couzens ]
161 * sgsn: Use the new NS2 api
162 * gbproxy: use ns2 vty2
163
164 [ Daniel Willmann ]
165 * gbproxy: Add config option to name an SGSN
166 * gbproxy: Add VTY command to override the node selection function
Pau Espin Pedroleab9d382019-08-08 16:46:31 +0200167
168 [ Vadim Yanitskiy ]
Oliver Smith29532c22021-01-29 11:13:00 +0100169 * gb_proxy_peer: sgsn can never be NULL in gbproxy_sgsn_by_nri()
170 * gb_proxy_peer: fix NULL pointer dereference in gbproxy_sgsn_alloc()
Pau Espin Pedroleab9d382019-08-08 16:46:31 +0200171
172 [ Daniel Willmann ]
Oliver Smith29532c22021-01-29 11:13:00 +0100173 * Fix gbproxy_sgsn_by_tlli wraparound
Harald Weltee250eaa2019-01-23 18:32:41 +0100174
175 [ Alexander Couzens ]
Oliver Smith29532c22021-01-29 11:13:00 +0100176 * configure.ac: define a c standard instead of using the compilers default
Harald Weltee250eaa2019-01-23 18:32:41 +0100177
178 [ Daniel Willmann ]
Oliver Smith29532c22021-01-29 11:13:00 +0100179 * gbproxy: Implement TLLI cache and use it for SUSPEND/RESUME
180 * gbproxy: Increase TLLI cache timeout to 10s
Harald Weltee250eaa2019-01-23 18:32:41 +0100181
182 [ Oliver Smith ]
Oliver Smith29532c22021-01-29 11:13:00 +0100183 * contrib/jenkins: don't build osmo-gsm-manuals
Harald Weltee250eaa2019-01-23 18:32:41 +0100184
Oliver Smith29532c22021-01-29 11:13:00 +0100185 [ Daniel Willmann ]
186 * gbproxy: Implement IMSI cache
187 * gbproxy: Use IMSI cache to handle PAGING_PS_REJECT
188 * gbproxy: Use C-style comments
189 * gbproxy: Move helper function to a more logical place
190 * gbproxy: Remove unused variable assignment
191 * gbproxy: Fix VTY cmd name
192 * gbproxy: Define and use help string for gbproxy
193 * gbproxy: Add VTY commands to query the TLLI/IMSI cache
Pau Espin Pedrol54936e92018-05-03 19:01:44 +0200194
195 [ Harald Welte ]
Oliver Smith29532c22021-01-29 11:13:00 +0100196 * gb_proxy: Don't use orphan log subsystem DPCU
Pau Espin Pedrol54936e92018-05-03 19:01:44 +0200197
Oliver Smith29532c22021-01-29 11:13:00 +0100198 [ Daniel Willmann ]
199 * gbproxy: Use IMSI cache for PTP paging and implement DUMMY_PAGING_PS
200 * gbproxy: Print the correct message type for dummy paging/paging reject
201 * gbproxy: Improve log messages in gbproxy_select_sgsn
202 * gbproxy: Fix radio status routing by TMSI
Harald Welte5641e9d2017-10-28 19:07:48 +0200203
204 [ Alexander Couzens ]
Oliver Smith29532c22021-01-29 11:13:00 +0100205 * follow libosmocore/gprs_ns2 API changes of GPRS enums
Harald Welte5641e9d2017-10-28 19:07:48 +0200206
207 [ Harald Welte ]
Oliver Smith29532c22021-01-29 11:13:00 +0100208 * gbproxy: Avoid depending on any of the SGSN code
Harald Welte5641e9d2017-10-28 19:07:48 +0200209
Oliver Smith29532c22021-01-29 11:13:00 +0100210 [ Daniel Willmann ]
211 * manual/gbproxy: Update overview chapter
212 * Rename OsmoGbPROXY -> *Proxy
213 * manuals/gbproxy: Update configuration chapter
214 * manuals/gbproxy: Add osmo-bsc MSC pooling chapter from Neels as a base
215 * manuals/gbproxy: MSC -> SGSN for pooling chapter
216 * manuals/gbproxy: Move pooling to separate chapter
Harald Welte5641e9d2017-10-28 19:07:48 +0200217
Oliver Smith29532c22021-01-29 11:13:00 +0100218 [ Alexander Couzens ]
219 * gbproxy: follow gprs_ns2 API vty changes
220 * sgsn: migrate to the new gprs_ns2_vty configuration
221 * follow libosmocore/gprs_ns2 API changes (gprs_ns2_dynamic_create_nse)
Holger Hans Peter Freytherb803b142016-05-24 23:15:12 +0200222
Oliver Smith29532c22021-01-29 11:13:00 +0100223 [ Oliver Smith ]
224 * === Split osmo-gbproxy from osmo-sgsn ===
Holger Hans Peter Freytherb803b142016-05-24 23:15:12 +0200225
Oliver Smith29532c22021-01-29 11:13:00 +0100226 -- Oliver Smith <osmith@sysmocom.de> Fri, 29 Jan 2021 12:57:28 +0100