blob: 2827f43b0b093880a179c63123da8bda2a714d57 [file] [log] [blame]
Pau Espin Pedrol379e75a2020-01-03 19:17:56 +01001osmo-sgsn (1.6.0) unstable; urgency=medium
2
3 [ Pau Espin Pedrol ]
4 * gprs_gmm: Introduce macros to access msgb's associated IU UE ctx
5 * gprs_llc.h: Improve documentation of some structs
6 * gprs_gmm.c: Improve doc on nullable parameters
7 * gprs_gmm.c: Drop unneeded brackets
8 * Introduce define TLLI_UNASSIGNED
9 * gprs_sgsn.c: Warn upon llme free unexpected scenarios
10 * gprs_gmm: Clarify comment during TLLI assignment
11 * gprs_sgsn.c: Remove recently introduced assert
12 * gprs_gmm: Introduce assert to guard against unexpected condition
13 * gprs_gmm.c: Use correct function to set MM_IDLE state during cleanup
14 * gprs_sgsn.h: Flag MM_CTX_T_GERAN_Iu as not supported
15 * gprs_gmm.c: Flag mmctx_set_(p)mm_state() functions static
16 * sgsn: use sccp_simple_client API to setup ss7 id 0 instead of 1
17 * gprs_gmm.c: Fix typo in log message
18 * gprs_gmm.c: Call mmctx_set_(p)mm_state only on related ran_type
19 * Introduce and use log macros when no mm ctx available
20 * gprs_gmm: Avoid spaces in fsm events and enum strings
21 * tests: Verify that timers can be set over VTY
22 * Replace own timer infra with libosmocore osmo_tdef
23 * tests: Introduce vty-transcript-test tests
24 * gprs_gmm.c: Use osmo_rai_name() in log line
25 * examples: Add osmo-sgsn_custom-sccp.cfg
26 * vty: Introduce cs7-instance-iu
27 * gprs_gmm.c: Print value_string of reject cause
28 * gprs_gmm.c: Add spec document to function documentation
29 * gtp: make echo_interval unsigned
30 * gtp: cb_delete_context(): Clarify why pdp->lib is set to NULL
31 * Introduce log helper LOGGGSN and log category DGTP
32 * sgsn: gtp: Drop related pdp contexts on echo timeout against GGSN
33 * Move lots of Iu/ranap specific code into its own file
34 * Move llc->MM/SM Gb specific glue code to its own file
35 * Split enum gprs_pmm_state into Iu and Gb counterparts
36 * Merge common allocation steps for Gb and Iu ctx
37 * gprs_gmm.c: Replace inet_ntoa with inet_ntop
38 * sgsn_cdr.c: Fix ip addr string buffer size
39 * sgsn_vty: Fix mmctx rate_ctr output indentation
40 * sgsn_vty: Print correct Iu mmctx id in 'show mm-context'
41 * Introduce FSM mm_state_gb_fsm
42 * Introduce FSM mm_state_iu_fsm
43 * vty: Print MM state and RAN type in show mm-context
44 * src/gprs/Makefile.am: Move build of shared .c files to an internal lib
45 * Move out gbproxy to its own subdir
46 * Move out gtphub to its own subdir
47 * Move out sgsn to its own subdir
48 * gmm: Move code handling GMM Attach Complete to its own function
49 * gmm: Move code handling GMM Routing Area Update Complete to its own function
50 * gmm: Move code handling GMM PTMSI Realloc Complete to its own function
51 * enum gprs_gmm_state: Fix spec reference
52 * Implement GMM State using osmocom FSM
53 * Split out GPRS SM layer into its own file
54 * sgsn: Reject PdpActReq if no GTP pdp ctx exists
55 * Introduce TODO-RELEASE file
56 * sgsn_libgtp.c: Drop use of deprecated libgtp APIs gtp_retrans*()
57 * gmm: Fix assertion hit during RA UPD REQ before completting gmm attach
58 * Improve logging in gprs_llc.c code
59 * gprs_llc.c: Use enum instead of hardcoded value
60 * gprs_gmm.c: Send XID reset with received TLLI
61
62 [ Alexander Couzens ]
63 * gprs/gprs_gmm: implement T3314. Timeout to reset MM state READY->STANDBY
64 * gprs_gmm: only update gb/iu cell information when Iu/Gb present
65 * gprs_gmm: clarify comment of Iu follow-on request
66 * gprs_gmm: gsm48_rx_gmm_att_req(): refactor duplicated code
67 * sgsn_pdp_ctx_terminate: check llme before accessing
68 * gprs_ranap: send CommonId after receiving Security Mode Complete
69 * mm_gb_fsm: unassign the llme when entering MM_IDLE
70 * gprs_ranap: refactor REQUIRE_MM define
71 * sgsn: when receiving data PDU notify the Gb GMM fsm
72 * Avoid compiling unneeded files when building without Iu
73 * gprs_ranap: release Iu UE Context when exiting PMM Connected
74 * Iu: implement a user inactivity timer
75 * gprs_ranap: on Iu release, stop the attach fsm if running
76 * gprs_mm_state_gb_fsm: ensure T3350 is not running when entering IDLE
77 * gprs_ranap: add missing rc = 0
78 * gprs_sgsn: always allocate Gb/Iu mm fsm
79 * sgsn: MM Gb Fsm: fix event handling for implicit detach
80 * ranap: add non-spec X1001
81 * gprs_gmm: release Iu connection on RAU failures
82 * sgsn_mm_ctx_alloc(): check for unallocated fsms
83 * sgsn_libgtp: refactor ps paging into gprs_gb
84 * sgsn: Gb: implementing PS Paging when MS is MM_STANDBY
85
86 [ Vadim Yanitskiy ]
87 * gprs_mm_state_iu_fsm.c: fix: assign timer_cb to mm_state_iu_fsm
88
89 [ Max ]
90 * Use libosmocore constant for IMSI length in ACL entry
91
92 [ Harald Welte ]
93 * LLC: Don't use hard-coded N201-U / N201-I values in XID
94 * Initial OsmoGbPROXY user manual
95 * check for osmo_fsm_register() error return values
96 * check for osmo_ss7_init() error return value
97 * manual: Fix copy+paste error
98 * exit(2) on unsupported positional arguments on command line
99
100 [ Oliver Smith ]
101 * gitignore: fix paths to binaries
102 * doc: add OsmoGbProxy VTY reference
103 * regen_doc.sh: support gbproxy, run without docker
104 * osmoappdesc.py, tests: switch to python 3
105
106 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 03 Jan 2020 19:17:56 +0100
107
Pau Espin Pedroleab9d382019-08-08 16:46:31 +0200108osmo-sgsn (1.5.0) unstable; urgency=medium
109
110 [ Max ]
111 * Improve 'show subscriber cache' vty command
112 * GMM: permit VLR_ANSWERED event in attach FSM
113 * Fix IMSI padding in imsi-acl
114
115 [ Harald Welte ]
116 * gbproxy_test: Fix test expectations of gprs_ns_rcvmsg()
117 * LLC XID: Fix string representation of N201_U
118 * LLC: Don't blindly assume all LLC frames have data payload
119 * LLC: Avoid NOTICE message on LLC NULL
120 * gprs_llc: Correctly refuse any ABM command (SABM, DISC) with DM
121 * LLC: Store the XID inside the LLC Entity, not LLC Mgmg Entity
122 * gb_proxy.h: Add missing comments; improve comments
123 * gb_proxy: cosmetic: Use 'bool' in data structures where applicable
124
125 [ efistokl ]
126 * gsm0408_rcv_gmm: send Iu-ReleaseCommand upon receiving Attach Complete.
127 * gprs_gmm: send Service Reject when no PDP ctxs are available.
128
129 [ Alexander Couzens ]
130 * gprs_gmm: reintroduce calling gsm48_gmm_authorize when not handling GMM Attach Requests
131 * gbproxy: parse dtap GSM48_MT_GSM_DEACT_PDP_REQ|ACK
132
133 [ Pau Espin Pedrol ]
134 * gprs_sndcp_comp_free: Replace ifelse with switch and better handling of error
135 * sgsn: vty: Improve log warning content with spec section
136 * Document max retransmit times for T3395
137 * sgsn: Fix echo timer not started upon first pdp ctx created
138 * sgsn_libgtp: Use new per-GSN libgtp API instead of deprecated API
139 * sgsn: Have authentication required on by default
140 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
141 * Require newer versions of dependencies
142
143 [ Keith ]
144 * Echo zero byte XID-Field of Type L3_PAR
145
146 [ Oliver Smith ]
147 * debian: create -doc subpackage with pdf manuals
148 * contrib/jenkins.sh: run "make maintainer-clean"
149 * osmo-gtphub.cfg: fix conflict with osmo-sgsn.cfg
150 * osmo-gbproxy.cfg: fix conflict with osmo-sgsn.cfg
151
152 [ Vadim Yanitskiy ]
153 * doc/manuals/vty: regenerate sgsn_vty_reference.xml
154 * osmo-sgsn: add VTY parameter to toggle authentication
155 * sgsn_mm_ctx_find_ggsn_ctx(): fix: always set gsm_cause
156
157 [ Eric Wild ]
158 * replace magic tmsi constant with define
159 * turn -Werror=null-dereference into a warning
160
161 [ Daniel Willmann ]
162 * manuals: Add script to regenerate vty/counter documentation
163 * manuals: Update vty/counter documentation
164 * Add/fix help string for version option
165 * osmo-sgsn: Fix outdated information in usermanual
166 * configuration.adoc: Small fixes
167 * configuration.adoc: Add a section about encryption
168
169 [ Ruben Undheim ]
170 * Spelling fixes
171
172 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 08 Aug 2019 16:46:31 +0200
173
Harald Weltee250eaa2019-01-23 18:32:41 +0100174osmo-sgsn (1.4.0) unstable; urgency=medium
175
176 [ Alexander Couzens ]
177 * gprs_subscriber: gsup_auth_error: reject MS in all cases
178 * gprs_gmm: make functions relating to GMM Attach Request public
179 * gprs_gmm: make extract_subscr_msisdn extract_subscr_hlr public
180 * gprs_gmm: Cancel Location: use detach type IMSI
181 * vty: add cmd "reset sgsn state"
182 * tests: remove gmm unit tests
183 * gprs_gmm: introduce a GMM Attach Request FSM
184 * debian: add missing build dependencies
185 * sgsn: use gtp_clear_queues() when reset sgsn state
186 * vty: restart sgsn state: improve output message
187 * sgsn_ggsn_ctx_drop_pdp: protect against nullpointer when MM is gone
188 * gprs_sgsn.h: fix wrong type of re-attempts
189 * GTP: refactor the echo timer
190 * gprs_gmm: dont answer unknown IMSI/TMSI on Service Requests NET_FAIL
191 * gprs_gmm: Fix missing Security Command for 3G when attaching
192 * sgsn_libgtp: fix a potential memleak when the GGSN is not reachable
193 * gprs_llc: remove the FCS from the msgb by trim'ing the msgb
194 * OsmoSGSN: add rate counter documentation
195
196 [ Daniel Willmann ]
197 * gb_proxy: tallocate memory for gbproxy cfg so it can be a talloc ctx
198 * gb_proxy: Add ctrl interface and nsvc-state, gbproxy-state commands
199 * git-version-gen: Don't check for .git directory
200
201 [ Stefan Sperling ]
202 * add a test for OS#3178 (invalid unitdata message)
203 * finish gbproxy_parse_bssgp_unitdata test
204 * fix bogus assertion in encode_comp_field()
205 * fix bogus error check in gprs_sndcp_comp_create()
206 * use enums consistently instead of falling back to int
207 * update gbproxy test expected output
208 * consistently check the result of osmo_shift_v_fixed()
209 * remove pointless declaration of struct gsm_network
210 * make gsup ipa name configurable in osmo-sgsn.cfg
211
212 [ Pau Espin Pedrol ]
213 * jenkins.sh: Use --enable-werror only when iu support is disabled
214 * jenkins.sh: Remove non-existent configure options
215 * Drop all references of unused SMPP
216 * Drop all references of unused MGCP
217 * Drop unused common_vty.c
218 * sgsn_libgtp.c: Log pointer of deleted context
219 * Maintain per ggsn pdp ctx list
220 * osmo-sgsn: ping GGSN periodically and check for restart counter
221 * Disarm T3395 when dettaching mmctx from pdpctx
222 * examples: Enable by default echo req towards active GGSNs
223 * vty: Add cmd to disable echo loop explictly
224 * Add optional TearDownInd IE in PDP DEACT REQ towards PCU
225 * sgsn: Don't attempt to delete GTP pdp ctx if GGSN was restarted
226 * Forward GGSN originated DEACT PDP CTX REQ
227 * sgsn: Fix T3395 firing forever
228 * sgsn: subscriber: Avoid calling memcpy with NULL src
229 * sgsn: cdr: Fix uninitialized string access if ggsn is detached
230 * sgsn: gtp: Use new API to send PDP DEL CTX REQ without freeing ctx locally
231 * sgsn: Fix crash using new libgtp cb_recovery2 API
232 * gbproxy: Replace '.' in counter names with ':'
233 * Drop gprs_msgb_copy with libosmocore replacement
234 * Drop gprs_msgb_resize_area with libosmocore replacement
235 * Use osmo_clock_gettime from libosmocore
236 * gbproxy: Add VTY parameter: link stored-msgs-max-length
237 * gbproxy: Add new VTY-managed timer: link-list clean-stale-timer
238 * gbproxy: Replace '.' in counter names with ':'
239 * Add osmo-gtphub systemd service file
240 * debian: Fix typo in rules preventing build with IU support
241 * Install systemd services with autotools
242 * Install sample cfg file to /etc/osmocom
243 * Update wrong references to bsc in sgsn code
244 * Allocate sgsn_instance with talloc
245 * gbproxy: flag gbproxy_assign_imsi as static
246 * gbproxy: Fix abort during APN patch
247 * gbproxy: Remove unneeded parse_ctx param
248 * gbproxy: flush_stored_messages: Move comment to func description
249 * gbproxy: flush_stored_messages: Log and route using stored_msg info
250 * gbproxy: flush_stored_messages: Get rid of msg param
251 * Allow easily disabling GFDL references
252 * OsmoSGSN: configuration: Move pdp ctx specific CDR fields to its own table
253 * OsmoSGSN: configuration: Add missing pdp-periodic event
254 * OsmoSGSN: configuration: Document CDR CTRL interface
255 * OsmoSGSN: overview: Fix typo and reference OpenGGSN->OsmoGGSN
256
257 [ Harald Welte ]
258 * migrate to oap_client in libosmogsm
259 * remove libcommon
260 * gbproxy-legacy: Ensure well-formed config file
261 * Remove local libgsupclient; Use libosmo-gsup-client from osmo-hlr
262 * initial checkin of manuals to public repo
263 * Add link to Asciidoc source code of manual
264 * OsmoSGSN: Fix formatting/cross reference in CDR section
265 * Update GSUP chapter regarding UMTS AKA and other recent changes
266 * GSUP: Add ladder diagrams for protocol transactions / procedures
267 * share chapters/gsup.adoc from OsmoSGSN to OsmoMSC + OsmoHLR
268 * vty-ref: Update URI of docbook 5.0 schema
269
270 [ Neels Hofmeyr ]
271 * use __FILE__, not __BASE_FILE__
272 * vty: fix doc str for 'reset sgsn state'
273 * vty: add SCCP related vty commands
274 * fix build: remove unused variable
275 * Importing history from osmo-gsm-manuals.git
276 * add 'make check' target
277 * fix 'make clean': shell glob, ignore failure
278 * refactor Makefile build rules, don't use the FORCE
279 * OsmoSGSN: update VTY reference
280 * sgsn: update vty reference
281
282 [ Oliver Smith ]
283 * gtphub: Add --version cmdline option
284 * build manuals moved here from osmo-gsm-manuals.git
285 * Fix DISTCHECK_CONFIGURE_FLAGS override
286 * contrib/jenkins.sh: build and publish manuals
287 * contrib: fix makedistcheck with disabled systemd
288
289 [ Max ]
290 * Cleanup non-existent files from debian/copyright
291 * Use safer functions for IMSI ACL
292 * gbproxy: fix formatting in gbproxy-state command
293 * gbproxy: add number-of-peers ctrl command
294 * Revert "gbproxy: fix formatting in gbproxy-state command"
295 * Add OsmoSGSN control interface description
296 * Remove misleading comment
297 * Constify sgsn_acl_lookup() parameter
298 * Drop unused osmo-sgsn.pc
299 * Use explicit length check
300 * Use explicit parameter for sgsn_auth_init()
301
302 [ Jonathan Brielmaier ]
303 * fix various typos across all manuals
304
305 [ ikostov ]
306 * SGSN: add Auth. policy, NS Statistics and BSSGP state examples, tweaks
307 * GSUP, OAP: fix AUTS length to 14, not 16
308
309 [ Philipp Maier ]
310 * osmo-sgsn: Update VTY command reference
311 * osmo-sgsn: improve auth-policy explaination
312 * osmo-sgsn: Explain TCP/IP header compression
313 * osmo-sgsn: fix arrow tips in flow diagrams
314
315 [ Holger Hans Peter Freyther ]
316 * sgsn: Fix numbering of QoS and add basic description for APN
317 * sgsn: Add charging characteristics to GSUP
318
319 -- Harald Welte <laforge@gnumonks.org> Wed, 23 Jan 2019 18:32:41 +0100
320
Pau Espin Pedrol54936e92018-05-03 19:01:44 +0200321osmo-sgsn (1.3.0) unstable; urgency=medium
322
323 [ Neels Hofmeyr ]
324 * drop osmo_sgsn.cfg from src/gprs dir
325 * change default config filename to osmo-sgsn.cfg, not osmo_sgsn.cfg
326 * vty: skip installing cmds now always installed by default
327 * add --enable-sanitize config option
328 * use default point-code as listed on Point_Codes wiki page
329 * gprs_gmm: segfault: gracefully handle failure to alloc context
330 * gsm48_rx_gmm_att_req: fix error handling: don't clean up NULL llme
331 * gprs_llc: tx dl ud: make mismatching LLE not crash osmo-sgsn
332 * fix build: missing LIBGTP_CFLAGS in sgsn_test
333 * sgsn_test: guard against struct gprs_ra_id changing
334 * vty: absorb command explanations from osmo-gsm-manuals
335 * configure: add --enable-werror
336 * implement support for 3-digit MNC with leading zeros
337 * osmo-gbproxy: use 'osmo-gbproxy.cfg' as default config name
338 * compiler warnings: use enum ranap_nsap_addr_enc, constify local var
339 * use osmo_init_logging2(), fix regression test memleaks
340 * auth+ciph: log is_r99 and auth types
341 * log two RA Update Request failure causes
342 * GERAN: allow GSM SRES on UMTS AKA challenge
343
344 [ Alexander Couzens ]
345 * .gitignore: remove unneeded ignores of bsc/msc/nitb files
346 * tests/ctrl_test_runner.py: remove BSC/NAT TestRunner
347 * debian: remove doublicated project name in example files
348 * .gitignore: remove non-existent /src/utils exludes
349 * configure.ac: remove pcap check
350 * configure.ac: remove unused libcdk check
351 * .service: remove OpenBSC from service desription
352 * mandatory depend on libc-ares and libgtp
353 * GMM: dont reply to GMM_DETACH_REQ with POWER OFF when MS is unknown
354
355 [ Harald Welte ]
356 * Replace '.' in counter names with ':'
357 * Add talloc context introspection via VTY
358
359 [ Pau Espin Pedrol ]
360 * Replace '.' in counter names with ':'
361 * tests: Fix selection of python version
362 * sgsn_cdr: Split log formatting into a snprintf function
363 * Add vty cmd 'cdr trap' to send CDR through CTRL iface
364 * tests: sgsn_test: Define wrap APIs with correct parameters
365 * cosmetic: tests: sgsn_test: Use proper formatting and remove uneeded semicolons
366 * gprs_gmm: Remove unused variable
367 * cosmetic: gprs_gmm: Remove trailing whitespace
368 * gprs_gmm: Convert warning message to pragma message
369 * configure.ac: Enable Wall in CFLAGS
370 * .gitignore: Add m4 files
371 * sgsn_libgtp.c: Fix typos and whitespace
372
373 [ Max ]
374 * Fix display of GTP addresses
375 * Show GTP version for PDP context in vty
376 * Remove unneeded .py scripts
377 * Replace '.' in counter names with ':'
378 * Remove dead code
379 * Enable sanitize for CI tests
380 * cosmetic: use macro for gtphub plane iteration
381 * Use connection id when allocating rate counters
382 * Migrate from OpenSSL to osmo_get_rand_id()
383 * Remove obsolete ./configure option
384 * Fix RAI construction
385 * gtphub: make rate_ctr unique
386 * Remove unused bsc_version.c
387 * Use gsm48_encode_ra() for RAI encoding
388 * gtphub: check for gsn_addr_from_sockaddr() errors
389 * gtphub: check for gsn_addr_from_sockaddr() error
390
391 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 19:01:44 +0200
392
Harald Welte5641e9d2017-10-28 19:07:48 +0200393osmo-sgsn (1.2.0) unstable; urgency=medium
394
395 [ Neels Hofmeyr ]
396 * jenkins: fix build: remove unused dependencies
397 * debian: fix osmo-sgsn.install, tweak VCS link and descriptions
398 * drop files unrelated to osmo-sgsn
399 * rewrite README
400 * configure.ac: set name to osmo-sgsn, fix ML addr
401 * move openbsc.pc to osmo-sgsn.pc
402 * move include/openbsc to include/osmocom/sgsn
403 * jenkins.sh: fix echo string to say osmo-sgsn, not msc
404 * jenkins: use osmo-clean-workspace.sh before and after build
405
406 [ Alexander Couzens ]
407 * debian: fix paths of examples
408 * debian/rules: show testsuite.log when tests are failing
409
410 [ Max ]
411 * Remove rest_octets.h
412 * gbproxy: ensure peer allocation result
413 * jenkins: use osmo-ggsn for tests
414 * Cleanup configure checks
415 * Use extended logging for PDP contexts
416 * deb: fix copyright file issues
417 * Move P-TMSI alloc/update into separate function
418 * Check for correct P-TMSI allocation
419 * Use new FSF address in license header
420 * SGSN: uncomment BSSGP vty tests
421 * SGSN: print additional GTP-related info
422 * SGSN: check that GSN is created in proper mode
423 * Fix APN printing
424 * Fix build after recent rate_ctr patches
425 * gbproxy: don't link unnecessary
426 * Fix libosmo-sigtran dependency
427 * jenkins: check for IU properly
428 * Log GTP-U endpoints update
429 * Log address on GTP creation
430
431 [ Pau Espin Pedrol ]
432 * Remove unneeded dep libdbi
433
434 [ Philipp Maier ]
435 * log: fix default loglevels
436 * non-iu-build: guard vty libosmo-sigtran function calls.
437 * configure: fix libosmo-sigtran dependency
438
439 [ Harald Welte ]
440 * Debian: Add systemd service files for osmo-sgsn and osmo-gbproxy
441 * Debian: fix dh_strip rules for creating one -dbg per program
442
443 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 19:07:48 +0200
444
Alexander Couzensd040bab2017-08-07 09:48:18 +0000445osmo-sgsn (0.1.0) unstable; urgency=low
Holger Hans Peter Freytherb803b142016-05-24 23:15:12 +0200446
Alexander Couzensd040bab2017-08-07 09:48:18 +0000447 * Initial release.
Holger Hans Peter Freytherb803b142016-05-24 23:15:12 +0200448
Alexander Couzensd040bab2017-08-07 09:48:18 +0000449 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:13:05 +0000