blob: 02ec236c3509f5fd39fd94fb7298aa1921a0fc55 [file] [log] [blame]
Pau Espin Pedroleab9d382019-08-08 16:46:31 +02001osmo-sgsn (1.5.0) unstable; urgency=medium
2
3 [ Max ]
4 * Improve 'show subscriber cache' vty command
5 * GMM: permit VLR_ANSWERED event in attach FSM
6 * Fix IMSI padding in imsi-acl
7
8 [ Harald Welte ]
9 * gbproxy_test: Fix test expectations of gprs_ns_rcvmsg()
10 * LLC XID: Fix string representation of N201_U
11 * LLC: Don't blindly assume all LLC frames have data payload
12 * LLC: Avoid NOTICE message on LLC NULL
13 * gprs_llc: Correctly refuse any ABM command (SABM, DISC) with DM
14 * LLC: Store the XID inside the LLC Entity, not LLC Mgmg Entity
15 * gb_proxy.h: Add missing comments; improve comments
16 * gb_proxy: cosmetic: Use 'bool' in data structures where applicable
17
18 [ efistokl ]
19 * gsm0408_rcv_gmm: send Iu-ReleaseCommand upon receiving Attach Complete.
20 * gprs_gmm: send Service Reject when no PDP ctxs are available.
21
22 [ Alexander Couzens ]
23 * gprs_gmm: reintroduce calling gsm48_gmm_authorize when not handling GMM Attach Requests
24 * gbproxy: parse dtap GSM48_MT_GSM_DEACT_PDP_REQ|ACK
25
26 [ Pau Espin Pedrol ]
27 * gprs_sndcp_comp_free: Replace ifelse with switch and better handling of error
28 * sgsn: vty: Improve log warning content with spec section
29 * Document max retransmit times for T3395
30 * sgsn: Fix echo timer not started upon first pdp ctx created
31 * sgsn_libgtp: Use new per-GSN libgtp API instead of deprecated API
32 * sgsn: Have authentication required on by default
33 * Remove undefined param passed to {logging,osmo_stats}_vty_add_cmds
34 * Require newer versions of dependencies
35
36 [ Keith ]
37 * Echo zero byte XID-Field of Type L3_PAR
38
39 [ Oliver Smith ]
40 * debian: create -doc subpackage with pdf manuals
41 * contrib/jenkins.sh: run "make maintainer-clean"
42 * osmo-gtphub.cfg: fix conflict with osmo-sgsn.cfg
43 * osmo-gbproxy.cfg: fix conflict with osmo-sgsn.cfg
44
45 [ Vadim Yanitskiy ]
46 * doc/manuals/vty: regenerate sgsn_vty_reference.xml
47 * osmo-sgsn: add VTY parameter to toggle authentication
48 * sgsn_mm_ctx_find_ggsn_ctx(): fix: always set gsm_cause
49
50 [ Eric Wild ]
51 * replace magic tmsi constant with define
52 * turn -Werror=null-dereference into a warning
53
54 [ Daniel Willmann ]
55 * manuals: Add script to regenerate vty/counter documentation
56 * manuals: Update vty/counter documentation
57 * Add/fix help string for version option
58 * osmo-sgsn: Fix outdated information in usermanual
59 * configuration.adoc: Small fixes
60 * configuration.adoc: Add a section about encryption
61
62 [ Ruben Undheim ]
63 * Spelling fixes
64
65 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 08 Aug 2019 16:46:31 +0200
66
Harald Weltee250eaa2019-01-23 18:32:41 +010067osmo-sgsn (1.4.0) unstable; urgency=medium
68
69 [ Alexander Couzens ]
70 * gprs_subscriber: gsup_auth_error: reject MS in all cases
71 * gprs_gmm: make functions relating to GMM Attach Request public
72 * gprs_gmm: make extract_subscr_msisdn extract_subscr_hlr public
73 * gprs_gmm: Cancel Location: use detach type IMSI
74 * vty: add cmd "reset sgsn state"
75 * tests: remove gmm unit tests
76 * gprs_gmm: introduce a GMM Attach Request FSM
77 * debian: add missing build dependencies
78 * sgsn: use gtp_clear_queues() when reset sgsn state
79 * vty: restart sgsn state: improve output message
80 * sgsn_ggsn_ctx_drop_pdp: protect against nullpointer when MM is gone
81 * gprs_sgsn.h: fix wrong type of re-attempts
82 * GTP: refactor the echo timer
83 * gprs_gmm: dont answer unknown IMSI/TMSI on Service Requests NET_FAIL
84 * gprs_gmm: Fix missing Security Command for 3G when attaching
85 * sgsn_libgtp: fix a potential memleak when the GGSN is not reachable
86 * gprs_llc: remove the FCS from the msgb by trim'ing the msgb
87 * OsmoSGSN: add rate counter documentation
88
89 [ Daniel Willmann ]
90 * gb_proxy: tallocate memory for gbproxy cfg so it can be a talloc ctx
91 * gb_proxy: Add ctrl interface and nsvc-state, gbproxy-state commands
92 * git-version-gen: Don't check for .git directory
93
94 [ Stefan Sperling ]
95 * add a test for OS#3178 (invalid unitdata message)
96 * finish gbproxy_parse_bssgp_unitdata test
97 * fix bogus assertion in encode_comp_field()
98 * fix bogus error check in gprs_sndcp_comp_create()
99 * use enums consistently instead of falling back to int
100 * update gbproxy test expected output
101 * consistently check the result of osmo_shift_v_fixed()
102 * remove pointless declaration of struct gsm_network
103 * make gsup ipa name configurable in osmo-sgsn.cfg
104
105 [ Pau Espin Pedrol ]
106 * jenkins.sh: Use --enable-werror only when iu support is disabled
107 * jenkins.sh: Remove non-existent configure options
108 * Drop all references of unused SMPP
109 * Drop all references of unused MGCP
110 * Drop unused common_vty.c
111 * sgsn_libgtp.c: Log pointer of deleted context
112 * Maintain per ggsn pdp ctx list
113 * osmo-sgsn: ping GGSN periodically and check for restart counter
114 * Disarm T3395 when dettaching mmctx from pdpctx
115 * examples: Enable by default echo req towards active GGSNs
116 * vty: Add cmd to disable echo loop explictly
117 * Add optional TearDownInd IE in PDP DEACT REQ towards PCU
118 * sgsn: Don't attempt to delete GTP pdp ctx if GGSN was restarted
119 * Forward GGSN originated DEACT PDP CTX REQ
120 * sgsn: Fix T3395 firing forever
121 * sgsn: subscriber: Avoid calling memcpy with NULL src
122 * sgsn: cdr: Fix uninitialized string access if ggsn is detached
123 * sgsn: gtp: Use new API to send PDP DEL CTX REQ without freeing ctx locally
124 * sgsn: Fix crash using new libgtp cb_recovery2 API
125 * gbproxy: Replace '.' in counter names with ':'
126 * Drop gprs_msgb_copy with libosmocore replacement
127 * Drop gprs_msgb_resize_area with libosmocore replacement
128 * Use osmo_clock_gettime from libosmocore
129 * gbproxy: Add VTY parameter: link stored-msgs-max-length
130 * gbproxy: Add new VTY-managed timer: link-list clean-stale-timer
131 * gbproxy: Replace '.' in counter names with ':'
132 * Add osmo-gtphub systemd service file
133 * debian: Fix typo in rules preventing build with IU support
134 * Install systemd services with autotools
135 * Install sample cfg file to /etc/osmocom
136 * Update wrong references to bsc in sgsn code
137 * Allocate sgsn_instance with talloc
138 * gbproxy: flag gbproxy_assign_imsi as static
139 * gbproxy: Fix abort during APN patch
140 * gbproxy: Remove unneeded parse_ctx param
141 * gbproxy: flush_stored_messages: Move comment to func description
142 * gbproxy: flush_stored_messages: Log and route using stored_msg info
143 * gbproxy: flush_stored_messages: Get rid of msg param
144 * Allow easily disabling GFDL references
145 * OsmoSGSN: configuration: Move pdp ctx specific CDR fields to its own table
146 * OsmoSGSN: configuration: Add missing pdp-periodic event
147 * OsmoSGSN: configuration: Document CDR CTRL interface
148 * OsmoSGSN: overview: Fix typo and reference OpenGGSN->OsmoGGSN
149
150 [ Harald Welte ]
151 * migrate to oap_client in libosmogsm
152 * remove libcommon
153 * gbproxy-legacy: Ensure well-formed config file
154 * Remove local libgsupclient; Use libosmo-gsup-client from osmo-hlr
155 * initial checkin of manuals to public repo
156 * Add link to Asciidoc source code of manual
157 * OsmoSGSN: Fix formatting/cross reference in CDR section
158 * Update GSUP chapter regarding UMTS AKA and other recent changes
159 * GSUP: Add ladder diagrams for protocol transactions / procedures
160 * share chapters/gsup.adoc from OsmoSGSN to OsmoMSC + OsmoHLR
161 * vty-ref: Update URI of docbook 5.0 schema
162
163 [ Neels Hofmeyr ]
164 * use __FILE__, not __BASE_FILE__
165 * vty: fix doc str for 'reset sgsn state'
166 * vty: add SCCP related vty commands
167 * fix build: remove unused variable
168 * Importing history from osmo-gsm-manuals.git
169 * add 'make check' target
170 * fix 'make clean': shell glob, ignore failure
171 * refactor Makefile build rules, don't use the FORCE
172 * OsmoSGSN: update VTY reference
173 * sgsn: update vty reference
174
175 [ Oliver Smith ]
176 * gtphub: Add --version cmdline option
177 * build manuals moved here from osmo-gsm-manuals.git
178 * Fix DISTCHECK_CONFIGURE_FLAGS override
179 * contrib/jenkins.sh: build and publish manuals
180 * contrib: fix makedistcheck with disabled systemd
181
182 [ Max ]
183 * Cleanup non-existent files from debian/copyright
184 * Use safer functions for IMSI ACL
185 * gbproxy: fix formatting in gbproxy-state command
186 * gbproxy: add number-of-peers ctrl command
187 * Revert "gbproxy: fix formatting in gbproxy-state command"
188 * Add OsmoSGSN control interface description
189 * Remove misleading comment
190 * Constify sgsn_acl_lookup() parameter
191 * Drop unused osmo-sgsn.pc
192 * Use explicit length check
193 * Use explicit parameter for sgsn_auth_init()
194
195 [ Jonathan Brielmaier ]
196 * fix various typos across all manuals
197
198 [ ikostov ]
199 * SGSN: add Auth. policy, NS Statistics and BSSGP state examples, tweaks
200 * GSUP, OAP: fix AUTS length to 14, not 16
201
202 [ Philipp Maier ]
203 * osmo-sgsn: Update VTY command reference
204 * osmo-sgsn: improve auth-policy explaination
205 * osmo-sgsn: Explain TCP/IP header compression
206 * osmo-sgsn: fix arrow tips in flow diagrams
207
208 [ Holger Hans Peter Freyther ]
209 * sgsn: Fix numbering of QoS and add basic description for APN
210 * sgsn: Add charging characteristics to GSUP
211
212 -- Harald Welte <laforge@gnumonks.org> Wed, 23 Jan 2019 18:32:41 +0100
213
Pau Espin Pedrol54936e92018-05-03 19:01:44 +0200214osmo-sgsn (1.3.0) unstable; urgency=medium
215
216 [ Neels Hofmeyr ]
217 * drop osmo_sgsn.cfg from src/gprs dir
218 * change default config filename to osmo-sgsn.cfg, not osmo_sgsn.cfg
219 * vty: skip installing cmds now always installed by default
220 * add --enable-sanitize config option
221 * use default point-code as listed on Point_Codes wiki page
222 * gprs_gmm: segfault: gracefully handle failure to alloc context
223 * gsm48_rx_gmm_att_req: fix error handling: don't clean up NULL llme
224 * gprs_llc: tx dl ud: make mismatching LLE not crash osmo-sgsn
225 * fix build: missing LIBGTP_CFLAGS in sgsn_test
226 * sgsn_test: guard against struct gprs_ra_id changing
227 * vty: absorb command explanations from osmo-gsm-manuals
228 * configure: add --enable-werror
229 * implement support for 3-digit MNC with leading zeros
230 * osmo-gbproxy: use 'osmo-gbproxy.cfg' as default config name
231 * compiler warnings: use enum ranap_nsap_addr_enc, constify local var
232 * use osmo_init_logging2(), fix regression test memleaks
233 * auth+ciph: log is_r99 and auth types
234 * log two RA Update Request failure causes
235 * GERAN: allow GSM SRES on UMTS AKA challenge
236
237 [ Alexander Couzens ]
238 * .gitignore: remove unneeded ignores of bsc/msc/nitb files
239 * tests/ctrl_test_runner.py: remove BSC/NAT TestRunner
240 * debian: remove doublicated project name in example files
241 * .gitignore: remove non-existent /src/utils exludes
242 * configure.ac: remove pcap check
243 * configure.ac: remove unused libcdk check
244 * .service: remove OpenBSC from service desription
245 * mandatory depend on libc-ares and libgtp
246 * GMM: dont reply to GMM_DETACH_REQ with POWER OFF when MS is unknown
247
248 [ Harald Welte ]
249 * Replace '.' in counter names with ':'
250 * Add talloc context introspection via VTY
251
252 [ Pau Espin Pedrol ]
253 * Replace '.' in counter names with ':'
254 * tests: Fix selection of python version
255 * sgsn_cdr: Split log formatting into a snprintf function
256 * Add vty cmd 'cdr trap' to send CDR through CTRL iface
257 * tests: sgsn_test: Define wrap APIs with correct parameters
258 * cosmetic: tests: sgsn_test: Use proper formatting and remove uneeded semicolons
259 * gprs_gmm: Remove unused variable
260 * cosmetic: gprs_gmm: Remove trailing whitespace
261 * gprs_gmm: Convert warning message to pragma message
262 * configure.ac: Enable Wall in CFLAGS
263 * .gitignore: Add m4 files
264 * sgsn_libgtp.c: Fix typos and whitespace
265
266 [ Max ]
267 * Fix display of GTP addresses
268 * Show GTP version for PDP context in vty
269 * Remove unneeded .py scripts
270 * Replace '.' in counter names with ':'
271 * Remove dead code
272 * Enable sanitize for CI tests
273 * cosmetic: use macro for gtphub plane iteration
274 * Use connection id when allocating rate counters
275 * Migrate from OpenSSL to osmo_get_rand_id()
276 * Remove obsolete ./configure option
277 * Fix RAI construction
278 * gtphub: make rate_ctr unique
279 * Remove unused bsc_version.c
280 * Use gsm48_encode_ra() for RAI encoding
281 * gtphub: check for gsn_addr_from_sockaddr() errors
282 * gtphub: check for gsn_addr_from_sockaddr() error
283
284 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 19:01:44 +0200
285
Harald Welte5641e9d2017-10-28 19:07:48 +0200286osmo-sgsn (1.2.0) unstable; urgency=medium
287
288 [ Neels Hofmeyr ]
289 * jenkins: fix build: remove unused dependencies
290 * debian: fix osmo-sgsn.install, tweak VCS link and descriptions
291 * drop files unrelated to osmo-sgsn
292 * rewrite README
293 * configure.ac: set name to osmo-sgsn, fix ML addr
294 * move openbsc.pc to osmo-sgsn.pc
295 * move include/openbsc to include/osmocom/sgsn
296 * jenkins.sh: fix echo string to say osmo-sgsn, not msc
297 * jenkins: use osmo-clean-workspace.sh before and after build
298
299 [ Alexander Couzens ]
300 * debian: fix paths of examples
301 * debian/rules: show testsuite.log when tests are failing
302
303 [ Max ]
304 * Remove rest_octets.h
305 * gbproxy: ensure peer allocation result
306 * jenkins: use osmo-ggsn for tests
307 * Cleanup configure checks
308 * Use extended logging for PDP contexts
309 * deb: fix copyright file issues
310 * Move P-TMSI alloc/update into separate function
311 * Check for correct P-TMSI allocation
312 * Use new FSF address in license header
313 * SGSN: uncomment BSSGP vty tests
314 * SGSN: print additional GTP-related info
315 * SGSN: check that GSN is created in proper mode
316 * Fix APN printing
317 * Fix build after recent rate_ctr patches
318 * gbproxy: don't link unnecessary
319 * Fix libosmo-sigtran dependency
320 * jenkins: check for IU properly
321 * Log GTP-U endpoints update
322 * Log address on GTP creation
323
324 [ Pau Espin Pedrol ]
325 * Remove unneeded dep libdbi
326
327 [ Philipp Maier ]
328 * log: fix default loglevels
329 * non-iu-build: guard vty libosmo-sigtran function calls.
330 * configure: fix libosmo-sigtran dependency
331
332 [ Harald Welte ]
333 * Debian: Add systemd service files for osmo-sgsn and osmo-gbproxy
334 * Debian: fix dh_strip rules for creating one -dbg per program
335
336 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 19:07:48 +0200
337
Alexander Couzensd040bab2017-08-07 09:48:18 +0000338osmo-sgsn (0.1.0) unstable; urgency=low
Holger Hans Peter Freytherb803b142016-05-24 23:15:12 +0200339
Alexander Couzensd040bab2017-08-07 09:48:18 +0000340 * Initial release.
Holger Hans Peter Freytherb803b142016-05-24 23:15:12 +0200341
Alexander Couzensd040bab2017-08-07 09:48:18 +0000342 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:13:05 +0000