blob: 461b0c9f9dd37a3a47941e03ca4ecaac127e65a7 [file] [log] [blame]
Pau Espin Pedrole5a96652018-05-15 14:10:38 +02001osmo-bsc (1.2.1) unstable; urgency=medium
2
3 [ Philipp Maier ]
4 * bsc_api/GSCON: prevent unnecessary channel mode modifications
5
6 [ Neels Hofmeyr ]
7 * resurrect meas_feed.c: vty, vty-test
8 * dyn ts, bts_ipaccess_nanobts.c: init PDCH on Chan OPSTART ACK
9 * dyn TS, assignment: set lchan state to LCHAN_S_ACT_REQ in the proper place
10 * dyn TS, assignment: allow switch from PDCH with associated conn
11 * dyn TS: init only when both RSL and the Channel OM are established
12 * dyn TS: allow any pchan type changes, fix for gprs mode none
13 * debug log: verbosely log all lchan alloc choices
14 * deprecate dyn_ts_allow_tch_f and by default allow all TCH
15 * fix default fallbacks in audio_support_to_gsm88()
16 * log: indicate hr/fr in audio_support_to_gsm88() error
17 * cosmetic: dyn ts init: undup logging for gprs = none
18
19 [ Vadim Yanitskiy ]
20 * osmo_bsc_vty.c: fix: write MGW configuration
21
22 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 15 May 2018 14:10:38 +0200
23
Pau Espin Pedrol1b11bc82018-05-03 18:40:12 +020024osmo-bsc (1.2.0) unstable; urgency=medium
25
26 [ Neels Hofmeyr ]
27 * vty: skip installing cmds now always installed by default
28 * bssap: paging: page entire BSS for unimplemented cell id list
29 * fix build: bssap test broke by undefined references
30 * osmo-bsc RESET FSM: use distinct struct names
31 * osmo-bsc: SCCP addrs: default only if unset, reject invalid
32 * osmo-bsc vty: be fatal for addressbook entry errors
33 * use osmo_sccp_inst_addr_name() instead of looking up ss7
34 * add --enable-sanitize config option
35 * bsc_init: fix Werror: define rc for 2quater with si2q_count == 0
36 * bsc filter: don't ignore imsi-allow on "global" filter level
37 * compiler warnings: drop some unused variables
38 * compiler warnings: constify in abis_nm.c
39 * cleanup: drop unused gsm_bts.role
40 * compiler warnings: add includes in abis_rsl.h, gsm_data_shared.h
41 * cosmetic: handover.h: use "#pragma once", declare structs, comments
42 * examples: add osmo-bsc-minimal.cfg
43 * HO prep: pass gsm_network to gsm_bts_alloc() already
44 * fix segfault upon release paging on BSSMAP Reset: init llist
45 * log typo fix in gsm0808_cipher_mode()
46 * debug log: log Cipher Mode info upon sending down RSL/A-bis
47 * fix bssmap_handle_cipher_mode()'s encryption decision
48 * abisip-find: add getopt option parsing in preparation for a new option
49 * abisip-find: add -l to list base stations instead of streaming replies
50 * abisip-find: update copyright
51 * abisip-find: add timeout option
52 * abisip-find: add --interval option
53 * vty: fix 'show lchan ...' arg [lchan_nr] to [<0-7>]
54 * vty: change handover command's arg LCHAN_NR to <0-7>
55 * vty: cosmetic: use common BTS, TRX, TS, LCHAN strings
56 * vty: add various manual handover and assignment trigger commands
57 * osmo_bsc_mgcp: cosmetic: introduce mgcp_init(), soak up fsm init
58 * HO: fix recovery from failed handover
59 * HO prep: introduce per-BTS handover config, with defaults on net node
60 * HO: add indicators for inter-cell and async ho, use for chan act type
61 * cosmetic: explicitly init ho_ref start value
62 * fixup: neigh_meas_avg: detect invalid window size as <=0, log if invalid
63 * fixup: neigh_meas_avg: fix condition to reduce window size
64 * HO: enable handover by initializing at startup; rename init function
65 * HO: add handover algo 2 parameters; skip HO 1 if HO 2 is configured
66 * HO: rename gsm_bts_neighbor() to bts_by_arfcn_bsic()
67 * HO: make bts_by_arfcn_bsic() public
68 * libcommon: eliminate bsc_version.c
69 * libcommon: eliminate common_vty.c
70 * libcommon: eliminate debug.c
71 * libcommon: eliminate socket.c
72 * libcommon: eliminate talloc_ctx.c
73 * ipaccess-proxy: don't redefine tall_bsc_ctx
74 * libcommon: join gsm_data_shared.* into gsm_data.*
75 * drop libcommon completely, move remaining files to libbsc
76 * libcommon-cs: move a_reset.c into libbsc
77 * libcommon-cs: move gsm_network_init() into bsc_network_init()
78 * gsm_network: drop unused trans_list
79 * libcommon_cs: move gsm48 bits to libbsc
80 * libcommon-cs: move vty bits to libbsc/bsc_vty.c
81 * common_cs.h: mv gsm_encr to gsm_data.h
82 * drop libcommon-cs completely
83 * drop unused common.h
84 * gsm_network: drop unused subscr_epxire_timer
85 * vty: 'show bts': write '(none)' if none are found.
86 * vty: 'show bts': fix indenting
87 * bts chan_load: ignore unusable BTS
88 * handover_logic.c: always do inter-cell channel activation
89 * handover_logic.c: on HO command, send new lchan's MS power
90 * HO: process_meas_rep: guard against modulo zero
91 * HO: cosmetic: bsc_handover_start(): "fix" memcpy for AMR config
92 * HO: add new_lchan_type arg to bsc_handover_start()
93 * HO: cosmetic: bsc_handover_start_lchan_change(): tweak local vars
94 * HO: always do async handover
95 * HO: bsc_handover_start_lchan_change(): set MS to max power on handover
96 * HO: logging: more logs, and more concise logging
97 * HO: move penalty timers to own file as proper API
98 * HO: store speech codec list from BSSMAP Assignment in conn
99 * HO: cfg: tweak vty write
100 * vty: 'show bts': list the TRXs' ARFCNs
101 * vty: 'show bts': print neighbor cells
102 * HO: cfg: separate hodec1 from hodec2 parameters
103 * HO: lchan: store last seen measurement report nr, tweak log
104 * HO: clearly mark conn penalty timer member for hodec2
105 * HO: cosmetic: handover_decision.c: make process_meas_rep() return void
106 * HO: introduce ho decision callbacks
107 * HO: cosmetic: getting a chan activ nack on a non-ho lchan is not an error
108 * HO: Implement load based handover, as handover_decision_2.c
109 * HO: vty: rename ho decision 1 vty to 'handover1' with 'handover' alias
110 * cosmetic: adjust copyrights on handover_cfg.c,_vty.c
111 * HO: vty: clearly mark 'handover foo' as legacy alias for 'handover1 foo'
112 * drop unused libbsc/meas_proc.c
113 * HO: fix minor issues found by coverity
114 * bsc_api.c: fix log string format
115 * fix build: gprs_ra_id_by_bts(): ensure to init all values
116 * compiler warning: chan_compat_with_mode(): clearly handle all enum vals
117 * add test for gsm48_ra_id_by_bts()
118 * add test for abis_nm_ipaccess_cgi()
119 * ctrl_test_runner: add tests for 3-digit MNC
120 * gsm48_ra_id_by_bts(): struct gsm48_ra_id* instead of buf
121 * cosmetic: bsc_network_init(): imply default 001-01 PLMN
122 * implement support for 3-digit MNC with leading zeros
123 * gsm48_parse_meas_rep(): set num_cell=0 if no neighbor cells are reported
124 * cosmetic: hodec2: log nr of neighbors in meas report
125 * cosmetic: typo in log: handover_decision2.c: 'measuements'
126 * handover_test: explicitly wrap abis_rsl_sendmsg()
127 * pcu_if: implement support for 3-digit MNC
128 * configure: add --enable-werror
129 * cosmetic: abis_nm: use osmo_cell_global_id, parse 3-digit MNC
130 * fixup: apply mnc3 change also in ipaccess/network_listen.c
131 * vty: drop unused vty definitions (*_NODE, msc_*)
132 * gsm0408_test: drop LAI encoding test
133 * range_enc_arfcns: avoid runtime error on zero size
134 * fix gsm0408_test: properly free bts struct after each test
135 * move init from gsm_bts_alloc_register() to gsm_bts_alloc(); fix gsm0408_test
136 * cosmetic: gsm0408_test: drop unused arg from bts_init()
137 * ctx cleanup: use non-NULL talloc ctx for osmo_init_logging2()
138 * vty: re-add 'timeout-ping' and 'timeout-pong' as dummy commands
139 * resurrect meas_feed.c from openbsc.git history
140 * resurrect meas_feed.c: make it compile, add logging
141
142 [ Max ]
143 * Check OML state per-BTS
144 * OML: consider administrative state when reporting
145 * cosmetic: remove obsolete ROLE_BSC
146 * cosmetic: tighten function type signatures
147 * cosmetic: drop unused include
148 * cosmetic: mark gsm_objclass2mo as static
149 * OML: expand status reporting checks
150 * Generate SI2ter Rest Octets
151 * Generate SI2bis Rest Octets
152 * Fix tests after rate_ctr change
153 * Remove unneeded .py scripts
154 * Enable sanitize for CI tests
155 * Migrate from OpenSSL to osmo_get_rand_id()
156 * Add optional profiling support
157 * Fix .deb builds
158 * Check and handle SMS encoding failure
159 * Remove obsolete ./configure option
160 * cosmetic: remove duplicated code
161 * RSL: print link state per-TRX
162 * vty: fix OML link state printing
163 * cosmetic: log prim operation as text
164
165 [ Philipp Maier ]
166 * mgcp: use osmo-mgw to switch RTP streams
167 * cosmetic: remove distracting newline
168 * cosmetic: reorder case list
169 * cosmetic: replace term MGCP-GW with MGW
170 * mgcp: add missing out state
171 * mgcp: remove unused variable
172 * reset: remove name variable from reset context
173 * doc: add example configuration for osmo-mgw
174 * auth: remove obsolete VTY commands
175 * bssap: remove libosmo-legacy-mgcp dependancy
176 * sccp-lite: remove obsolete VTY commands
177 * auth: remove unused structs
178 * auth: remove obsolete VTY commands
179 * mgcp: use hexadecimal digits in endpoint names
180 * mgcp: use mgw assigned connection identifiers
181 * mgcp: add missing switch case
182 * mgcp: do not fail silently on snprintf()
183 * cosmetic: remove duplicate logging
184 * cosmetic: do not cast void pointer
185 * cosmetic: add missing log prefix
186 * cosmetic: correct sourcecode formatting
187 * cosmetic: use fsm pointer from parameter list
188 * mgcp: cosmetic fixups
189 * paging: paging_flush_bts: be sure pending_requests is initalized
190 * cosmetic: osmo_bsc_mgcp: improve comments
191 * mgcp: cancel transactions on timeout
192 * mgcp: validate rtp connection data in MGW response (ip/port)
193 * mgcp: log file and line of calls to handle_error()
194 * cosmetic: mgcp: remove duplicate logging
195 * abis_rsl: permit first EstablishInd only on SAPI=0
196 * abis_rsl: do not allow SACCH in MF mode on SAPI=0
197 * SIGTRAN: correct wrong log category
198 * bsc_api: drop unknown RR messages.
199 * paging: page all bts when no cell is associated
200 * paging: fix paging attemt rate counter
201 * a_reset: Add FSM event names
202 * gsm_data: use feature list from libosmocore
203 * bsc_vty: display bts features in show bts
204 * cosmetic: remove unused enum members
205 * cosmetic: fix typo
206 * cosmetic: fix argument order of forward_dtap()
207 * cosmetic: remove needless fixme note.
208 * cosmetic: fix incomplete sentence in comment.
209 * Cosmetic: fix missing semicolon after osmo-assert
210 * cosmetic: remove dead code and obsolete fixmes
211 * cosmetic: remove old, already commented-out code
212 * ipaccess: make ipaccess-config build again
213 * bs11: make bs11_config build again
214 * cosmetic: remove dead code: osmo_bsc_reset.c
215 * gscon: fix illegal state transitions
216 * cosmetic: remove dead code
217 * cosmetic: Add fixme note for OS#3112
218 * inform A-RESET FSM about MSC CR timeouts
219 * gscon: fix assignment of signalling channels
220 * cosmetic: Add note about libosmo-legacy-mgcp to configure.ac
221
222 [ Harald Welte ]
223 * debian: Add dependency to libosmo-mgcp-client-dev
224 * debian: Increase required libosmo-legacy-mgcp-dev version
225 * configure.ac/debian: Require libosmo-mgcp-client-dev >= 1.2.0
226 * osmo-bsc: Print NOTICE message on unimplemented BSSMAP UDT
227 * Move many counters from BSC-global to per-BTS granularity
228 * rate_ctr: Use ':' as separator, not '.'
229 * Remove 'msc' counter group from BSC
230 * Change T3101 default from 10s to 3s.
231 * paging.c: add more documentation on what the functions actually do
232 * paging: Remove obsolete paging call-back support
233 * paging: Stop all paging if MSC sends us BSSMAP RESET
234 * Fix per-BTS counter group index
235 * libbsc: paging: more reasonable (and detailed) paging statistics
236 * Reduce T3113 default from 60s to 10s
237 * Add per-BTS rate_ctr for total + failed number of RSL CHAN_ACT
238 * Add new per-BTS "rsl:unknown" counter to count unknown RSL messages
239 * Add a new counter "rsl:ipa_nack" to count number of IPA related NACKs
240 * Add new "chan:mode_modify_nack" counter to count RSL MODE MODIFY NACK
241 * Remove dead code left over from NITB split
242 * Remove unused RRLP options/codec
243 * Remove bogus vty config for LU reject cause
244 * Remove bogus MM INFO configuration
245 * Remove some more dead code
246 * remove libosmo-sccp dependency for osmo-bsc
247 * osmo_bsc_bssap.c: Spelling fixes in comment
248 * Remove unused struct osmo_bsc_sccp_con member sccp_queue_size
249 * osmo_bsc.h: document every field in 'struct osmo_bsc_sccp_con'
250 * osmo-bsc: Move user plane/voice related bits into sub-structure
251 * gsm_data.h: Document all fields of gsm_subscriber_connection
252 * remove unused 'lac' member of 'struct gsm_subscriber_connection'
253 * BSC: Add "show subscriber all" command
254 * BSC: Fix bsc_subsc leak on paging
255 * bsc_test.c: Use proper network/bts/lchan structures
256 * cosmetic: Hide all accesses to conn->bts behind conn_get_bts()
257 * Reduce T3109 default from 19s to 5s
258 * Make libcommon, libcommon-cs, libfilter, utils depend on mgcp/sigtran
259 * cosmetic: Remove data/len variables in bssmap_handle_assignm_req()
260 * bssmap_handle_assignm_req(): Decode channel type as first step
261 * remove obsolete gsm_subscriber_connection.bts member
262 * update.gitignore with 'tags' files and 'deps' directory
263 * gsm_data_shared.h: Remove unused sacch_deact member field
264 * vty: print RTP IP of lchan if actually bound; print remote (mgw) IP
265 * osmo-bsc: Add talloc context introspection via VTY
266 * Structural reform: Get rid of osmo_bsc_sccp_con
267 * vty: Permit codec-list containing both full-rate and half-rate codecs
268 * logging: Remove obsolete log categories
269 * Permit set of multiple different A5 ciphers
270 * bssmap_handle_assignm_req(): Use proper cause values
271 * bssmap_handle_assignm_req(): Use more conscise error/log message texts
272 * bssmap_handle_assignm_req(): Don't print log statemens in malloc failure case
273 * chan_compat_with_mode: signalling works over all channel types
274 * osmo-bts/nanobts: Set RACH_Busy Threshold to -90 dBm
275 * Align syntax of "handover" + "assignment" command with that of lchan act/deact
276 * Revert "Generate the S_L_INP_TEI_UP signal earlier."
277 * bsc_vty: Merge more VTY documentation string #defines
278 * sysinfo: Fix regression causing missing L2 Pseudo-Length in SI5/SI6
279 (Closes: #3059)
280 * introduce an osmo_fsm for gsm_subscriber_connection
281 * cosmetic: Fix infinite number of formatting errors in gscon_fsm_states
282 * abis_nm: Improve and fix OML logging
283 * paging: Unify formatting of log messages with (bts=%d) prefix
284 * RR: Send RR STATUS in case of unsupported/unknown message
285 * BSSAP: Fix test_codec_pref() implementation for AMR
286 * BSSAP: document match_codec_pref() more thoroughly
287 * GSCON FSM: Fix argument order when calling gsm0808_assign_req()
288 * bssmap: State correct speech codec in ASSIGNMENT COMPLETE
289 * Start Dynamic PDCH Initialization after RSL is up
290 * "show timeslot": Show dynamic PDCH state also for Osmocom-style dyn PDCH
291
292 [ Alexander Couzens ]
293 * debian: remove doublicated project name in example files
294 * use _NUM_CHREQ_T to define the size of ctype_by_chreq
295 * pcuif_proto.h: fix whitespaces and indention
296 * pcuif_proto.h: add features of version 7 (txt indication)
297
298 [ Pau Espin Pedrol ]
299 * tests: Fix selection of python version
300 * Use type bool for boolean fields in gsm48_si_ro_info
301 * vty: Add cmd to configure 3g Early Classmark Sending
302 * cosmetic: bsc_vty: Fix trailing whitespace
303 * cosmetic: bsc_vty: Document bvci reserved values
304 * osmo_bsc_bssap.c: Fix discard of const qualifier in assignment
305 * debian: Move abisip-find from osmo-bsc to its own package
306 * abisip-find: Add option to bind to a specific source address
307 * abisip-find: Force stdout buffer flush
308 * abisip-find: Add --format-json option
309 * ipaccess-config: Enable logging all categories to print errors
310 * ipaccess-config: Add missing path with log error
311 * ipaccess-config: Improve handling of last parameter
312 * abisip-find: Improve use information output
313 * ipaccess-config: Check cmdlie arg unit-id format
314 * bsc_api.c: bsc_handle_lchan_signal: Remove unused variable
315 * bsc_subscr_conn_fsm.c: Fix wrong param list passed to LOGPFSML
316 * tests: handover_test.c: Add missing header
317 * pcu_sock.c: Avoid breaking strict-aliasing on ptr derreference
318 * contrib: jenkins.sh: Add --enable-werror flag
319 * contrib: osmo-bsc.service: Update description
320 * contrib: osmo-bsc.service: Fix osmo-mgw.service dependency
321 * libbsc: nokia_site: Fix uninitialized return val
322 * bsc_vty: Fix uninitialized var false positive on gcc 7.3.1
323 * paging: paging_request_bts: Fix wrong return value
324 * bssap: Log non handled paging requests
325 * libbsc: set_net_mcc_mnc_apply: Fix memleak on parsing incorrect mcc mnc
326 * bsc_nat: ctrl: fix memleak on reply receival
327 * bsc_nat: forward_to_bsc: remove one level of indentation
328 * bsc_nat: forward_to_bsc: Fix memleak on send failure
329 * bsc_nat: Drop redundant ccon ptr in bsc_cmd_list
330 * bsc_nat: ctrl: Fix crash on receveing bsc reply
331 * use osmo_init_logging2
332 * chan_alloc.c: Fix log var formatting issues
333 * abis_rsl.c: abis_rsl_rx_cchan: Print msg type name for unimplemented messages received
334 * abis_rsl.c: Clean ericsson specific imm assign code
335 * gsm_data_shared.h: Remove unused enum gsm_paging_event
336
337 [ Stefan Sperling ]
338 * Fix "CTRL GET msc_connection_status" response.
339 * Support control connection status query for a particular MSC.
340 * Implement support for paging by LAI.
341 * Add TAGS files (produced by 'make tags') to .gitignore file.
342 * Implement support for CELL_IDENT_NO_CELL.
343 * Implement support for paging based on CI (cell identifier).
344 * Move BTS selection for paging from osmo_bsc_grace.c into osmo_bsc_bssap.c.
345 * Implement support for paging based on a Cell Global Identifier.
346 * Implement support for paging based on LAC and CI.
347 * Show the BTS number for outgoing paging commands in debug log.
348 * Split paging cases in bssmap_handle_paging() off into helper functions.
349 * Remove an unused variable.
350 * Improve an error message in page_lai_and_lac()
351 * Make "waiting indicator" of IMMEDIATE ASSIGN REJECT dynamic.
352 * Add stat items for the BTS's channel load average and T3122.
353 * Make RSL connection attempts time out.
354 * fix handover_test link error
355 * Add support for Access Control Class ramping.
356 * Generate the S_L_INP_TEI_UP signal earlier.
357 * use libosmocore to parse cell identifiers in osmo-bsc
358 * fix an error message in bssmap_handle_paging()
359 * change return type of page_subscriber() to void
360 * Generate the S_L_INP_TEI_UP signal earlier.
361 * fix a format string error in bts_update_t3122_chan_load()
362 * fix initialization of acc ramping
363 * only log actual access control class ramping changes
364 * ensure that acc_ramp_init() is only called once
365 * trigger acc ramping based on trx rf-locked state
366 * rename helper functions in the acc ramp code to avoid confusion
367 * trigger acc ramping on state-changed-event reports
368 * only trigger acc ramping if trx 0 is usable and unlocked
369 * fix handling of state changes in acc ramping
370 * properly skip paging is OML link is down
371 * extend documentation of paging_flush_bts()
372 * flush paging when RSL link is dropped
373
374 [ Vadim Yanitskiy ]
375 * bsc/gsm_04_80.h: use '#pragma once' instead of includes
376 * bsc/gsm_04_80.h: clean up useless declarations
377 * libbsc/bsc_vty.c: prevent uninitialized access
378 * doc/examples: use NECI = 1 by default
379
380 [ Ivan Kluchnikov ]
381 * handover_decision: Fix condition for power budget handover attempt
382 * handover_decision: log HO causes more accurately
383
384 [ Andreas Eversberg ]
385 * HO: Send Channel Mode and Multirate IE along with handover command
386 * HO: Add function to count currently ongoing handovers to a given BTS
387 * Fix: If paging for half rate was requested, use hr, if supported by MS
388 * HO: Assign SDCCH on channel request
389 * Fix of checking TCH rate at chan_compat_with_mode
390 * HO: Count the actual meas.rep. get_meas_rep_avg fails if not reached
391 * HO: Count neighbor measurements and reduce window of neigh_meas_avg
392 * HO: Changed availablilty of ts_is_usable() from static to extern
393 * HO: Always update rqd_ta after receiving measurement report
394 * HO: If handover logic is used to do assignment, signal assignment result
395 * HO: Add handover decision debugging category
396 * Do not perform assignment, if the new channel equals the current one
397 * Allow assignment to TCH channel with signalling only mode
398 * Correctly set T3105 for ipaccess BTS type
399 * HO: fix: increase the number of measurement report history to 10
400 * HO: Change debug category at handover decision: DHO -> DHODEC
401 * HO: Count number of free timeslot on a given BTS
402 * HO: add queue to cache DTAP messages during handover/assignment
403 * Fix: meas_rep.c will only use valid DL measurement reports
404 * HO: Add a penalty timer list to the subscriber connection entity
405
406 [ Keith ]
407 * Cosmetic: Fix typo: Siganlling->Signalling
408
409 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 18:40:11 +0200
410
Harald Weltef3fb5f32017-10-29 09:03:34 +0100411osmo-bsc (1.1.2) unstable; urgency=medium
412
413 * Debian: depend on libosmo-sigtran (bsc) and libosmo-sccp (bsc-nat)
414 * debian/control: Specify versions of packages we depend upon
415
416 -- Harald Welte <laforge@gnumonks.org> Sun, 29 Oct 2017 09:03:33 +0100
417
Harald Welted1225f32017-10-28 21:49:01 +0200418osmo-bsc (1.1.1) unstable; urgency=medium
419
420 [ Neels Hofmeyr ]
421 * jenkins: use osmo-clean-workspace.sh before and after build
422
423 [ Harald Welte ]
424 * Debian: re-introduce missing build dependency to libssl-dev
425
426 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 21:49:00 +0200
427
Harald Welte9bce2bd2017-10-28 11:19:03 +0200428osmo-bsc (1.1.0) unstable; urgency=medium
429
430 [ Alexander Couzens ]
431 * Initial release.
432 * debian/rules: show testsuite.log when tests are failing
433
434 [ Neels Hofmeyr ]
435 * jenkins: fix build: osmo-mgw from master, not pre_release
436 * drop files unrelated to osmo-bsc
437 * rename openbsc.pc to osmo-bsc.pc
438 * rewrite README
439 * move include/openbsc to include/osmocom/bsc
440 * drop MGCP client from osmo-bsc
441 * fix vty tests: vty no longer goes to parent node implicitly
442 * doc/examples: tweak osmo-bsc.cfg, add osmo-bsc_custom-sccp.cfg
443 * add ';' after OSMO_ASSERT()
444
445 [ Harald Welte ]
446 * configure.ac: No more libosmogb dependency
447 * configure.ac: remove --enable-osmo-bsc, --enable-nat
448 * configure.ac: remove smpp_mirror, which has no relation to a BSC
449 * contrib/jenkins.sh: MGCP is unconditional now
450 * configure.ac: Remove --enable-mgcp-transcoding
451 * configure.ac: Remove --enable-iu
452 * configure.ac: Remove checks for libgtp + c-ares
453 * configure.ac: Remove check for GMTOFF
454 * configure.ac: Package is now called osmo-bsc, not openbsc
455 * libbsc: document arguments of generate_bcch_chan_list()
456 * Make sure BA-IND in all SI2xxx is '0' and in all SI5xxx is '1'
457 * gsm0408_test: Verify that BA-IND is 0 in SI2xxx and 1 in SI5xxx
458 * .gitignore: Update to post-NITB-split realities
459 * Remove any references to RANAP and Iu
460 * Fix nanobts_omlattr unit test
461 * nanobts_omlattra_test: Initialize logging before executing tests
462 * osmo-bsc: Initialize logging before initializing rate_ctr
463 * Rename osmo_fsm to avoid illegal space in name + more meaningful name
464
465 [ Max ]
466 * Make TRX rf locking more visible
467 * SI13: drop PBCCH-related bits
468 * Wrap channel state assignment in macro
469 * Further cleanup leftovers from BSC/MSC split
470 * CTRL: cleanup write-only command functions
471 * Show OML link uptime in vty
472 * Fix repo split aftermath
473 * SI2q: cleanup UARFCN addition
474 * OML: consider RSL link state
475 * SI2q: fix generation for multiple UARFCNs
476 * Remove pkg-config file
477 * ctrl: add oml-uptime command
478 * SI1q: fix EARFCN appender
479
480 [ Pau Espin Pedrol ]
481 * Remove unneeded dbi dependency
482 * bsc_api: Fix NULL secondary_lchan access in handle_ass_fail
483 * libbsc: Use correct printf formatting for uint64_t
484 * bsc_vty: Improve description of mid-call-text cmd
485
486 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 11:19:03 +0200
487
Alexander Couzens77ac7af2017-08-07 07:57:20 +0000488osmo-bsc (0.1.0) UNRELEASED; urgency=low
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200489
Harald Welte9bce2bd2017-10-28 11:19:03 +0200490 [ Alexander Couzens ]
491 * Initial release.
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200492
Alexander Couzens77ac7af2017-08-07 07:57:20 +0000493 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:12:56 +0000