blob: 2e07507ef9d50b9ed6e25f69b61c1ec993d72297 [file] [log] [blame]
Pau Espin Pedrol08d02dd2018-07-27 19:25:05 +02001osmo-bsc (1.3.0) unstable; urgency=medium
2
3 [ Philipp Maier ]
4 * a_reset: cleanup + remove dead code
5 * gscon: remove dead code
6 * gscon: pick suitable payload type / encoding name for MGCP
7 * lcls: set codec info when performing MGW operation
8 * codec_pref: move match_codec_pref() to separate c-file and add unit-test
9 * codec_pref: check bts codec support
10 * chan_alloc: reset rtp voice related bits in lchan_free()
11 * rsl: use 3GPP assigned payload type constants from libosmo-netif
12
13 [ Stefan Sperling ]
14 * show all global counters of osmo-bsc in vty
15 * add counter for connection attempts from BTS with unknown unit id
16 * fix misaligned memory write access in abis_nm_ipaccess_rsl_connect()
17 * increment 'paging responded' counter for active paging only
18 * fix handling of invalid pchan names in vty
19
20 [ Pau Espin Pedrol ]
21 * nat: Add jitter buffer on the uplink receiver
22 * acc_ramp: Increase log level of some messages
23 * chan_alloc: Print bts nr on chan alloc failure
24 * abis_rsl.c: Fix whitespace
25 * abis_rsl: rsl_rx_chan_rqd: Format bts log string as in everywhere else
26 * pcu_sock: Log event pcu_sock created
27 * osmo-bsc: Clean help description of cmd line parameters
28 * osmo-bsc: Add -V param to print version
29 * debian: Move meas related binaries into new package osmo-bsc-meas-utils
30 * bsc-filter: Remove unused func barr_adapt and set barr_find static
31 * bsc_vty: Write access list entries when storing bsc config
32 * Init access_lists before passing it as a parameter
33 * Rename bsc_msg_acc_lst_vty_init to have more uniform prefix
34 * filter: vty: Print policy list in cmd show access-list
35 * filter: Replace '.' in counter names with ':'
36 * filter: Allocate each ctr group with a different idx
37 * ctrl: Avoid sending back received ERROR msgs
38
39 [ Neels Hofmeyr ]
40 * bsc_api.c: actually log with context
41 * abis_rsl.h: drop unused rsl_chan_activate() declaration
42 * cosmetic: bsc_dyn_ts.c: make local functions static
43 * cosmetic: define TCH_F_PDCH_PENDING_MASK as actual bitwise or
44 * cosmetic: logging and ordering in handle_ass_compl()
45 * doc: add msc charts on Assignment/Handover internals
46 * tests: remove bssap_test
47 * tests: remove channel_test
48 * bsc_test: drop "scan to MSC" code path
49 * dissolve libbsc: move all to src/osmo-bsc, link .o files
50 * remove struct bsc_api
51 * cosmetic: magic number: use RSL_ACT_ constant for chan act
52 * cosmetic: gscon: undup code: add common assignment_failed()
53 * assignment: signal assignment failure on chan act nack
54 * log: fix logging in rsl_rx_chan_act_nack()
55 * log: assignment: add two logs on unexpected lchan release
56 * use libosmocore's gsm0808_permitted_speech(), gsm0808_chosen_channel()
57 * cosmetic: penalty timers: constify, tweak doc
58 * cosmetic: bsc_subscr_alloc: log initial get
59 * gscon: put subscriber a little later
60 * try to pick up subsrc IMSI on l3-compl
61 * store subscriber identity on paging
62 * cosmetic: handover_test: add IMSI to subscr for logging
63 * doc: tweak msc charts on Assignment/Handover: act_timer
64 * doc: add lchan-release.msc
65 * doc: add ms-channel-request.msc
66 * doc: charts: illustrate new plan for ts and lchans
67 * cosmetic: gscon: drop odd use of OSMO_STRINGIFY
68 * HO: introduce T7, T8, T101 timers
69 * drop dead code: conn->T10, handled by gscon instead
70 * make T10 configurable like the rest of them
71 * fix dyn TS init: properly identify BTS on OML OPSTART ACK
72 * cosmetic / linking: move str_to_imsi() out of abis_rsl.c
73 * cosmetic: name osmo-bsc's root ctx 'osmo-bsc', not 'openbsc'
74 * call osmo_xua_msg_tall_ctx_init()
75 * fix handover start: dealloc ho if event not permitted
76 * ho cfg: fix unit strings
77 * hodec2 log: less verbose, more concise logging
78 * various logging: fix missing/extra newlines
79 * BTS codec pref legacy compat: allow all codecs per default
80
81 [ Harald Welte ]
82 * bsc: Fix check for MSC-side FSM allocation failure
83 * vty: Permit selection of other ASP protocol than M3UA
84 * bsc: Add mgcp_port_to_cic() to determine CIC from RTP Port
85 * bsc: Use correct MGCP endpoint name for IPA/SCCPlite
86 * bsc: Don't reject ASSIGNMENT for Audio in IPA/SCCPlite case
87 * bsc: Don't include AoIP IEs in ASSIGNMENT COMPLETE over SCCPlite
88 * bsc: Don't create MSC-side MGCP connection in IPA/SCCPlite case
89 * remove remaining bits of osmo-bsc_nat
90 * Remove 'struct bsc_msc_connection' + fix IPA-encapsulated CTRL
91 * move 'extern struct gsm_network *bsc_gsmnet" to header file
92 * VTY: Print some more information in "show conns"
93 * Add initial 3GPP LCLS support to OsmoBSC
94 * LCLS: add VTY config to enable/disable LCLS on per-MSC basis
95 * Reject ASSIGNMENT REQ with CIC but no AoIP transp addr in AoIP case
96 * Ignore "dest" command in MSC node
97 * Explicitly register CTRL-over-IPA callback with libosmo-sigtran
98 * Remove unused logging subsystems DCC and DMGCP
99 * remove traces of osmo-bsc_nat in python test (osmoappdesc/test_runner)
100 * Add missing event string name for GSCON_EV_LCLS_FAIL
101 * bsc_subscr_conn_fsm: BSC must not release SCCP connection
102 * absi_rsl: Fix segfault in rsl_rx_conn_fail()
103
104 [ Daniel Willmann ]
105 * git-version-gen: Don't check for .git directory
106
107 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 19:25:05 +0200
108
Pau Espin Pedrole5a96652018-05-15 14:10:38 +0200109osmo-bsc (1.2.1) unstable; urgency=medium
110
111 [ Philipp Maier ]
112 * bsc_api/GSCON: prevent unnecessary channel mode modifications
113
114 [ Neels Hofmeyr ]
115 * resurrect meas_feed.c: vty, vty-test
116 * dyn ts, bts_ipaccess_nanobts.c: init PDCH on Chan OPSTART ACK
117 * dyn TS, assignment: set lchan state to LCHAN_S_ACT_REQ in the proper place
118 * dyn TS, assignment: allow switch from PDCH with associated conn
119 * dyn TS: init only when both RSL and the Channel OM are established
120 * dyn TS: allow any pchan type changes, fix for gprs mode none
121 * debug log: verbosely log all lchan alloc choices
122 * deprecate dyn_ts_allow_tch_f and by default allow all TCH
123 * fix default fallbacks in audio_support_to_gsm88()
124 * log: indicate hr/fr in audio_support_to_gsm88() error
125 * cosmetic: dyn ts init: undup logging for gprs = none
126
127 [ Vadim Yanitskiy ]
128 * osmo_bsc_vty.c: fix: write MGW configuration
129
130 -- Pau Espin Pedrol <pespin@sysmocom.de> Tue, 15 May 2018 14:10:38 +0200
131
Pau Espin Pedrol1b11bc82018-05-03 18:40:12 +0200132osmo-bsc (1.2.0) unstable; urgency=medium
133
134 [ Neels Hofmeyr ]
135 * vty: skip installing cmds now always installed by default
136 * bssap: paging: page entire BSS for unimplemented cell id list
137 * fix build: bssap test broke by undefined references
138 * osmo-bsc RESET FSM: use distinct struct names
139 * osmo-bsc: SCCP addrs: default only if unset, reject invalid
140 * osmo-bsc vty: be fatal for addressbook entry errors
141 * use osmo_sccp_inst_addr_name() instead of looking up ss7
142 * add --enable-sanitize config option
143 * bsc_init: fix Werror: define rc for 2quater with si2q_count == 0
144 * bsc filter: don't ignore imsi-allow on "global" filter level
145 * compiler warnings: drop some unused variables
146 * compiler warnings: constify in abis_nm.c
147 * cleanup: drop unused gsm_bts.role
148 * compiler warnings: add includes in abis_rsl.h, gsm_data_shared.h
149 * cosmetic: handover.h: use "#pragma once", declare structs, comments
150 * examples: add osmo-bsc-minimal.cfg
151 * HO prep: pass gsm_network to gsm_bts_alloc() already
152 * fix segfault upon release paging on BSSMAP Reset: init llist
153 * log typo fix in gsm0808_cipher_mode()
154 * debug log: log Cipher Mode info upon sending down RSL/A-bis
155 * fix bssmap_handle_cipher_mode()'s encryption decision
156 * abisip-find: add getopt option parsing in preparation for a new option
157 * abisip-find: add -l to list base stations instead of streaming replies
158 * abisip-find: update copyright
159 * abisip-find: add timeout option
160 * abisip-find: add --interval option
161 * vty: fix 'show lchan ...' arg [lchan_nr] to [<0-7>]
162 * vty: change handover command's arg LCHAN_NR to <0-7>
163 * vty: cosmetic: use common BTS, TRX, TS, LCHAN strings
164 * vty: add various manual handover and assignment trigger commands
165 * osmo_bsc_mgcp: cosmetic: introduce mgcp_init(), soak up fsm init
166 * HO: fix recovery from failed handover
167 * HO prep: introduce per-BTS handover config, with defaults on net node
168 * HO: add indicators for inter-cell and async ho, use for chan act type
169 * cosmetic: explicitly init ho_ref start value
170 * fixup: neigh_meas_avg: detect invalid window size as <=0, log if invalid
171 * fixup: neigh_meas_avg: fix condition to reduce window size
172 * HO: enable handover by initializing at startup; rename init function
173 * HO: add handover algo 2 parameters; skip HO 1 if HO 2 is configured
174 * HO: rename gsm_bts_neighbor() to bts_by_arfcn_bsic()
175 * HO: make bts_by_arfcn_bsic() public
176 * libcommon: eliminate bsc_version.c
177 * libcommon: eliminate common_vty.c
178 * libcommon: eliminate debug.c
179 * libcommon: eliminate socket.c
180 * libcommon: eliminate talloc_ctx.c
181 * ipaccess-proxy: don't redefine tall_bsc_ctx
182 * libcommon: join gsm_data_shared.* into gsm_data.*
183 * drop libcommon completely, move remaining files to libbsc
184 * libcommon-cs: move a_reset.c into libbsc
185 * libcommon-cs: move gsm_network_init() into bsc_network_init()
186 * gsm_network: drop unused trans_list
187 * libcommon_cs: move gsm48 bits to libbsc
188 * libcommon-cs: move vty bits to libbsc/bsc_vty.c
189 * common_cs.h: mv gsm_encr to gsm_data.h
190 * drop libcommon-cs completely
191 * drop unused common.h
192 * gsm_network: drop unused subscr_epxire_timer
193 * vty: 'show bts': write '(none)' if none are found.
194 * vty: 'show bts': fix indenting
195 * bts chan_load: ignore unusable BTS
196 * handover_logic.c: always do inter-cell channel activation
197 * handover_logic.c: on HO command, send new lchan's MS power
198 * HO: process_meas_rep: guard against modulo zero
199 * HO: cosmetic: bsc_handover_start(): "fix" memcpy for AMR config
200 * HO: add new_lchan_type arg to bsc_handover_start()
201 * HO: cosmetic: bsc_handover_start_lchan_change(): tweak local vars
202 * HO: always do async handover
203 * HO: bsc_handover_start_lchan_change(): set MS to max power on handover
204 * HO: logging: more logs, and more concise logging
205 * HO: move penalty timers to own file as proper API
206 * HO: store speech codec list from BSSMAP Assignment in conn
207 * HO: cfg: tweak vty write
208 * vty: 'show bts': list the TRXs' ARFCNs
209 * vty: 'show bts': print neighbor cells
210 * HO: cfg: separate hodec1 from hodec2 parameters
211 * HO: lchan: store last seen measurement report nr, tweak log
212 * HO: clearly mark conn penalty timer member for hodec2
213 * HO: cosmetic: handover_decision.c: make process_meas_rep() return void
214 * HO: introduce ho decision callbacks
215 * HO: cosmetic: getting a chan activ nack on a non-ho lchan is not an error
216 * HO: Implement load based handover, as handover_decision_2.c
217 * HO: vty: rename ho decision 1 vty to 'handover1' with 'handover' alias
218 * cosmetic: adjust copyrights on handover_cfg.c,_vty.c
219 * HO: vty: clearly mark 'handover foo' as legacy alias for 'handover1 foo'
220 * drop unused libbsc/meas_proc.c
221 * HO: fix minor issues found by coverity
222 * bsc_api.c: fix log string format
223 * fix build: gprs_ra_id_by_bts(): ensure to init all values
224 * compiler warning: chan_compat_with_mode(): clearly handle all enum vals
225 * add test for gsm48_ra_id_by_bts()
226 * add test for abis_nm_ipaccess_cgi()
227 * ctrl_test_runner: add tests for 3-digit MNC
228 * gsm48_ra_id_by_bts(): struct gsm48_ra_id* instead of buf
229 * cosmetic: bsc_network_init(): imply default 001-01 PLMN
230 * implement support for 3-digit MNC with leading zeros
231 * gsm48_parse_meas_rep(): set num_cell=0 if no neighbor cells are reported
232 * cosmetic: hodec2: log nr of neighbors in meas report
233 * cosmetic: typo in log: handover_decision2.c: 'measuements'
234 * handover_test: explicitly wrap abis_rsl_sendmsg()
235 * pcu_if: implement support for 3-digit MNC
236 * configure: add --enable-werror
237 * cosmetic: abis_nm: use osmo_cell_global_id, parse 3-digit MNC
238 * fixup: apply mnc3 change also in ipaccess/network_listen.c
239 * vty: drop unused vty definitions (*_NODE, msc_*)
240 * gsm0408_test: drop LAI encoding test
241 * range_enc_arfcns: avoid runtime error on zero size
242 * fix gsm0408_test: properly free bts struct after each test
243 * move init from gsm_bts_alloc_register() to gsm_bts_alloc(); fix gsm0408_test
244 * cosmetic: gsm0408_test: drop unused arg from bts_init()
245 * ctx cleanup: use non-NULL talloc ctx for osmo_init_logging2()
246 * vty: re-add 'timeout-ping' and 'timeout-pong' as dummy commands
247 * resurrect meas_feed.c from openbsc.git history
248 * resurrect meas_feed.c: make it compile, add logging
249
250 [ Max ]
251 * Check OML state per-BTS
252 * OML: consider administrative state when reporting
253 * cosmetic: remove obsolete ROLE_BSC
254 * cosmetic: tighten function type signatures
255 * cosmetic: drop unused include
256 * cosmetic: mark gsm_objclass2mo as static
257 * OML: expand status reporting checks
258 * Generate SI2ter Rest Octets
259 * Generate SI2bis Rest Octets
260 * Fix tests after rate_ctr change
261 * Remove unneeded .py scripts
262 * Enable sanitize for CI tests
263 * Migrate from OpenSSL to osmo_get_rand_id()
264 * Add optional profiling support
265 * Fix .deb builds
266 * Check and handle SMS encoding failure
267 * Remove obsolete ./configure option
268 * cosmetic: remove duplicated code
269 * RSL: print link state per-TRX
270 * vty: fix OML link state printing
271 * cosmetic: log prim operation as text
272
273 [ Philipp Maier ]
274 * mgcp: use osmo-mgw to switch RTP streams
275 * cosmetic: remove distracting newline
276 * cosmetic: reorder case list
277 * cosmetic: replace term MGCP-GW with MGW
278 * mgcp: add missing out state
279 * mgcp: remove unused variable
280 * reset: remove name variable from reset context
281 * doc: add example configuration for osmo-mgw
282 * auth: remove obsolete VTY commands
283 * bssap: remove libosmo-legacy-mgcp dependancy
284 * sccp-lite: remove obsolete VTY commands
285 * auth: remove unused structs
286 * auth: remove obsolete VTY commands
287 * mgcp: use hexadecimal digits in endpoint names
288 * mgcp: use mgw assigned connection identifiers
289 * mgcp: add missing switch case
290 * mgcp: do not fail silently on snprintf()
291 * cosmetic: remove duplicate logging
292 * cosmetic: do not cast void pointer
293 * cosmetic: add missing log prefix
294 * cosmetic: correct sourcecode formatting
295 * cosmetic: use fsm pointer from parameter list
296 * mgcp: cosmetic fixups
297 * paging: paging_flush_bts: be sure pending_requests is initalized
298 * cosmetic: osmo_bsc_mgcp: improve comments
299 * mgcp: cancel transactions on timeout
300 * mgcp: validate rtp connection data in MGW response (ip/port)
301 * mgcp: log file and line of calls to handle_error()
302 * cosmetic: mgcp: remove duplicate logging
303 * abis_rsl: permit first EstablishInd only on SAPI=0
304 * abis_rsl: do not allow SACCH in MF mode on SAPI=0
305 * SIGTRAN: correct wrong log category
306 * bsc_api: drop unknown RR messages.
307 * paging: page all bts when no cell is associated
308 * paging: fix paging attemt rate counter
309 * a_reset: Add FSM event names
310 * gsm_data: use feature list from libosmocore
311 * bsc_vty: display bts features in show bts
312 * cosmetic: remove unused enum members
313 * cosmetic: fix typo
314 * cosmetic: fix argument order of forward_dtap()
315 * cosmetic: remove needless fixme note.
316 * cosmetic: fix incomplete sentence in comment.
317 * Cosmetic: fix missing semicolon after osmo-assert
318 * cosmetic: remove dead code and obsolete fixmes
319 * cosmetic: remove old, already commented-out code
320 * ipaccess: make ipaccess-config build again
321 * bs11: make bs11_config build again
322 * cosmetic: remove dead code: osmo_bsc_reset.c
323 * gscon: fix illegal state transitions
324 * cosmetic: remove dead code
325 * cosmetic: Add fixme note for OS#3112
326 * inform A-RESET FSM about MSC CR timeouts
327 * gscon: fix assignment of signalling channels
328 * cosmetic: Add note about libosmo-legacy-mgcp to configure.ac
329
330 [ Harald Welte ]
331 * debian: Add dependency to libosmo-mgcp-client-dev
332 * debian: Increase required libosmo-legacy-mgcp-dev version
333 * configure.ac/debian: Require libosmo-mgcp-client-dev >= 1.2.0
334 * osmo-bsc: Print NOTICE message on unimplemented BSSMAP UDT
335 * Move many counters from BSC-global to per-BTS granularity
336 * rate_ctr: Use ':' as separator, not '.'
337 * Remove 'msc' counter group from BSC
338 * Change T3101 default from 10s to 3s.
339 * paging.c: add more documentation on what the functions actually do
340 * paging: Remove obsolete paging call-back support
341 * paging: Stop all paging if MSC sends us BSSMAP RESET
342 * Fix per-BTS counter group index
343 * libbsc: paging: more reasonable (and detailed) paging statistics
344 * Reduce T3113 default from 60s to 10s
345 * Add per-BTS rate_ctr for total + failed number of RSL CHAN_ACT
346 * Add new per-BTS "rsl:unknown" counter to count unknown RSL messages
347 * Add a new counter "rsl:ipa_nack" to count number of IPA related NACKs
348 * Add new "chan:mode_modify_nack" counter to count RSL MODE MODIFY NACK
349 * Remove dead code left over from NITB split
350 * Remove unused RRLP options/codec
351 * Remove bogus vty config for LU reject cause
352 * Remove bogus MM INFO configuration
353 * Remove some more dead code
354 * remove libosmo-sccp dependency for osmo-bsc
355 * osmo_bsc_bssap.c: Spelling fixes in comment
356 * Remove unused struct osmo_bsc_sccp_con member sccp_queue_size
357 * osmo_bsc.h: document every field in 'struct osmo_bsc_sccp_con'
358 * osmo-bsc: Move user plane/voice related bits into sub-structure
359 * gsm_data.h: Document all fields of gsm_subscriber_connection
360 * remove unused 'lac' member of 'struct gsm_subscriber_connection'
361 * BSC: Add "show subscriber all" command
362 * BSC: Fix bsc_subsc leak on paging
363 * bsc_test.c: Use proper network/bts/lchan structures
364 * cosmetic: Hide all accesses to conn->bts behind conn_get_bts()
365 * Reduce T3109 default from 19s to 5s
366 * Make libcommon, libcommon-cs, libfilter, utils depend on mgcp/sigtran
367 * cosmetic: Remove data/len variables in bssmap_handle_assignm_req()
368 * bssmap_handle_assignm_req(): Decode channel type as first step
369 * remove obsolete gsm_subscriber_connection.bts member
370 * update.gitignore with 'tags' files and 'deps' directory
371 * gsm_data_shared.h: Remove unused sacch_deact member field
372 * vty: print RTP IP of lchan if actually bound; print remote (mgw) IP
373 * osmo-bsc: Add talloc context introspection via VTY
374 * Structural reform: Get rid of osmo_bsc_sccp_con
375 * vty: Permit codec-list containing both full-rate and half-rate codecs
376 * logging: Remove obsolete log categories
377 * Permit set of multiple different A5 ciphers
378 * bssmap_handle_assignm_req(): Use proper cause values
379 * bssmap_handle_assignm_req(): Use more conscise error/log message texts
380 * bssmap_handle_assignm_req(): Don't print log statemens in malloc failure case
381 * chan_compat_with_mode: signalling works over all channel types
382 * osmo-bts/nanobts: Set RACH_Busy Threshold to -90 dBm
383 * Align syntax of "handover" + "assignment" command with that of lchan act/deact
384 * Revert "Generate the S_L_INP_TEI_UP signal earlier."
385 * bsc_vty: Merge more VTY documentation string #defines
386 * sysinfo: Fix regression causing missing L2 Pseudo-Length in SI5/SI6
387 (Closes: #3059)
388 * introduce an osmo_fsm for gsm_subscriber_connection
389 * cosmetic: Fix infinite number of formatting errors in gscon_fsm_states
390 * abis_nm: Improve and fix OML logging
391 * paging: Unify formatting of log messages with (bts=%d) prefix
392 * RR: Send RR STATUS in case of unsupported/unknown message
393 * BSSAP: Fix test_codec_pref() implementation for AMR
394 * BSSAP: document match_codec_pref() more thoroughly
395 * GSCON FSM: Fix argument order when calling gsm0808_assign_req()
396 * bssmap: State correct speech codec in ASSIGNMENT COMPLETE
397 * Start Dynamic PDCH Initialization after RSL is up
398 * "show timeslot": Show dynamic PDCH state also for Osmocom-style dyn PDCH
399
400 [ Alexander Couzens ]
401 * debian: remove doublicated project name in example files
402 * use _NUM_CHREQ_T to define the size of ctype_by_chreq
403 * pcuif_proto.h: fix whitespaces and indention
404 * pcuif_proto.h: add features of version 7 (txt indication)
405
406 [ Pau Espin Pedrol ]
407 * tests: Fix selection of python version
408 * Use type bool for boolean fields in gsm48_si_ro_info
409 * vty: Add cmd to configure 3g Early Classmark Sending
410 * cosmetic: bsc_vty: Fix trailing whitespace
411 * cosmetic: bsc_vty: Document bvci reserved values
412 * osmo_bsc_bssap.c: Fix discard of const qualifier in assignment
413 * debian: Move abisip-find from osmo-bsc to its own package
414 * abisip-find: Add option to bind to a specific source address
415 * abisip-find: Force stdout buffer flush
416 * abisip-find: Add --format-json option
417 * ipaccess-config: Enable logging all categories to print errors
418 * ipaccess-config: Add missing path with log error
419 * ipaccess-config: Improve handling of last parameter
420 * abisip-find: Improve use information output
421 * ipaccess-config: Check cmdlie arg unit-id format
422 * bsc_api.c: bsc_handle_lchan_signal: Remove unused variable
423 * bsc_subscr_conn_fsm.c: Fix wrong param list passed to LOGPFSML
424 * tests: handover_test.c: Add missing header
425 * pcu_sock.c: Avoid breaking strict-aliasing on ptr derreference
426 * contrib: jenkins.sh: Add --enable-werror flag
427 * contrib: osmo-bsc.service: Update description
428 * contrib: osmo-bsc.service: Fix osmo-mgw.service dependency
429 * libbsc: nokia_site: Fix uninitialized return val
430 * bsc_vty: Fix uninitialized var false positive on gcc 7.3.1
431 * paging: paging_request_bts: Fix wrong return value
432 * bssap: Log non handled paging requests
433 * libbsc: set_net_mcc_mnc_apply: Fix memleak on parsing incorrect mcc mnc
434 * bsc_nat: ctrl: fix memleak on reply receival
435 * bsc_nat: forward_to_bsc: remove one level of indentation
436 * bsc_nat: forward_to_bsc: Fix memleak on send failure
437 * bsc_nat: Drop redundant ccon ptr in bsc_cmd_list
438 * bsc_nat: ctrl: Fix crash on receveing bsc reply
439 * use osmo_init_logging2
440 * chan_alloc.c: Fix log var formatting issues
441 * abis_rsl.c: abis_rsl_rx_cchan: Print msg type name for unimplemented messages received
442 * abis_rsl.c: Clean ericsson specific imm assign code
443 * gsm_data_shared.h: Remove unused enum gsm_paging_event
444
445 [ Stefan Sperling ]
446 * Fix "CTRL GET msc_connection_status" response.
447 * Support control connection status query for a particular MSC.
448 * Implement support for paging by LAI.
449 * Add TAGS files (produced by 'make tags') to .gitignore file.
450 * Implement support for CELL_IDENT_NO_CELL.
451 * Implement support for paging based on CI (cell identifier).
452 * Move BTS selection for paging from osmo_bsc_grace.c into osmo_bsc_bssap.c.
453 * Implement support for paging based on a Cell Global Identifier.
454 * Implement support for paging based on LAC and CI.
455 * Show the BTS number for outgoing paging commands in debug log.
456 * Split paging cases in bssmap_handle_paging() off into helper functions.
457 * Remove an unused variable.
458 * Improve an error message in page_lai_and_lac()
459 * Make "waiting indicator" of IMMEDIATE ASSIGN REJECT dynamic.
460 * Add stat items for the BTS's channel load average and T3122.
461 * Make RSL connection attempts time out.
462 * fix handover_test link error
463 * Add support for Access Control Class ramping.
464 * Generate the S_L_INP_TEI_UP signal earlier.
465 * use libosmocore to parse cell identifiers in osmo-bsc
466 * fix an error message in bssmap_handle_paging()
467 * change return type of page_subscriber() to void
468 * Generate the S_L_INP_TEI_UP signal earlier.
469 * fix a format string error in bts_update_t3122_chan_load()
470 * fix initialization of acc ramping
471 * only log actual access control class ramping changes
472 * ensure that acc_ramp_init() is only called once
473 * trigger acc ramping based on trx rf-locked state
474 * rename helper functions in the acc ramp code to avoid confusion
475 * trigger acc ramping on state-changed-event reports
476 * only trigger acc ramping if trx 0 is usable and unlocked
477 * fix handling of state changes in acc ramping
478 * properly skip paging is OML link is down
479 * extend documentation of paging_flush_bts()
480 * flush paging when RSL link is dropped
481
482 [ Vadim Yanitskiy ]
483 * bsc/gsm_04_80.h: use '#pragma once' instead of includes
484 * bsc/gsm_04_80.h: clean up useless declarations
485 * libbsc/bsc_vty.c: prevent uninitialized access
486 * doc/examples: use NECI = 1 by default
487
488 [ Ivan Kluchnikov ]
489 * handover_decision: Fix condition for power budget handover attempt
490 * handover_decision: log HO causes more accurately
491
492 [ Andreas Eversberg ]
493 * HO: Send Channel Mode and Multirate IE along with handover command
494 * HO: Add function to count currently ongoing handovers to a given BTS
495 * Fix: If paging for half rate was requested, use hr, if supported by MS
496 * HO: Assign SDCCH on channel request
497 * Fix of checking TCH rate at chan_compat_with_mode
498 * HO: Count the actual meas.rep. get_meas_rep_avg fails if not reached
499 * HO: Count neighbor measurements and reduce window of neigh_meas_avg
500 * HO: Changed availablilty of ts_is_usable() from static to extern
501 * HO: Always update rqd_ta after receiving measurement report
502 * HO: If handover logic is used to do assignment, signal assignment result
503 * HO: Add handover decision debugging category
504 * Do not perform assignment, if the new channel equals the current one
505 * Allow assignment to TCH channel with signalling only mode
506 * Correctly set T3105 for ipaccess BTS type
507 * HO: fix: increase the number of measurement report history to 10
508 * HO: Change debug category at handover decision: DHO -> DHODEC
509 * HO: Count number of free timeslot on a given BTS
510 * HO: add queue to cache DTAP messages during handover/assignment
511 * Fix: meas_rep.c will only use valid DL measurement reports
512 * HO: Add a penalty timer list to the subscriber connection entity
513
514 [ Keith ]
515 * Cosmetic: Fix typo: Siganlling->Signalling
516
517 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 18:40:11 +0200
518
Harald Weltef3fb5f32017-10-29 09:03:34 +0100519osmo-bsc (1.1.2) unstable; urgency=medium
520
521 * Debian: depend on libosmo-sigtran (bsc) and libosmo-sccp (bsc-nat)
522 * debian/control: Specify versions of packages we depend upon
523
524 -- Harald Welte <laforge@gnumonks.org> Sun, 29 Oct 2017 09:03:33 +0100
525
Harald Welted1225f32017-10-28 21:49:01 +0200526osmo-bsc (1.1.1) unstable; urgency=medium
527
528 [ Neels Hofmeyr ]
529 * jenkins: use osmo-clean-workspace.sh before and after build
530
531 [ Harald Welte ]
532 * Debian: re-introduce missing build dependency to libssl-dev
533
534 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 21:49:00 +0200
535
Harald Welte9bce2bd2017-10-28 11:19:03 +0200536osmo-bsc (1.1.0) unstable; urgency=medium
537
538 [ Alexander Couzens ]
539 * Initial release.
540 * debian/rules: show testsuite.log when tests are failing
541
542 [ Neels Hofmeyr ]
543 * jenkins: fix build: osmo-mgw from master, not pre_release
544 * drop files unrelated to osmo-bsc
545 * rename openbsc.pc to osmo-bsc.pc
546 * rewrite README
547 * move include/openbsc to include/osmocom/bsc
548 * drop MGCP client from osmo-bsc
549 * fix vty tests: vty no longer goes to parent node implicitly
550 * doc/examples: tweak osmo-bsc.cfg, add osmo-bsc_custom-sccp.cfg
551 * add ';' after OSMO_ASSERT()
552
553 [ Harald Welte ]
554 * configure.ac: No more libosmogb dependency
555 * configure.ac: remove --enable-osmo-bsc, --enable-nat
556 * configure.ac: remove smpp_mirror, which has no relation to a BSC
557 * contrib/jenkins.sh: MGCP is unconditional now
558 * configure.ac: Remove --enable-mgcp-transcoding
559 * configure.ac: Remove --enable-iu
560 * configure.ac: Remove checks for libgtp + c-ares
561 * configure.ac: Remove check for GMTOFF
562 * configure.ac: Package is now called osmo-bsc, not openbsc
563 * libbsc: document arguments of generate_bcch_chan_list()
564 * Make sure BA-IND in all SI2xxx is '0' and in all SI5xxx is '1'
565 * gsm0408_test: Verify that BA-IND is 0 in SI2xxx and 1 in SI5xxx
566 * .gitignore: Update to post-NITB-split realities
567 * Remove any references to RANAP and Iu
568 * Fix nanobts_omlattr unit test
569 * nanobts_omlattra_test: Initialize logging before executing tests
570 * osmo-bsc: Initialize logging before initializing rate_ctr
571 * Rename osmo_fsm to avoid illegal space in name + more meaningful name
572
573 [ Max ]
574 * Make TRX rf locking more visible
575 * SI13: drop PBCCH-related bits
576 * Wrap channel state assignment in macro
577 * Further cleanup leftovers from BSC/MSC split
578 * CTRL: cleanup write-only command functions
579 * Show OML link uptime in vty
580 * Fix repo split aftermath
581 * SI2q: cleanup UARFCN addition
582 * OML: consider RSL link state
583 * SI2q: fix generation for multiple UARFCNs
584 * Remove pkg-config file
585 * ctrl: add oml-uptime command
586 * SI1q: fix EARFCN appender
587
588 [ Pau Espin Pedrol ]
589 * Remove unneeded dbi dependency
590 * bsc_api: Fix NULL secondary_lchan access in handle_ass_fail
591 * libbsc: Use correct printf formatting for uint64_t
592 * bsc_vty: Improve description of mid-call-text cmd
593
594 -- Harald Welte <laforge@gnumonks.org> Sat, 28 Oct 2017 11:19:03 +0200
595
Alexander Couzens77ac7af2017-08-07 07:57:20 +0000596osmo-bsc (0.1.0) UNRELEASED; urgency=low
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200597
Harald Welte9bce2bd2017-10-28 11:19:03 +0200598 [ Alexander Couzens ]
599 * Initial release.
Holger Hans Peter Freytherddf4e1e2016-05-24 23:15:12 +0200600
Alexander Couzens77ac7af2017-08-07 07:57:20 +0000601 -- Alexander Couzens <lynxis@fe80.eu> Tue, 08 Aug 2017 01:12:56 +0000