blob: 72466158e34d1e917c5616ceafa47a81f2c5bcae [file] [log] [blame]
Holger Hans Peter Freytherf52b4a62011-11-11 21:31:43 +08001# Copyright (C) 2007-2008, Stelios Koroneos - Digital OPSiS, All Rights Reserved
2# Copyright (C) 2011, sysmocom - systems for mobile communications GmbH
3# Released under the MIT license (see packages/COPYING)
4DESCRITOPN = "asterisk PBX"
5DEPENDS = "openssl ncurses"
6HOMEPAGE = "http://www.asterisk.org"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=3c6764ffcbe996d1d8f919b393ccdd67"
9
Holger Hans Peter Freytherf58538e2011-12-11 21:38:31 +010010PR = "r3"
Holger Hans Peter Freytherf52b4a62011-11-11 21:31:43 +080011
12SRC_URI = "http://downloads.asterisk.org/pub/telephony/asterisk/releases/asterisk-${PV}.tar.gz \
13 file://modules.conf \
14 file://asterisk.init"
15
16EXTRA_OECONF = " \
17 --without-curses \
18 --with-sm=internal \
19 --without-gtk \
20 --without-gtk2 \
21 --without-isdnnet \
22 --without-kde \
23 --without-misdn \
24 --without-nbs \
25 --with-ncurses \
26 --without-netsnmp \
27 --without-newt \
28 --without-odbc \
29 --without-ogg \
30 --without-osptk \
31 --without-popt \
32 --without-pri \
33 --without-qt \
34 --without-radius \
35 --without-sdl \
36 --without-spandsp \
37 --without-suppserv \
38 --without-tds \
39 --without-termcap \
40 --without-tinfo \
41 --without-vorbis \
42 --without-vpb \
43 --without-postgres \
44 --without-openais \
45 --without-lua \
46 --disable-xmldoc"
47
48inherit autotools update-rc.d
49
50FILES_${PN}-dbg += "${libdir}/asterisk/modules/.debug"
51
52do_configure_prepend() {
53 # Due to menuselect below we want to save off these configures
54 mv ${S}/menuselect/configure ${S}/menuselect/configure.SAVE
55 mv ${S}/menuselect/mxml/configure ${S}/menuselect/mxml/configure.SAVE
56 mv ${S}/main/editline/configure ${S}/main/editline/configure.SAVE
57}
58
59do_configure_append() {
60 # Put this back
61 mv ${S}/menuselect/configure.SAVE ${S}/menuselect/configure
62 mv ${S}/menuselect/mxml/configure.SAVE ${S}/menuselect/mxml/configure
63 mv ${S}/main/editline/configure.SAVE ${S}/main/editline/configure
64}
65
66INITSCRIPT_PACKAGES = "${PN}"
67INITSCRIPT_NAME_${PN} = "asterisk"
68INITSCRIPT_PARAMS_${PN} = "defaults 29 29"
69
Holger Hans Peter Freytherf52b4a62011-11-11 21:31:43 +080070PACKAGES =+ "${PN}-moh"
71
72DESCRIPTION_${PN}-moh = "Asterisk MusicOnHold sound"
73FILES_${PN}-moh = "${localstatedir}/lib/${PN}/moh"
74
75
76do_install_append() {
77 install -d ${D}${sysconfdir}/init.d
78 install -d ${D}${sysconfdir}/asterisk
79
80 install -m 0775 ${WORKDIR}/asterisk.init ${D}${sysconfdir}/init.d/asterisk
81 install -m 0660 ${WORKDIR}/modules.conf ${D}${sysconfdir}/asterisk/
82}