blob: 7aaa6e18e96b2ce287515948af3ffe6837bca196 [file] [log] [blame]
Holger Hans Peter Freyther00e53d52016-03-23 11:53:00 +01001SUMMARY = "The Linux Kernel Stream Control Transmission Protocol (lksctp) project"
2HOMEPAGE = "http://lksctp.org"
3SECTION = "net"
4LICENSE = "LGPLv2.1 & GPLv2"
5
6LIC_FILES_CHKSUM = " \
7 file://COPYING.lib;md5=0a1b79af951c42a9c8573533fbba9a92 \
8 file://COPYING;md5=0c56db0143f4f80c369ee3af7425af6e \
9"
10
11SRC_URI = "${SOURCEFORGE_MIRROR}/lksctp/${BP}.tar.gz \
12 file://run-ptest \
13 file://v4test.sh \
14 file://v6test.sh \
15 "
16
17SRC_URI[md5sum] = "708bb0b5a6806ad6e8d13c55b067518e"
18SRC_URI[sha256sum] = "0903dd526b7f30a89d5031aa2c82757612becc38ed7bc6e4f972f8deae351f26"
19
Pau Espin Pedrole3952be2019-12-03 13:45:18 +010020PR = "r1"
21
Holger Hans Peter Freyther00e53d52016-03-23 11:53:00 +010022#| arm-oe-linux-gnueabi-libtool: link: arm-oe-linux-gnueabi-gcc -march=armv5te -marm -mthumb-interwork --sysroot=/home/jenkins/oe/world/shr-core/tmp-eglibc/sysroots/qemuarm -shared -fPIC -DPIC .libs/bindx.o .libs/connectx.o .libs/peeloff.o .libs/opt_info.o .libs/addrs.o .libs/sendmsg.o .libs/recvmsg.o -march=armv5te -marm -mthumb-interwork --sysroot=/home/jenkins/oe/world/shr-core/tmp-eglibc/sysroots/qemuarm -O2 -Wl,--version-script=/home/jenkins/oe/world/shr-core/tmp-eglibc/work/armv5te-oe-linux-gnueabi/lksctp-tools/1.0.16-r0/lksctp-tools-1.0.16/src/lib/Versions.map -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,-soname -Wl,libsctp.so.1 -o .libs/libsctp.so.1.0.16
23#| /home/jenkins/oe/world/shr-core/tmp-eglibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.0/ld: error: symbol sctp_connectx has undefined version
24#| collect2: error: ld returned 1 exit status
25#| make[4]: *** [libsctp.la] Error 1
Pau Espin Pedrol687b6832017-08-18 15:25:01 +020026PNBLACKLIST[lksctp-tools] ?= "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', "BROKEN: fails to link against sctp_connectx symbol", '', d)}"
Holger Hans Peter Freyther00e53d52016-03-23 11:53:00 +010027
28S = "${WORKDIR}/${BP}"
29
30BBCLASSEXTEND = "native"
31
32inherit autotools pkgconfig binconfig ptest
33
34do_install_ptest () {
35 install -m 0755 ${WORKDIR}/v4test.sh ${D}${PTEST_PATH}
36 install -m 0755 ${WORKDIR}/v6test.sh ${D}${PTEST_PATH}
37 for testcase in `find ${B}/src/apps/.libs ${B}/src/func_tests/.libs -maxdepth 1 -type f -executable`; do
38 install $testcase ${D}${PTEST_PATH}
39 done
40}
41
42SOLIBVERSION="${PV}"
43SOLIBMAJORVERSION="1"
44
45PACKAGES =+ "${PN}-withsctp ${PN}-utils"
46
47FILES_${PN} = " \
48 ${libdir}/libsctp.so.${SOLIBVERSION} \
49 ${libdir}/libsctp.so.${SOLIBMAJORVERSION} \
50"
51
52FILES_${PN}-withsctp = " \
53 ${libdir}/lksctp-tools/libwithsctp.so.${SOLIBVERSION} \
54 ${libdir}/lksctp-tools/libwithsctp.so.${SOLIBMAJORVERSION} \
55"
56
57FILES_${PN}-dev += " \
58 ${libdir}/libsctp.so \
59 ${libdir}/lksctp-tools/libwithsctp.so \
60 ${datadir}/lksctp-tools/*.c \
61 ${datadir}/lksctp-tools/*.h \
62"
63
64FILES_${PN}-utils = "${bindir}/*"
65
Pau Espin Pedrole3952be2019-12-03 13:45:18 +010066RRECOMMENDS_${PN} += "kernel-module-sctp"
Holger Hans Peter Freyther00e53d52016-03-23 11:53:00 +010067RRECOMMENDS_${PN}-utils += "kernel-module-sctp"
68RRECOMMENDS_${PN}-ptest += "kernel-module-sctp"