blob: 51628538811756a751fdfa327a0344d8d75f8de9 [file] [log] [blame]
Holger Hans Peter Freytherf52b4a62011-11-11 21:31:43 +08001# Copyright (C) 2007-2008, Stelios Koroneos - Digital OPSiS, All Rights Reserved
Holger Hans Peter Freythere77df792012-01-16 16:08:45 +08002# Copyright (C) 2011-2012, sysmocom - systems for mobile communications GmbH
Holger Hans Peter Freytherf52b4a62011-11-11 21:31:43 +08003# Released under the MIT license (see packages/COPYING)
4DESCRITOPN = "asterisk PBX"
5DEPENDS = "openssl ncurses"
6HOMEPAGE = "http://www.asterisk.org"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=3c6764ffcbe996d1d8f919b393ccdd67"
9
Holger Hans Peter Freythere77df792012-01-16 16:08:45 +080010PR = "r4"
Holger Hans Peter Freytherf52b4a62011-11-11 21:31:43 +080011
12SRC_URI = "http://downloads.asterisk.org/pub/telephony/asterisk/releases/asterisk-${PV}.tar.gz \
13 file://modules.conf \
Holger Hans Peter Freythere77df792012-01-16 16:08:45 +080014 file://asterisk.init \
15 file://stop-crash.patch "
Holger Hans Peter Freyther95667152012-01-16 16:07:56 +080016
17SRC_URI[md5sum] = "783b2da2036745edeea8885c62bbc8bf"
18SRC_URI[sha256sum] = "ed98204f6261e1362c673e595823c668ae39b9833daec9127a4936cf9f4890e1"
19
Holger Hans Peter Freytherf52b4a62011-11-11 21:31:43 +080020
21EXTRA_OECONF = " \
22 --without-curses \
23 --with-sm=internal \
24 --without-gtk \
25 --without-gtk2 \
26 --without-isdnnet \
27 --without-kde \
28 --without-misdn \
29 --without-nbs \
30 --with-ncurses \
31 --without-netsnmp \
32 --without-newt \
33 --without-odbc \
34 --without-ogg \
35 --without-osptk \
36 --without-popt \
37 --without-pri \
38 --without-qt \
39 --without-radius \
40 --without-sdl \
41 --without-spandsp \
42 --without-suppserv \
43 --without-tds \
44 --without-termcap \
45 --without-tinfo \
46 --without-vorbis \
47 --without-vpb \
48 --without-postgres \
49 --without-openais \
50 --without-lua \
51 --disable-xmldoc"
52
53inherit autotools update-rc.d
54
55FILES_${PN}-dbg += "${libdir}/asterisk/modules/.debug"
56
57do_configure_prepend() {
58 # Due to menuselect below we want to save off these configures
59 mv ${S}/menuselect/configure ${S}/menuselect/configure.SAVE
60 mv ${S}/menuselect/mxml/configure ${S}/menuselect/mxml/configure.SAVE
61 mv ${S}/main/editline/configure ${S}/main/editline/configure.SAVE
62}
63
64do_configure_append() {
65 # Put this back
66 mv ${S}/menuselect/configure.SAVE ${S}/menuselect/configure
67 mv ${S}/menuselect/mxml/configure.SAVE ${S}/menuselect/mxml/configure
68 mv ${S}/main/editline/configure.SAVE ${S}/main/editline/configure
69}
70
71INITSCRIPT_PACKAGES = "${PN}"
72INITSCRIPT_NAME_${PN} = "asterisk"
73INITSCRIPT_PARAMS_${PN} = "defaults 29 29"
74
Holger Hans Peter Freytherf52b4a62011-11-11 21:31:43 +080075PACKAGES =+ "${PN}-moh"
76
77DESCRIPTION_${PN}-moh = "Asterisk MusicOnHold sound"
78FILES_${PN}-moh = "${localstatedir}/lib/${PN}/moh"
79
80
81do_install_append() {
82 install -d ${D}${sysconfdir}/init.d
83 install -d ${D}${sysconfdir}/asterisk
84
85 install -m 0775 ${WORKDIR}/asterisk.init ${D}${sysconfdir}/init.d/asterisk
86 install -m 0660 ${WORKDIR}/modules.conf ${D}${sysconfdir}/asterisk/
Holger Hans Peter Freyther45392932014-09-24 16:22:05 +020087
88 rm -rf ${D}/var/run
Holger Hans Peter Freytherf52b4a62011-11-11 21:31:43 +080089}