blob: 606d923c9f10a5e77a0ab0304615e1039f36d549 [file] [log] [blame]
Pau Espin Pedrol924ef0b2018-07-27 17:31:47 +02001libosmocore (0.12.0) unstable; urgency=medium
2
3 [ Pau Espin Pedrol ]
4 * control_if: Avoid heap-use-after-free in osmo_wqueue_bfd_cb
5 * configure: Check separately for lib implementing dlopen and dlsym
6 * tests: bitrev_test: Fix dynamic-stack-buffer-overflow
7 * tests: gea_test: Use correct max size for key in buffer
8 * tests: a5_test: Print wrong buffer correctly on error
9 * gsm: kasumi: Fix dynamic-stack-buffer-overflow on out buffers not multiple of 64 bits
10 * gsm: lapdm.c: Add missing new line char in notice log string
11 * ctrl: Log CMD TYPE on invalid ID number
12 * ctrl: Fix parsing of ERROR recvd msgs with id=err
13 * gsm0808: Add value_string for encryption algorithms
14 * ctrl: Introduce ctrl_cmd_parse3 API
15 * ctrl: ctrl_handle_msg: Avoid sending back received ERROR msgs
16 * tests: ctrl: Test received ERROR messages are handled correctly
17 * libosmocoding: clarify return values for TCH decoding functions
18 * libosmocodec: FR err concealment: Fix too many silent frames generated
19 * tests: codec: ecu_fr: Print XMAXC fields
20 * tests: codec: ecu_fr: Add buffer with unequal XMAXC values
21 * rate_ctr: Improve logging
22 * logging: log_vty_command_string: Fix undercount of buf alloc size
23 * logging_vty: Simplify code in config_write_log_single
24 * logging.c: Fix whitespace typo
25
26 [ Harald Welte ]
27 * lapdm: Fix back-pointer from lapdm_entity to lapdm_channel
28 * lapdm: Implement SABM related constraints
29 * lapdm: cleanup: send_rslms_rll_l3_ui(): Use msgb_tv_push()
30 * lapdm: send_rslms_rll_l3_ui(): Don't include B4/SACCH IE unless needed
31 * lapdm: don't enforce contention resolution on SAPI0/DCCH
32 * Add osmo_timerfd_* functions for osmo_fd-wrapped timerfd
33 * import isdn4linux HDLC code from linux kernel
34 * isdnhdlc: Port from kernel to userspace
35 * mncc: properly export osmo_mncc_name()
36 * cosmetic: Whitespace fixes in control_if.c
37 * ctrl: Introduce libosmoctrl.map to avoid unintended exports
38 * ctrl: Add doxygen API documentation; generate html from it
39 * debian: Add libosmoctrl-doc sub-package
40 * gsm_08_08.h: Add enum for LCLS config, control and status
41 * gsm0808: Add encoding functions for LCLS BSSMAP messages
42 * gsm0808: Add value_string for LCLS related IEs
43 * tlv: Add TLVP_VAL_MINLEN() to obtain value _if_ length is >= minimum
44 * Add osmo_isqrt32() to compute 32bit integer square root
45 * fsm: Change semantics of LOGPFSML() log-level
46 * vty: Don't dump deprecated commands in XML export
47 * vty: Add logging_vty_add_deprecated_subsys
48 * gsup: Add osmo_gsup_get_err_msg_type() function
49 * gsup: Add value_string for Session State IE
50 * gsm 04.80: Add value_string for component type and op code
51 * Fix embedded (arm-none-eabi) builds
52 * jenkins_arm.sh: Don't run 'make check' on embedded builds
53 * jenkins_arch.sh: Accept "arm-none-eabi" as alias for "arm"
54 * jenkins_arch.sh: Exit with error on unknown architecture
55 * Don't call abort() directly, always use osmo_panic()
56 * osmo_panic(): Annotate as __attribute__ ((noreturn))
57 * gprs_ns.h: Declare gprs_ns_cause_str() which already existed in c file
58
59 [ Stefan Sperling ]
60 * define a constant for the max length of called party BCD IE
61 * introduce vty_out_rate_ctr_group_fmt() function
62 * Add a 'show rate-counters' VTY command.
63 * remove unused argument from pad_append_ctr() helper function
64 * check bssgp_tlv_parse() return code in bssgp_rcvmsg()
65 * return error to sender upon bssgp_tlv_parse() failure
66
67 [ Neels Hofmeyr ]
68 * add gsm0808 channel enum to IE val conversion functions
69 * add gsm0808_cell_id_to_list()
70 * add support for gsm0808 HANDOVER REQUIRED message
71 * add gsm0808_create_handover_request_ack()
72 * add osmo_fsm_inst_state_chg_keep_timer()
73 * fix gsm0808_permitted_speech(): don't return HR3 for TCH_F + AMR
74 * add and tweak inter-BSC HO API
75 * vty/command.c: talloc from tall_vty_cmd_ctx, not NULL
76 * vty: cosmetic: cmd_deopt(): use talloc_strndup(), not memcpy()
77 * vty: fix use-after-free and memleaks in is_cmd_ambiguous()
78 * utils_test: fix isqrt_test calculation range
79 * utils_test: check stderr to catch sanitizer issues
80 * add osmo_sockaddr_to_str_and_uint()
81
82 [ Philipp Maier ]
83 * fsm: guard action callback
84 * gsm_04_08: add function to get value string
85 * gsm_08_08: gsm0808_permitted_speech does not have value strings
86
87 [ Thorsten Alteholz ]
88 * fix spelling
89
90 [ Keith ]
91 * Add enum gsm48_cause_coding from GSM 04.08 Section 10.5.4.11
92 * Add enum gsm48_progress_desc
93
94 [ Daniel Willmann ]
95 * ports.h: Add ctrl port for osmo-gbproxy
96 * Add function gprs_nsvc_state_append
97 * stats_vty: Add asciidoc sections between the different counters
98
99 [ Vadim Yanitskiy ]
100 * gsm0480: fix: don't overwrite the data of RELEASE_COMPLETE
101 * GSUP: implement TCAP-like session management
102 * GSUP: introduce new messages for SS/USSD payloads
103 * Doxygen: gitignore generated files for libosmoctrl
104 * gsm/gsm0480.c: introduce gsm0480_extract_ie_by_tag()
105 * gsm/gsm0480: refactor and expose gsm0480_parse_facility_ie()
106 * Don't enforce Python 2 for utilities
107
108 [ Alexander Chemeris ]
109 * coding: Fix (E)GPRS BER calculation to correctly account for puncturing.
110 * coding: Documentation typo fix.
111
112 [ Alexander Couzens ]
113 * vty: initialize termios before using it
114 * stats_statsd: sanitize statsd name
115
116 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 17:31:46 +0200
117
Pau Espin Pedrol13154ff2018-05-03 15:47:11 +0200118libosmocore (0.11.0) unstable; urgency=medium
119
120 [ Max ]
121 * Enable GnuTLS fallback
122 * Ctrl: add rate counter group introspection
123 * ctrl: log incorrect interval values
124 * Improve get_rate_ctr() error handling
125 * ctrl: make response easier to parse
126 * coding test: cosmetic cleanup
127 * coding test: enable debug output
128 * coding test: move bit dump into functions
129 * coding test: use OSMO_ASSERT
130 * Fix embedded build
131 * embedded: fix tests
132 * Embedded: fix sercomm test
133 * Add functions for extended RACH coding
134 * Do not allocate already existing counter group
135 * Fix incorrect spec reference
136 * Use 127.0.0.1 for GSMTAP logging by default
137 * coding: move eB adjustement to appropriate place
138 * Add function to properly encode RAI
139 * Use existing function for TLLI encoding
140 * log: print loginfo assertions source
141 * Allow multiple 'log gsmtap' sinks
142 * Deprecate gsm48_construct_ra()
143 * Log lapd_datalink state on errors
144 * jenkins: add dispatcher script
145 * Embedded: disable stats test
146 * Embedded: add sercomm stubs
147 * GSUP: don't fail test on first error
148 * jenkins: remove obsolete scripts
149 * jenkins: move make invocation into shared function
150 * utils: add helper wrapper for osmo_strlcpy()
151 * GSUP: change osmo_gsup_encode() return type
152 * Use python 3 for utilities
153 * Add test for gsm48_generate_mid_from_imsi()
154 * Add generic Mobile Identity encoder
155 * Add function to encode classmark
156
157 [ Niro Mahasinghe ]
158 * gsm0503_coding.c: Fix tch_efr_unreorder() of one bit
159 * gsm0503_coding.c: Use majority vote in tch_efr_unreorder()
160
161 [ Harald Welte ]
162 * debian: build now depends on libgnutls
163 * Fix/Update copyright notices; Add SPDX annotation
164 * Print /proc/cpuinfo before executing testsuite
165 * conv_acc: Our code requires SSSE3, not just SSE3
166 * ports.h: Use same VTY port number for osmo-mgw and osmo-bsc_mgcp
167 * gsmtap.h: Introduce new GSMTAP type for LTE NAS messages
168 * gsm0808_create_cipher_reject: Fix encoding of Cause IE
169 * rate_ctr: print proper error message if rate_ctr already exists
170 * timer: fixup whitespace issues
171 * control_if: Close control connection socket/fd on read/write == 0
172 * control_if: Log the disconnect of a CTRL client
173 * CTRL: Ensure peer/connection info is always printed the same way
174 * MNCC: Add MNCC to string dumper
175 * gsm48_pdisc_names: Use conscise, short names
176 * SMS: Add value_string for TS 04.11 CP and RP state
177 * gsm_04_08.h: Clearly annotate timers that don't have a 3GPP Default value
178 * gsm_04_08.h: Reduce T310 default to 30s.
179 * gsm48_hdr_msg_type[_r99]: Fix bit-masks
180 * gsm48_hdr_msg_type(): SS is in the same group as MM/CC
181 * tlv_parser: Report *first* occurrence of repeated IEs
182 * msgb: Add msgb_hexdump_{l2,l3}() to dump l2 or l3 part of message buffer
183 * Revert "Use python 3 for utilities"
184 * Revert "fsm: do not terminate child FSMs early"
185 * osmo_msgbdump_{l2,l3}(): Proper typecast
186 * debian/control: Fix Vcs-Browser URL
187 * Add GSM 04.08 type-of-number / numbering-plan-id definitions
188 * talloc_ctx_vty: Fix help strings (missing \n at end of line)
189 * Revert "Add function to encode classmark"
190 * rate_ctr: Add rate_ctr_inc2() as convenience wrapper
191 * coding: Add BER-reporting RACH decode functions
192 * l1sap: Add RSSI, BER and quarter-bit accurate timing to PH-RACH.ind
193 * l1sap: Add fields for higher-precision timing offset values
194 * abis_nm: Introduce abis_nm_dump_foh()
195 * VTY: Don't welcome the user to the "control" interface, if it's VTY
196 * prevent integer underflow in ipa_ccm_make_id_resp_from_req()
197 * RSL/LAPDm: Not all RLL message are "transparent"
198
199 [ Neels Hofmeyr ]
200 * vty: deprecate now empty node commands
201 * memleak: osmo_config_list_parse: getline() needs free also on error
202 * abis_test: sanitize: fix msgb memleak
203 * lapd_test: sanitize: fix msgb memleaks
204 * gsm0408_test: sanitize: cleanup msgb
205 * gsm0808_test: sanitize: fix msgb memleak
206 * msgb: add inline msgb_queue_free()
207 * rate_ctr: fix mem leak for mangled desc
208 * bssgp_fc_test: remove rounding to deciseconds
209 * bssgp_fc_test: clarify by outputting ok / failure messages
210 * bssgp_fc_test: sanitizer: free msgb context when done
211 * gprs_bssgp: bssgp_fc_in(): fix mem leak on queue overflow
212 * bssgp_fc_test: sanitize: free fc struct when done
213 * tlv_put: guard against NULL val and 0 len
214 * sercomm_test: sanitize: fix msgb mem leak
215 * osmo_strlcpy: sanitize: don't memcpy from NULL src even if len is 0
216 * fsm_tmr_cb: don't set T=0, the fi may no longer exist
217 * vty XML export: avoid repeating common node commands for each node
218 * VTY reference: do not list empty nodes
219 * VTY reference: use node names as section names
220 * vty: set name for VIEW+ENABLE nodes, for VTY reference
221 * vty reference: merge_doc.xsl: do not omit description tag
222 * comment: utils: more accurately describe OSMO_STRINGIFY macro
223 * logging vty: describe 'logging set-log-mask' command, add OSMO_STRINGIFY_VAL()
224 * fix osmo_identifier_valid(): only allow printable characters
225 * utils: add osmo_separated_identifiers_valid()
226 * add osmo_auth_c3() (separate from gsm_milenage())
227 * utils: add osmo_escape_str()
228 * ctrl_test.c: replace print_escaped() with new osmo_escape_str()
229 * ctrl: prep test: separate new ctrl_handle_msg() from handle_control_read()
230 * ctrl_test: expand to test message handling and detect mem leaks
231 * ctrl_test: show memleak when receiving GET_REPLY and SET_REPLY commands
232 * ctrl: fix mem leak when handling GET_REPLY and SET_REPLY
233 * ctrl_test: add two more current parsing bugs to prep for fix
234 * add ctrl_cmd_parse2() to return parsing errors
235 * ctrl: on parse errors, return a detailed message to sender
236 * rate_ctr: fix osmo-sgsn DoS: don't return NULL on already used index
237 * ports: define proper VTY and CTRL ports for OsmoHNBGW
238 * ctrl: tighten CTRL input parsing
239 * ctrl: separate handling of GET_REPLY, SET_REPLY and TRAP
240 * jenkins: add 'make V=1' for more verbose build logs
241 * logging vty: tweak general 'logging' command doc
242 * gsm: add gsm0808_speech_codec_type_names
243 * logging-gsmtap: send only basename of source file
244 * logging: add ability to log the log-level with API and vty
245 * logging: color the log level
246 * logging: color the log category according to level
247 * fix -Werror build: logging.c: always use literal with snprintf
248 * cosmetic: logging: if color is disabled, don't print ""
249 * logging: separate the '<000b>' subsys from filename logging
250 * logging: allow to log only the basename of each source
251 * logging vty: add 'logging print file (0|1|basename)' cmd
252 * vty: fix 'logging print file' output
253 * gsmtap_sendmsg(): clarify API doc concerning msgb ownership
254 * memleak: gsmtap_sendmsg(): don't return 0 when no data was written
255 * memleak: fix all libosmocore callers of gsmtap_sendmsg() to free on failure
256 * memleak: _gsmtap_raw_output(): free msg in case of vsnprintf failure
257 * cosmetic: gsm0408_test: RA test cases as array-of-struct
258 * gsm0408_test: cosmetically re-order MCC to come before MNC
259 * gsm0408_test: include BCD and leading zeros in test output
260 * gsm0408_test: RA test: include min/max value cases
261 * gsm0408_test: also test gsm48_generate_lai() and gsm48_decode_lai()
262 * implement support for 3-digit MNC with leading zeros
263 * gsm0408_test: check for new mnc_3_digits flag
264 * gsm0408_test: test new gsm48_{decode,generate}_lai2() functions
265 * gsm0408_test: add test cases for MNC with leading zeros
266 * gsm: add osmo_mnc_from_str(), osmo_mnc_cmp(), osmo_plmn_cmp() for 3-digit MNC
267 * introduce GSM_MCC_MNC_INVALID
268 * gsm23003_test: fix: compare members instead of bcmp
269 * fix osmo_mnc_from_str(): don't try to parse NULL
270 * gsm23003: add osmo_mcc_from_str()
271 * configure: add --enable-werror
272 * jenkins_amd64.sh: use --enable-werror configure flag, not CFLAGS
273 * gsm0808_test: cosmetic: re-arrange struct init; print hexdump on failure
274 * gsm0808_test: cosmetic: test non-hex MCC
275 * show failure in gsm0808_enc_cell_id_list2() in gsm0808_test
276 * fix gsm0808_enc_cell_id_list2 for leading-zero MNC
277 * cosmetic: gsm0808_test: drop extraneous assertion
278 * contrib/fsm-to-dot: add -h option to print basic instructions
279 * contrib/fsm-to-dot: allow transition from and to the same state
280 * contrib/fsm-to-dot: don't match on event names in comments
281 * contrib/fsm-to-dot: warn and draw unallowed state transitions
282 * contrib/fsm-to-dot: add default edge label '-'
283 * contrib/fsm-to-dot: mark arrows that feed events
284 * contrib/fsm-to-dot: less false positives on event parsing
285 * contrib/fsm-to-dot: mark illegal states in red
286 * contrib/fsm-to-dot: warn about identically named FSMs
287 * vty/command.c: write_config_file(): sanely compose temp path
288 * fix logging talloc ctx: add osmo_init_logging2()
289 * ctrl: test deferred cmd, show current failure
290 * ctrl: fix deferred commands (and hence fix osmo-bts-sysmo 'clock-info' cmd)
291 * cosmetic: flatten ctrl_handle_msg()
292 * fix ctrl_test sanitizer issues
293 * use osmo_init_logging2() with proper talloc ctx
294 * add osmo_quote_str(),osmo_quote_str_buf() and test
295 * fsm_test: terminate the main loop instead of exit on timeout
296 * osmo_fsm_inst_find_by_name(): guard against strcmp(NULL)
297 * fsm_test: more thoroughly test FSM inst ids and names
298 * fsm: id: properly set name in case of NULL id
299 * cosmetic: osmo_fsm_inst_update_id(): don't log "allocate"
300 * add osmo_fsm_inst_update_id_f()
301 * add gsm48_reject_value_names
302 * deprecate PLMN de-/coding functions incapable of 3-digit MNC with leading zeros
303 * avoid warning in gsm0808_create_layer3
304 * add osmo_cgi_name()
305 * add gsm0808_cell_id_list_add() to combine two cell identifier lists
306 * add tlv_parse2(), capable of multiple instances of the same IE
307 * add gsm0808_{enc,dec}_cell_id
308 * test_gsm0808_enc_dec_cell_id_list_lac(): validate encoded bytes
309 * test_gsm0808_enc_dec_cell_id_list_lac(): populate all LACs
310 * test_gsm0808_enc_dec_speech_codec_with_cfg: initialize properly
311 * cosmetic: log: fix typo, clarify msg for rate_ctr name mangling
312 * tlv: add TLV_GET() and TLV_GET_MINLEN()
313 * add gsm0808_cell_{id,id_list}_name() and friends
314 * gsm0808_test: fix more missing inits (address sanitizer issues)
315 * gsm0808_test: silence deprecation: use gsm0808_create_layer3_2()
316
317 [ Philipp Maier ]
318 * vty: add port number for osmo-mgw
319 * libosmocodec: add FR bit offset definitions
320 * libosmocodec: implement ECU (Error Concealment Unit) for FR
321 * fsm: fix double llist_del in osmo_fsm_inst_term()
322 * socket: fix socket leak in osmo_sock_local_ip()
323 * socket: use inet_ntop() instead of inet_ntoa() in osmo_sock_local_ip()
324 * fsm: add functions for unlinking and changing parents
325 * fsm: do not terminate child FSMs early
326 * fsm: allow graceful exit on FSM termination
327 * features: move bts feature related functionality to libosmocore
328 * features: define osmo_bts_*_feature() as static inline
329 * gsm_08_08: correct speech codec defaults
330 * gsm0808: Add value strings for BSSMAP cause codes
331
332 [ Pau Espin Pedrol ]
333 * vty: Fix bad use of vector_slot()
334 * gsm: Use correct include for getrandom
335 * utils: Fix false positive in compiler warning
336 * cosmetic: Fix trailing whitespace
337 * Fix malformed Abis/RSL messages with extra L3 Information field
338 * tests: coding_test: Fix compilation with -O0
339 * tests: utils_test: Fix test failure when compiling with -O0
340 * ports.h: Add VTY and CTRL ports for osmo-trx
341 * core: Add timespec helper macros and make timer_compat.h public
342 * core/logging.h: Add logging category for jitter buffer
343 * timer: Introduce osmo_clock_gettime to override clock_gettime
344 * timer: Document osmo_gettimeofday API
345 * osmo-release.sh: Set correct version when generating the changelog
346 * socket.c: osmo_sock_init2: bind: Several logic fixes and log improvements
347 * socket.c: osmo_sock_init2: connect: Several logic fixes and log improvements
348 * socket.c: osmo_sock_init: Several logic fixes and log improvements
349 * msgb: msgb_get: Drop unneeded tmp var
350 * msgb: msgb_pull: Abort when pulling more than avail size
351 * osmo_get_macaddr: Fix buffer read out of bounds
352 * osmo_sockaddr_is_local: Fix memleak
353 * gsm_08_58.h: Add Ericsson vendor-specific RSL message types
354 * osmo-release.sh: Remove temporary file TODO-RELEASE.entries after use
355 * osmo-release.sh: Exit with error if no description for new changelog entry provided
356 * osmo-release.sh: Fix error condition no LIBVERSION modified
357 * osmo-release.sh: Always generate entire commit changelog
358 * osmo-release.sh: Allow user to add extra information to the release commit
359 * debian: libosmoctrl: Use correct library version in pkg name
360 * debian/changelog: Fix typo in maintainer e-mail
361
362 [ Holger Hans Peter Freyther ]
363 * logging: Extend the LOGPSRC macro to put cont in it as well
364 * license: Fix the license to GPL
365
366 [ Alexander Couzens ]
367 * counters: add osmo_counters_count() returns the amount of counters
368 * vty: show asciidoc counters: don't create an empty table for osmo_counters
369 * gsm_08_58.h: introduce RSL_IE_ERIC_PAGING_GROUP
370 * gsm_utils: call gnutls_global_init() as constructor
371
372 [ Jean-Francois Dionne ]
373 * Fix LAPD UA msgb memory leak.
374
375 [ Vadim Yanitskiy ]
376 * libosmocodec: add FR/HR/EFR frame length definitions
377 * ussd_test.c: fix rc / len debug output confusion
378 * gsm0480: fix USSD OCTET STRING length confusion
379 * gsm0480: clean up the parse_process_uss_req() code
380 * gsm0480: handle UnstructuredSS Request with DSC != 0x0F
381 * gsm0480: parse GSM0480_MTYPE_FACILITY separately
382 * gsm0480: handle GSM0480_CTYPE_RETURN_RESULT
383 * gsm0480: handle USS_NOTIFY and USS_REQUEST with PROCESS_USS_REQ
384 * gsm0480: handle GSM0480_OP_CODE_PROCESS_USS_DATA
385 * gsm0480: add specification reference to SS message type
386 * gsm0480: pass exact GSM 04.80 payload length to parse_ss()
387 * gsm0480: move SS request length check to parse_ss()
388 * gsm0480: refactor gsm0480_decode_ss_request
389 * gsm0480: correct parse_ss_info_elements() declaration
390 * tests/ussd: fix wrong GSM 04.80 payload length
391 * gsm0480: parse all SS info elements in a message
392 * gsm0480: parse optional IEs for RELEASE COMPLETE message
393 * tests/ussd: prevent uninitialized memory access
394 * libosmocoding: fix typo in library documentation
395 * libosmocoding: use frame length definitions from codec.h
396 * src/msgb.c: cosmetic: fix spelling mistakes
397 * src/msgb.c: remove dead includes from OpenBSC
398 * src/msgb.c: print an error if msgb allocation failed
399 * src/msgb.c: avoid using internal talloc API
400 * gsm0480: document the 'ss_request' structure
401 * gsm0480: copy the raw USSD data, its DCS and length
402 * gsm0480: drop messages with incorrect data length
403 * protocol/gsm_04_08.h: drop incorrect GSM48_PDISC_USSD
404 * gsm/gsm48.c: add call independent SS message names
405
406 [ Stefan Sperling ]
407 * TLVP_PRESENT() should not return TRUE after tlv_parse() fails.
408 * Add helper functions for ACC bit flags in rach control IE.
409 * ensure that osmo_fsm vty commands are only installed once
410 * print BIG FAT ERROR message if osmo_fsm lacks event names
411 * ensure VTY commands don't segfault if an FSM has no event names
412 * support for more cell ID list types in libosmocore
413 * fix a cell identifier parsing bug in libosmocore
414 * fix cell identifier decoding in libosmocore
415 * use gsm48_decode_lai2() in gsm0808_dec_cell_id_list()
416 * fix bug in parse_cell_id_ci_list()
417 * fix parse_cell_id_lac_and_ci_list()
418 * add a test for CELL_IDENT_WHOLE_GLOBAL cell identifier lists
419 * add a regression test for TLV parsing with repeated IEs
420
421 [ Sergey Kostanbaev ]
422 * gsm0480: skip length check for 'RELEASE COMPLETE' message
423
424 [ allesklar2 ]
425 * gsmtap.h: define TETRA DMO mode channels
426
427 [ Martin Hauke ]
428 * build: Ensure all .pc files are installed
429
430 [ Daniel Willmann ]
431 * fsm: Add a function to change the FSM instance ID later
432 * contrib/jenkins_arch.sh: Fix script comparison and arm support
433 * fsm: Update the name as well if the id is updated and accept NULL
434
435 [ Thorsten Alteholz ]
436 * fix spelling
437 * fix issue on big endian architecture
438
439 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 15:47:11 +0200
440
Harald Welte69b61fe2017-11-02 18:51:03 +0100441libosmocore (0.10.2) unstable; urgency=medium
442
443 * Revert "vty: Fix bad use of vector_slot()"
444 * New upstream release of libosmocore
445
Pau Espin Pedrol456081d2018-05-03 15:39:11 +0200446 -- Harald Welte <laforge@gnumonks.org> Thu, 02 Nov 2017 18:51:02 +0100
Harald Welte69b61fe2017-11-02 18:51:03 +0100447
Harald Welted9abb0a2017-10-29 10:46:47 +0100448libosmocore (0.10.1) unstable; urgency=medium
449
450 * New upstream release of libosmocore
451
Pau Espin Pedrol456081d2018-05-03 15:39:11 +0200452 -- Harald Welte <laforge@gnumonks.org> Sun, 29 Oct 2017 10:46:47 +0100
Harald Welted9abb0a2017-10-29 10:46:47 +0100453
Harald Weltefaee5de2017-10-27 19:43:33 +0200454libosmocore (0.10.0+nmu1) UNRELEASED; urgency=medium
455
456 * Non-maintainer upload.
457 * New upstream release of libosmocore
458
Pau Espin Pedrol456081d2018-05-03 15:39:11 +0200459 -- Harald Welte <laforge@gnumonks.org> Fri, 27 Oct 2017 19:45:00 +0200
Harald Weltefaee5de2017-10-27 19:43:33 +0200460
Max4e72ee02016-12-13 18:41:17 +0100461libosmocore (0.9.6) unstable; urgency=medium
462
463 * doc: osmocom-authn-protocol.txt: fix numbering, mark unused sync msgs
464 * New upstream release of libosmocore.
465
466 -- Max <msuraev@sysmocom.de> Tue, 13 Dec 2016 18:23:56 +0100
467
468libosmocore (0.9.5) unstable; urgency=medium
469
470 * fix: DLGSUP logging category "unusable"
471 * New upstream release of libosmocore.
472 * ph_data_param struct changed / Extend L1SAP PH-DATA with measurement information
473 * size of ph_tch_param struct changed / Extend with RTP Marker
474 * size of struct log_target changed / Extend with GSMTAP
475
476 -- Max <msuraev@sysmocom.de> Tue, 13 Dec 2016 18:22:56 +0100
477
478libosmocore (0.9.4) unstable; urgency=medium
479
480 * New upstream release of libosmocore.
481 * Internal API for GPRS cipher implementors updated to accommodate for arbitrary key lengths
482 * external talloc dependency / internal talloc removal
483 * size of ph_data_param struct changed / Extend L1SAP PH-DATA with presence information
484
485 -- Max <msuraev@sysmocom.de> Tue, 13 Dec 2016 18:21:56 +0100
486
Holger Hans Peter Freytherabc46af2015-11-09 21:34:43 +0100487libosmocore (0.9.3) unstable; urgency=medium
488
489 * Send all stats values after re-configuration.
490 * Fix using an empty prefix.
491 * Fix sending timing values.
492
493 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Mon, 09 Nov 2015 21:34:37 +0100
494
Holger Hans Peter Freythereed46952015-11-04 14:48:13 +0100495libosmocore (0.9.2) unstable; urgency=medium
496
497 * Fix the counter index after the NS reset.
498
499 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Wed, 04 Nov 2015 14:47:48 +0100
500
Holger Hans Peter Freyther6e149b12015-11-04 10:23:57 +0100501libosmocore (0.9.1) unstable; urgency=medium
502
503 * Fix rate_ctr attribute for GPRS NS counters.
504
505 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Wed, 04 Nov 2015 10:23:39 +0100
506
Holger Hans Peter Freyther8649d572015-11-03 09:30:52 +0100507libosmocore (0.9.0) unstable; urgency=medium
508
509 * StatsD support
510 * Disable building of static libraries
511 * GTP Hub and OAP ports/identifiers assigned
512
513 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Tue, 03 Nov 2015 09:31:41 +0100
514
Holger Hans Peter Freytherd452a482015-08-23 17:38:26 +0200515libosmocore (0.8.3) unstable; urgency=medium
516
517 * Prepare new release
518
519 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Sun, 23 Aug 2015 17:38:55 +0200
520
Holger Hans Peter Freytherc136da52015-08-01 20:19:13 +0200521libosmocore (0.8.2) unstable; urgency=medium
Holger Hans Peter Freytherad69f892015-04-16 21:23:49 +0200522
523 * Add endian header
Holger Hans Peter Freyther16082fd2015-05-06 17:58:07 +0200524 * GPRS flow control changes
Holger Hans Peter Freythera6ea50c2015-05-25 14:17:29 +0200525 * Add APN format routines to libosmocore.
Holger Hans Peter Freytherad69f892015-04-16 21:23:49 +0200526
Holger Hans Peter Freytherc136da52015-08-01 20:19:13 +0200527 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Sat, 01 Aug 2015 20:18:45 +0200
Holger Hans Peter Freytherad69f892015-04-16 21:23:49 +0200528
529libosmocore (0.8.0) unstable; urgency=medium
Holger Hans Peter Freyther25aeab72015-01-18 19:05:19 +0100530
531 * New upstream release of libosmocore.
532
533 -- Holger Hans Peter Freyther <holger@freyther.de> Sun, 18 Jan 2015 19:04:10 +0100
534
535libosmocore (0.7.0) unstable; urgency=medium
Harald Welte336915a2014-08-21 15:51:07 +0200536
537 * New upstream release of libosmocore.
538
539 -- Harald Welte <laforge@gnumonks.org> Thu, 21 Aug 2014 15:52:00 +0200
540
Holger Hans Peter Freyther0c50b172014-03-31 15:36:57 +0200541libosmocore (0.6.6) UNRELEASED; urgency=medium
542
543 * New upstream release of libosmocore.
544
545 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 31 Mar 2014 15:37:33 +0200
546
547libosmocore (0.6.5) unstable; urgency=medium
Holger Hans Peter Freyther050e9c42014-01-20 10:37:42 +0100548
549 * New upstream release of libosmocore
550
551 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 20 Jan 2014 10:37:23 +0100
552
553libosmocore (0.6.4+git3) unstable; urgency=low
Jacob Erlbeck1fa16642013-11-11 09:43:06 +0100554
555 * GPRS fix NS connections to a SGSN when configured via VTY
556
557 -- Jacob Erlbeck <jerlbeck@sysmocom.de> Thu, 07 Nov 2013 16:07:20 +0100
558
559libosmocore (0.6.4+git2) unstable; urgency=low
Holger Hans Peter Freytherf41e5e62013-10-10 14:17:51 +0200560
561 * GPRS related changes, some GSM encoding/decoding changes
Holger Hans Peter Freyther81286a72013-10-17 14:49:02 +0200562 * GPRS correctly determine routable NSVC.
Holger Hans Peter Freyther7fcb3ce2013-10-25 09:51:17 +0200563 * Update with GPRS changes
Holger Hans Peter Freytherf41e5e62013-10-10 14:17:51 +0200564
565 -- Holger Hans Peter Freyther <holger@freyther.de> Thu, 10 Oct 2013 14:16:37 +0200
566
567libosmocore (0.6.3+git1-1) unstable; urgency=low
Holger Hans Peter Freyther73fa6422013-08-09 17:48:06 +0200568
569 * New upstream release with new primitives, USSD fixes.
Holger Hans Peter Freyther9a935e22013-08-12 11:47:12 +0200570 * Split libosmocore into several package. One lib per package.
Holger Hans Peter Freyther73fa6422013-08-09 17:48:06 +0200571
572 -- Holger Hans Peter Freyther <holger@freyther.de> Fri, 09 Aug 2013 17:47:30 +0200
573
Holger Hans Peter Freytherd2446752013-06-26 08:03:14 +0200574libosmocore (0.6.2) unstable; urgency=low
Holger Hans Peter Freytherb64b2b02013-03-25 17:41:15 +0100575
576 * New upstream release with NS UDP DSCP ABI changes
577
Holger Hans Peter Freytherd2446752013-06-26 08:03:14 +0200578 -- Holger Hans Peter Freyther <holger@freyther.de> Wed, 26 Jun 2013 08:01:55 +0200
Holger Hans Peter Freytherb64b2b02013-03-25 17:41:15 +0100579
580libosmocore (0.5.3+git1-6) unstable; urgency=low
Holger Hans Peter Freytherb73d1912013-01-04 09:55:29 +0100581
582 * Build new package with the new API required for osmo-bts/openbsc
Holger Hans Peter Freytherb3f304b2013-02-13 18:11:43 +0100583 * Package the arfcn utility.
584 * Add the SOCK_RAW work-around for glibc.
Holger Hans Peter Freythera5007db2013-02-13 19:27:42 +0100585 * Re-enable the debug packages thanks to Jan.
Holger Hans Peter Freytherb73d1912013-01-04 09:55:29 +0100586
587 -- Holger Hans Peter Freyther <holger@freyther.de> Fri, 04 Jan 2013 09:54:55 +0100
588
Holger Hans Peter Freyther9e6789d2012-11-05 21:36:48 +0100589libosmocore (0.5.3+git1-2) unstable; urgency=low
590
Pau Espin Pedrol456081d2018-05-03 15:39:11 +0200591 * New upstream version
Holger Hans Peter Freyther9e6789d2012-11-05 21:36:48 +0100592
593 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 05 Nov 2012 21:35:57 +0100
594
Eric Butlerb5372ab2012-08-14 20:43:47 -0700595libosmocore (0.5.3+git1-1) precise; urgency=low
596
597 * Fix issue with package version.
598
599 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 20:43:17 -0700
600
Eric Butler8dbdc4f2012-08-14 18:07:00 -0700601libosmocore (0.5.3+git1) precise; urgency=low
602
603 * Updated debian package.
604
605 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 16:53:56 -0700
606
Harald Weltef5afa182011-05-10 17:29:01 +0200607libosmocore (0.3.0) natty; urgency=low
608
609 * New upstream version of libosmocore
610
611 -- Harald Welte <laforge@gnumonks.org> Tue, 10 May 2011 17:28:24 +0200
612
Holger Hans Peter Freytherab1255b2011-01-13 18:09:44 +0800613libosmocore (0.1.27) natty; urgency=low
614
615 * New upstream version of libosmocore.
616
617 -- Holger Hans Peter Freyther <holger@freyther.de> Thu, 13 Jan 2011 18:07:36 +0800
618
Harald Welted4bb7ab2010-08-24 15:17:13 +0200619libosmocore (0.1.17-1) unstable; urgency=low
620
Holger Hans Peter Freyther9a935e22013-08-12 11:47:12 +0200621 * Initial release
Harald Welted4bb7ab2010-08-24 15:17:13 +0200622
623 -- Harald Welte <laforge@gnumonks.org> Tue, 24 Aug 2010 10:55:04 +0200