blob: 393ea17db4c4b32b967286b0d8569c41c18fdaba [file] [log] [blame]
Pau Espin Pedrol13154ff2018-05-03 15:47:11 +02001libosmocore (0.11.0) unstable; urgency=medium
2
3 [ Max ]
4 * Enable GnuTLS fallback
5 * Ctrl: add rate counter group introspection
6 * ctrl: log incorrect interval values
7 * Improve get_rate_ctr() error handling
8 * ctrl: make response easier to parse
9 * coding test: cosmetic cleanup
10 * coding test: enable debug output
11 * coding test: move bit dump into functions
12 * coding test: use OSMO_ASSERT
13 * Fix embedded build
14 * embedded: fix tests
15 * Embedded: fix sercomm test
16 * Add functions for extended RACH coding
17 * Do not allocate already existing counter group
18 * Fix incorrect spec reference
19 * Use 127.0.0.1 for GSMTAP logging by default
20 * coding: move eB adjustement to appropriate place
21 * Add function to properly encode RAI
22 * Use existing function for TLLI encoding
23 * log: print loginfo assertions source
24 * Allow multiple 'log gsmtap' sinks
25 * Deprecate gsm48_construct_ra()
26 * Log lapd_datalink state on errors
27 * jenkins: add dispatcher script
28 * Embedded: disable stats test
29 * Embedded: add sercomm stubs
30 * GSUP: don't fail test on first error
31 * jenkins: remove obsolete scripts
32 * jenkins: move make invocation into shared function
33 * utils: add helper wrapper for osmo_strlcpy()
34 * GSUP: change osmo_gsup_encode() return type
35 * Use python 3 for utilities
36 * Add test for gsm48_generate_mid_from_imsi()
37 * Add generic Mobile Identity encoder
38 * Add function to encode classmark
39
40 [ Niro Mahasinghe ]
41 * gsm0503_coding.c: Fix tch_efr_unreorder() of one bit
42 * gsm0503_coding.c: Use majority vote in tch_efr_unreorder()
43
44 [ Harald Welte ]
45 * debian: build now depends on libgnutls
46 * Fix/Update copyright notices; Add SPDX annotation
47 * Print /proc/cpuinfo before executing testsuite
48 * conv_acc: Our code requires SSSE3, not just SSE3
49 * ports.h: Use same VTY port number for osmo-mgw and osmo-bsc_mgcp
50 * gsmtap.h: Introduce new GSMTAP type for LTE NAS messages
51 * gsm0808_create_cipher_reject: Fix encoding of Cause IE
52 * rate_ctr: print proper error message if rate_ctr already exists
53 * timer: fixup whitespace issues
54 * control_if: Close control connection socket/fd on read/write == 0
55 * control_if: Log the disconnect of a CTRL client
56 * CTRL: Ensure peer/connection info is always printed the same way
57 * MNCC: Add MNCC to string dumper
58 * gsm48_pdisc_names: Use conscise, short names
59 * SMS: Add value_string for TS 04.11 CP and RP state
60 * gsm_04_08.h: Clearly annotate timers that don't have a 3GPP Default value
61 * gsm_04_08.h: Reduce T310 default to 30s.
62 * gsm48_hdr_msg_type[_r99]: Fix bit-masks
63 * gsm48_hdr_msg_type(): SS is in the same group as MM/CC
64 * tlv_parser: Report *first* occurrence of repeated IEs
65 * msgb: Add msgb_hexdump_{l2,l3}() to dump l2 or l3 part of message buffer
66 * Revert "Use python 3 for utilities"
67 * Revert "fsm: do not terminate child FSMs early"
68 * osmo_msgbdump_{l2,l3}(): Proper typecast
69 * debian/control: Fix Vcs-Browser URL
70 * Add GSM 04.08 type-of-number / numbering-plan-id definitions
71 * talloc_ctx_vty: Fix help strings (missing \n at end of line)
72 * Revert "Add function to encode classmark"
73 * rate_ctr: Add rate_ctr_inc2() as convenience wrapper
74 * coding: Add BER-reporting RACH decode functions
75 * l1sap: Add RSSI, BER and quarter-bit accurate timing to PH-RACH.ind
76 * l1sap: Add fields for higher-precision timing offset values
77 * abis_nm: Introduce abis_nm_dump_foh()
78 * VTY: Don't welcome the user to the "control" interface, if it's VTY
79 * prevent integer underflow in ipa_ccm_make_id_resp_from_req()
80 * RSL/LAPDm: Not all RLL message are "transparent"
81
82 [ Neels Hofmeyr ]
83 * vty: deprecate now empty node commands
84 * memleak: osmo_config_list_parse: getline() needs free also on error
85 * abis_test: sanitize: fix msgb memleak
86 * lapd_test: sanitize: fix msgb memleaks
87 * gsm0408_test: sanitize: cleanup msgb
88 * gsm0808_test: sanitize: fix msgb memleak
89 * msgb: add inline msgb_queue_free()
90 * rate_ctr: fix mem leak for mangled desc
91 * bssgp_fc_test: remove rounding to deciseconds
92 * bssgp_fc_test: clarify by outputting ok / failure messages
93 * bssgp_fc_test: sanitizer: free msgb context when done
94 * gprs_bssgp: bssgp_fc_in(): fix mem leak on queue overflow
95 * bssgp_fc_test: sanitize: free fc struct when done
96 * tlv_put: guard against NULL val and 0 len
97 * sercomm_test: sanitize: fix msgb mem leak
98 * osmo_strlcpy: sanitize: don't memcpy from NULL src even if len is 0
99 * fsm_tmr_cb: don't set T=0, the fi may no longer exist
100 * vty XML export: avoid repeating common node commands for each node
101 * VTY reference: do not list empty nodes
102 * VTY reference: use node names as section names
103 * vty: set name for VIEW+ENABLE nodes, for VTY reference
104 * vty reference: merge_doc.xsl: do not omit description tag
105 * comment: utils: more accurately describe OSMO_STRINGIFY macro
106 * logging vty: describe 'logging set-log-mask' command, add OSMO_STRINGIFY_VAL()
107 * fix osmo_identifier_valid(): only allow printable characters
108 * utils: add osmo_separated_identifiers_valid()
109 * add osmo_auth_c3() (separate from gsm_milenage())
110 * utils: add osmo_escape_str()
111 * ctrl_test.c: replace print_escaped() with new osmo_escape_str()
112 * ctrl: prep test: separate new ctrl_handle_msg() from handle_control_read()
113 * ctrl_test: expand to test message handling and detect mem leaks
114 * ctrl_test: show memleak when receiving GET_REPLY and SET_REPLY commands
115 * ctrl: fix mem leak when handling GET_REPLY and SET_REPLY
116 * ctrl_test: add two more current parsing bugs to prep for fix
117 * add ctrl_cmd_parse2() to return parsing errors
118 * ctrl: on parse errors, return a detailed message to sender
119 * rate_ctr: fix osmo-sgsn DoS: don't return NULL on already used index
120 * ports: define proper VTY and CTRL ports for OsmoHNBGW
121 * ctrl: tighten CTRL input parsing
122 * ctrl: separate handling of GET_REPLY, SET_REPLY and TRAP
123 * jenkins: add 'make V=1' for more verbose build logs
124 * logging vty: tweak general 'logging' command doc
125 * gsm: add gsm0808_speech_codec_type_names
126 * logging-gsmtap: send only basename of source file
127 * logging: add ability to log the log-level with API and vty
128 * logging: color the log level
129 * logging: color the log category according to level
130 * fix -Werror build: logging.c: always use literal with snprintf
131 * cosmetic: logging: if color is disabled, don't print ""
132 * logging: separate the '<000b>' subsys from filename logging
133 * logging: allow to log only the basename of each source
134 * logging vty: add 'logging print file (0|1|basename)' cmd
135 * vty: fix 'logging print file' output
136 * gsmtap_sendmsg(): clarify API doc concerning msgb ownership
137 * memleak: gsmtap_sendmsg(): don't return 0 when no data was written
138 * memleak: fix all libosmocore callers of gsmtap_sendmsg() to free on failure
139 * memleak: _gsmtap_raw_output(): free msg in case of vsnprintf failure
140 * cosmetic: gsm0408_test: RA test cases as array-of-struct
141 * gsm0408_test: cosmetically re-order MCC to come before MNC
142 * gsm0408_test: include BCD and leading zeros in test output
143 * gsm0408_test: RA test: include min/max value cases
144 * gsm0408_test: also test gsm48_generate_lai() and gsm48_decode_lai()
145 * implement support for 3-digit MNC with leading zeros
146 * gsm0408_test: check for new mnc_3_digits flag
147 * gsm0408_test: test new gsm48_{decode,generate}_lai2() functions
148 * gsm0408_test: add test cases for MNC with leading zeros
149 * gsm: add osmo_mnc_from_str(), osmo_mnc_cmp(), osmo_plmn_cmp() for 3-digit MNC
150 * introduce GSM_MCC_MNC_INVALID
151 * gsm23003_test: fix: compare members instead of bcmp
152 * fix osmo_mnc_from_str(): don't try to parse NULL
153 * gsm23003: add osmo_mcc_from_str()
154 * configure: add --enable-werror
155 * jenkins_amd64.sh: use --enable-werror configure flag, not CFLAGS
156 * gsm0808_test: cosmetic: re-arrange struct init; print hexdump on failure
157 * gsm0808_test: cosmetic: test non-hex MCC
158 * show failure in gsm0808_enc_cell_id_list2() in gsm0808_test
159 * fix gsm0808_enc_cell_id_list2 for leading-zero MNC
160 * cosmetic: gsm0808_test: drop extraneous assertion
161 * contrib/fsm-to-dot: add -h option to print basic instructions
162 * contrib/fsm-to-dot: allow transition from and to the same state
163 * contrib/fsm-to-dot: don't match on event names in comments
164 * contrib/fsm-to-dot: warn and draw unallowed state transitions
165 * contrib/fsm-to-dot: add default edge label '-'
166 * contrib/fsm-to-dot: mark arrows that feed events
167 * contrib/fsm-to-dot: less false positives on event parsing
168 * contrib/fsm-to-dot: mark illegal states in red
169 * contrib/fsm-to-dot: warn about identically named FSMs
170 * vty/command.c: write_config_file(): sanely compose temp path
171 * fix logging talloc ctx: add osmo_init_logging2()
172 * ctrl: test deferred cmd, show current failure
173 * ctrl: fix deferred commands (and hence fix osmo-bts-sysmo 'clock-info' cmd)
174 * cosmetic: flatten ctrl_handle_msg()
175 * fix ctrl_test sanitizer issues
176 * use osmo_init_logging2() with proper talloc ctx
177 * add osmo_quote_str(),osmo_quote_str_buf() and test
178 * fsm_test: terminate the main loop instead of exit on timeout
179 * osmo_fsm_inst_find_by_name(): guard against strcmp(NULL)
180 * fsm_test: more thoroughly test FSM inst ids and names
181 * fsm: id: properly set name in case of NULL id
182 * cosmetic: osmo_fsm_inst_update_id(): don't log "allocate"
183 * add osmo_fsm_inst_update_id_f()
184 * add gsm48_reject_value_names
185 * deprecate PLMN de-/coding functions incapable of 3-digit MNC with leading zeros
186 * avoid warning in gsm0808_create_layer3
187 * add osmo_cgi_name()
188 * add gsm0808_cell_id_list_add() to combine two cell identifier lists
189 * add tlv_parse2(), capable of multiple instances of the same IE
190 * add gsm0808_{enc,dec}_cell_id
191 * test_gsm0808_enc_dec_cell_id_list_lac(): validate encoded bytes
192 * test_gsm0808_enc_dec_cell_id_list_lac(): populate all LACs
193 * test_gsm0808_enc_dec_speech_codec_with_cfg: initialize properly
194 * cosmetic: log: fix typo, clarify msg for rate_ctr name mangling
195 * tlv: add TLV_GET() and TLV_GET_MINLEN()
196 * add gsm0808_cell_{id,id_list}_name() and friends
197 * gsm0808_test: fix more missing inits (address sanitizer issues)
198 * gsm0808_test: silence deprecation: use gsm0808_create_layer3_2()
199
200 [ Philipp Maier ]
201 * vty: add port number for osmo-mgw
202 * libosmocodec: add FR bit offset definitions
203 * libosmocodec: implement ECU (Error Concealment Unit) for FR
204 * fsm: fix double llist_del in osmo_fsm_inst_term()
205 * socket: fix socket leak in osmo_sock_local_ip()
206 * socket: use inet_ntop() instead of inet_ntoa() in osmo_sock_local_ip()
207 * fsm: add functions for unlinking and changing parents
208 * fsm: do not terminate child FSMs early
209 * fsm: allow graceful exit on FSM termination
210 * features: move bts feature related functionality to libosmocore
211 * features: define osmo_bts_*_feature() as static inline
212 * gsm_08_08: correct speech codec defaults
213 * gsm0808: Add value strings for BSSMAP cause codes
214
215 [ Pau Espin Pedrol ]
216 * vty: Fix bad use of vector_slot()
217 * gsm: Use correct include for getrandom
218 * utils: Fix false positive in compiler warning
219 * cosmetic: Fix trailing whitespace
220 * Fix malformed Abis/RSL messages with extra L3 Information field
221 * tests: coding_test: Fix compilation with -O0
222 * tests: utils_test: Fix test failure when compiling with -O0
223 * ports.h: Add VTY and CTRL ports for osmo-trx
224 * core: Add timespec helper macros and make timer_compat.h public
225 * core/logging.h: Add logging category for jitter buffer
226 * timer: Introduce osmo_clock_gettime to override clock_gettime
227 * timer: Document osmo_gettimeofday API
228 * osmo-release.sh: Set correct version when generating the changelog
229 * socket.c: osmo_sock_init2: bind: Several logic fixes and log improvements
230 * socket.c: osmo_sock_init2: connect: Several logic fixes and log improvements
231 * socket.c: osmo_sock_init: Several logic fixes and log improvements
232 * msgb: msgb_get: Drop unneeded tmp var
233 * msgb: msgb_pull: Abort when pulling more than avail size
234 * osmo_get_macaddr: Fix buffer read out of bounds
235 * osmo_sockaddr_is_local: Fix memleak
236 * gsm_08_58.h: Add Ericsson vendor-specific RSL message types
237 * osmo-release.sh: Remove temporary file TODO-RELEASE.entries after use
238 * osmo-release.sh: Exit with error if no description for new changelog entry provided
239 * osmo-release.sh: Fix error condition no LIBVERSION modified
240 * osmo-release.sh: Always generate entire commit changelog
241 * osmo-release.sh: Allow user to add extra information to the release commit
242 * debian: libosmoctrl: Use correct library version in pkg name
243 * debian/changelog: Fix typo in maintainer e-mail
244
245 [ Holger Hans Peter Freyther ]
246 * logging: Extend the LOGPSRC macro to put cont in it as well
247 * license: Fix the license to GPL
248
249 [ Alexander Couzens ]
250 * counters: add osmo_counters_count() returns the amount of counters
251 * vty: show asciidoc counters: don't create an empty table for osmo_counters
252 * gsm_08_58.h: introduce RSL_IE_ERIC_PAGING_GROUP
253 * gsm_utils: call gnutls_global_init() as constructor
254
255 [ Jean-Francois Dionne ]
256 * Fix LAPD UA msgb memory leak.
257
258 [ Vadim Yanitskiy ]
259 * libosmocodec: add FR/HR/EFR frame length definitions
260 * ussd_test.c: fix rc / len debug output confusion
261 * gsm0480: fix USSD OCTET STRING length confusion
262 * gsm0480: clean up the parse_process_uss_req() code
263 * gsm0480: handle UnstructuredSS Request with DSC != 0x0F
264 * gsm0480: parse GSM0480_MTYPE_FACILITY separately
265 * gsm0480: handle GSM0480_CTYPE_RETURN_RESULT
266 * gsm0480: handle USS_NOTIFY and USS_REQUEST with PROCESS_USS_REQ
267 * gsm0480: handle GSM0480_OP_CODE_PROCESS_USS_DATA
268 * gsm0480: add specification reference to SS message type
269 * gsm0480: pass exact GSM 04.80 payload length to parse_ss()
270 * gsm0480: move SS request length check to parse_ss()
271 * gsm0480: refactor gsm0480_decode_ss_request
272 * gsm0480: correct parse_ss_info_elements() declaration
273 * tests/ussd: fix wrong GSM 04.80 payload length
274 * gsm0480: parse all SS info elements in a message
275 * gsm0480: parse optional IEs for RELEASE COMPLETE message
276 * tests/ussd: prevent uninitialized memory access
277 * libosmocoding: fix typo in library documentation
278 * libosmocoding: use frame length definitions from codec.h
279 * src/msgb.c: cosmetic: fix spelling mistakes
280 * src/msgb.c: remove dead includes from OpenBSC
281 * src/msgb.c: print an error if msgb allocation failed
282 * src/msgb.c: avoid using internal talloc API
283 * gsm0480: document the 'ss_request' structure
284 * gsm0480: copy the raw USSD data, its DCS and length
285 * gsm0480: drop messages with incorrect data length
286 * protocol/gsm_04_08.h: drop incorrect GSM48_PDISC_USSD
287 * gsm/gsm48.c: add call independent SS message names
288
289 [ Stefan Sperling ]
290 * TLVP_PRESENT() should not return TRUE after tlv_parse() fails.
291 * Add helper functions for ACC bit flags in rach control IE.
292 * ensure that osmo_fsm vty commands are only installed once
293 * print BIG FAT ERROR message if osmo_fsm lacks event names
294 * ensure VTY commands don't segfault if an FSM has no event names
295 * support for more cell ID list types in libosmocore
296 * fix a cell identifier parsing bug in libosmocore
297 * fix cell identifier decoding in libosmocore
298 * use gsm48_decode_lai2() in gsm0808_dec_cell_id_list()
299 * fix bug in parse_cell_id_ci_list()
300 * fix parse_cell_id_lac_and_ci_list()
301 * add a test for CELL_IDENT_WHOLE_GLOBAL cell identifier lists
302 * add a regression test for TLV parsing with repeated IEs
303
304 [ Sergey Kostanbaev ]
305 * gsm0480: skip length check for 'RELEASE COMPLETE' message
306
307 [ allesklar2 ]
308 * gsmtap.h: define TETRA DMO mode channels
309
310 [ Martin Hauke ]
311 * build: Ensure all .pc files are installed
312
313 [ Daniel Willmann ]
314 * fsm: Add a function to change the FSM instance ID later
315 * contrib/jenkins_arch.sh: Fix script comparison and arm support
316 * fsm: Update the name as well if the id is updated and accept NULL
317
318 [ Thorsten Alteholz ]
319 * fix spelling
320 * fix issue on big endian architecture
321
322 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 15:47:11 +0200
323
Harald Welte69b61fe2017-11-02 18:51:03 +0100324libosmocore (0.10.2) unstable; urgency=medium
325
326 * Revert "vty: Fix bad use of vector_slot()"
327 * New upstream release of libosmocore
328
Pau Espin Pedrol456081d2018-05-03 15:39:11 +0200329 -- Harald Welte <laforge@gnumonks.org> Thu, 02 Nov 2017 18:51:02 +0100
Harald Welte69b61fe2017-11-02 18:51:03 +0100330
Harald Welted9abb0a2017-10-29 10:46:47 +0100331libosmocore (0.10.1) unstable; urgency=medium
332
333 * New upstream release of libosmocore
334
Pau Espin Pedrol456081d2018-05-03 15:39:11 +0200335 -- Harald Welte <laforge@gnumonks.org> Sun, 29 Oct 2017 10:46:47 +0100
Harald Welted9abb0a2017-10-29 10:46:47 +0100336
Harald Weltefaee5de2017-10-27 19:43:33 +0200337libosmocore (0.10.0+nmu1) UNRELEASED; urgency=medium
338
339 * Non-maintainer upload.
340 * New upstream release of libosmocore
341
Pau Espin Pedrol456081d2018-05-03 15:39:11 +0200342 -- Harald Welte <laforge@gnumonks.org> Fri, 27 Oct 2017 19:45:00 +0200
Harald Weltefaee5de2017-10-27 19:43:33 +0200343
Max4e72ee02016-12-13 18:41:17 +0100344libosmocore (0.9.6) unstable; urgency=medium
345
346 * doc: osmocom-authn-protocol.txt: fix numbering, mark unused sync msgs
347 * New upstream release of libosmocore.
348
349 -- Max <msuraev@sysmocom.de> Tue, 13 Dec 2016 18:23:56 +0100
350
351libosmocore (0.9.5) unstable; urgency=medium
352
353 * fix: DLGSUP logging category "unusable"
354 * New upstream release of libosmocore.
355 * ph_data_param struct changed / Extend L1SAP PH-DATA with measurement information
356 * size of ph_tch_param struct changed / Extend with RTP Marker
357 * size of struct log_target changed / Extend with GSMTAP
358
359 -- Max <msuraev@sysmocom.de> Tue, 13 Dec 2016 18:22:56 +0100
360
361libosmocore (0.9.4) unstable; urgency=medium
362
363 * New upstream release of libosmocore.
364 * Internal API for GPRS cipher implementors updated to accommodate for arbitrary key lengths
365 * external talloc dependency / internal talloc removal
366 * size of ph_data_param struct changed / Extend L1SAP PH-DATA with presence information
367
368 -- Max <msuraev@sysmocom.de> Tue, 13 Dec 2016 18:21:56 +0100
369
Holger Hans Peter Freytherabc46af2015-11-09 21:34:43 +0100370libosmocore (0.9.3) unstable; urgency=medium
371
372 * Send all stats values after re-configuration.
373 * Fix using an empty prefix.
374 * Fix sending timing values.
375
376 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Mon, 09 Nov 2015 21:34:37 +0100
377
Holger Hans Peter Freythereed46952015-11-04 14:48:13 +0100378libosmocore (0.9.2) unstable; urgency=medium
379
380 * Fix the counter index after the NS reset.
381
382 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Wed, 04 Nov 2015 14:47:48 +0100
383
Holger Hans Peter Freyther6e149b12015-11-04 10:23:57 +0100384libosmocore (0.9.1) unstable; urgency=medium
385
386 * Fix rate_ctr attribute for GPRS NS counters.
387
388 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Wed, 04 Nov 2015 10:23:39 +0100
389
Holger Hans Peter Freyther8649d572015-11-03 09:30:52 +0100390libosmocore (0.9.0) unstable; urgency=medium
391
392 * StatsD support
393 * Disable building of static libraries
394 * GTP Hub and OAP ports/identifiers assigned
395
396 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Tue, 03 Nov 2015 09:31:41 +0100
397
Holger Hans Peter Freytherd452a482015-08-23 17:38:26 +0200398libosmocore (0.8.3) unstable; urgency=medium
399
400 * Prepare new release
401
402 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Sun, 23 Aug 2015 17:38:55 +0200
403
Holger Hans Peter Freytherc136da52015-08-01 20:19:13 +0200404libosmocore (0.8.2) unstable; urgency=medium
Holger Hans Peter Freytherad69f892015-04-16 21:23:49 +0200405
406 * Add endian header
Holger Hans Peter Freyther16082fd2015-05-06 17:58:07 +0200407 * GPRS flow control changes
Holger Hans Peter Freythera6ea50c2015-05-25 14:17:29 +0200408 * Add APN format routines to libosmocore.
Holger Hans Peter Freytherad69f892015-04-16 21:23:49 +0200409
Holger Hans Peter Freytherc136da52015-08-01 20:19:13 +0200410 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Sat, 01 Aug 2015 20:18:45 +0200
Holger Hans Peter Freytherad69f892015-04-16 21:23:49 +0200411
412libosmocore (0.8.0) unstable; urgency=medium
Holger Hans Peter Freyther25aeab72015-01-18 19:05:19 +0100413
414 * New upstream release of libosmocore.
415
416 -- Holger Hans Peter Freyther <holger@freyther.de> Sun, 18 Jan 2015 19:04:10 +0100
417
418libosmocore (0.7.0) unstable; urgency=medium
Harald Welte336915a2014-08-21 15:51:07 +0200419
420 * New upstream release of libosmocore.
421
422 -- Harald Welte <laforge@gnumonks.org> Thu, 21 Aug 2014 15:52:00 +0200
423
Holger Hans Peter Freyther0c50b172014-03-31 15:36:57 +0200424libosmocore (0.6.6) UNRELEASED; urgency=medium
425
426 * New upstream release of libosmocore.
427
428 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 31 Mar 2014 15:37:33 +0200
429
430libosmocore (0.6.5) unstable; urgency=medium
Holger Hans Peter Freyther050e9c42014-01-20 10:37:42 +0100431
432 * New upstream release of libosmocore
433
434 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 20 Jan 2014 10:37:23 +0100
435
436libosmocore (0.6.4+git3) unstable; urgency=low
Jacob Erlbeck1fa16642013-11-11 09:43:06 +0100437
438 * GPRS fix NS connections to a SGSN when configured via VTY
439
440 -- Jacob Erlbeck <jerlbeck@sysmocom.de> Thu, 07 Nov 2013 16:07:20 +0100
441
442libosmocore (0.6.4+git2) unstable; urgency=low
Holger Hans Peter Freytherf41e5e62013-10-10 14:17:51 +0200443
444 * GPRS related changes, some GSM encoding/decoding changes
Holger Hans Peter Freyther81286a72013-10-17 14:49:02 +0200445 * GPRS correctly determine routable NSVC.
Holger Hans Peter Freyther7fcb3ce2013-10-25 09:51:17 +0200446 * Update with GPRS changes
Holger Hans Peter Freytherf41e5e62013-10-10 14:17:51 +0200447
448 -- Holger Hans Peter Freyther <holger@freyther.de> Thu, 10 Oct 2013 14:16:37 +0200
449
450libosmocore (0.6.3+git1-1) unstable; urgency=low
Holger Hans Peter Freyther73fa6422013-08-09 17:48:06 +0200451
452 * New upstream release with new primitives, USSD fixes.
Holger Hans Peter Freyther9a935e22013-08-12 11:47:12 +0200453 * Split libosmocore into several package. One lib per package.
Holger Hans Peter Freyther73fa6422013-08-09 17:48:06 +0200454
455 -- Holger Hans Peter Freyther <holger@freyther.de> Fri, 09 Aug 2013 17:47:30 +0200
456
Holger Hans Peter Freytherd2446752013-06-26 08:03:14 +0200457libosmocore (0.6.2) unstable; urgency=low
Holger Hans Peter Freytherb64b2b02013-03-25 17:41:15 +0100458
459 * New upstream release with NS UDP DSCP ABI changes
460
Holger Hans Peter Freytherd2446752013-06-26 08:03:14 +0200461 -- Holger Hans Peter Freyther <holger@freyther.de> Wed, 26 Jun 2013 08:01:55 +0200
Holger Hans Peter Freytherb64b2b02013-03-25 17:41:15 +0100462
463libosmocore (0.5.3+git1-6) unstable; urgency=low
Holger Hans Peter Freytherb73d1912013-01-04 09:55:29 +0100464
465 * Build new package with the new API required for osmo-bts/openbsc
Holger Hans Peter Freytherb3f304b2013-02-13 18:11:43 +0100466 * Package the arfcn utility.
467 * Add the SOCK_RAW work-around for glibc.
Holger Hans Peter Freythera5007db2013-02-13 19:27:42 +0100468 * Re-enable the debug packages thanks to Jan.
Holger Hans Peter Freytherb73d1912013-01-04 09:55:29 +0100469
470 -- Holger Hans Peter Freyther <holger@freyther.de> Fri, 04 Jan 2013 09:54:55 +0100
471
Holger Hans Peter Freyther9e6789d2012-11-05 21:36:48 +0100472libosmocore (0.5.3+git1-2) unstable; urgency=low
473
Pau Espin Pedrol456081d2018-05-03 15:39:11 +0200474 * New upstream version
Holger Hans Peter Freyther9e6789d2012-11-05 21:36:48 +0100475
476 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 05 Nov 2012 21:35:57 +0100
477
Eric Butlerb5372ab2012-08-14 20:43:47 -0700478libosmocore (0.5.3+git1-1) precise; urgency=low
479
480 * Fix issue with package version.
481
482 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 20:43:17 -0700
483
Eric Butler8dbdc4f2012-08-14 18:07:00 -0700484libosmocore (0.5.3+git1) precise; urgency=low
485
486 * Updated debian package.
487
488 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 16:53:56 -0700
489
Harald Weltef5afa182011-05-10 17:29:01 +0200490libosmocore (0.3.0) natty; urgency=low
491
492 * New upstream version of libosmocore
493
494 -- Harald Welte <laforge@gnumonks.org> Tue, 10 May 2011 17:28:24 +0200
495
Holger Hans Peter Freytherab1255b2011-01-13 18:09:44 +0800496libosmocore (0.1.27) natty; urgency=low
497
498 * New upstream version of libosmocore.
499
500 -- Holger Hans Peter Freyther <holger@freyther.de> Thu, 13 Jan 2011 18:07:36 +0800
501
Harald Welted4bb7ab2010-08-24 15:17:13 +0200502libosmocore (0.1.17-1) unstable; urgency=low
503
Holger Hans Peter Freyther9a935e22013-08-12 11:47:12 +0200504 * Initial release
Harald Welted4bb7ab2010-08-24 15:17:13 +0200505
506 -- Harald Welte <laforge@gnumonks.org> Tue, 24 Aug 2010 10:55:04 +0200