blob: 26d288047ec26f8b8c89b8feb475a049805a8bf2 [file] [log] [blame]
Eric Butler91ffa2b2012-08-14 18:07:48 -07001#!/usr/bin/make -f
2
Eric Butlerd11a5c12012-08-14 20:56:26 -07003DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
4DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
5VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
6
Eric Butler91ffa2b2012-08-14 18:07:48 -07007CFLAGS = -Wall -g
8
9export DH_VERBOSE=1
10
11%:
12 dh --with autoreconf $@ --fail-missing
Eric Butlerd11a5c12012-08-14 20:56:26 -070013
14override_dh_autoreconf:
15 echo $(VERSION) > .tarball-version
16 dh_autoreconf