blob: ac91c60a16e6cd4b7b530f600a548eb8f2a547b7 [file] [log] [blame]
Oliver Smith39dffb62020-05-14 11:28:06 +02001#
2# spec file for package libosmo-abis
3#
4# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
5#
6# All modifications and additions to the file contributed by third parties
7# remain the property of their copyright owners, unless otherwise agreed
8# upon. The license for this file, and modifications and additions to the
9# file, is the same license as for the pristine package itself (unless the
10# license for the pristine package is not an Open Source License, in which
11# case the license is the MIT License). An "Open Source License" is a
12# license that conforms to the Open Source Definition (Version 1.9)
13# published by the Open Source Initiative.
14
15# Please submit bugfixes or comments via http://bugs.opensuse.org/
16#
17
18
19%define version_unconverted 0.8.0.26
20
21Name: libosmo-abis
22Version: 0.8.0.26
23Release: 0
24Summary: Osmocom library for A-bis interface between BTS and BSC
25License: AGPL-3.0-or-later AND GPL-2.0-or-later
26Group: Productivity/Telephony/Utilities
27Url: https://osmocom.org/projects/libosmo-abis/wiki/Libosmo-abis
28
29Source: %name-%version.tar.xz
30Patch1: osmo-talloc.diff
31BuildRoot: %{_tmppath}/%{name}-%{version}-build
32BuildRequires: automake >= 1.6
33#BuildRequires: dahdi-linux-devel
34BuildRequires: libtool >= 2
35BuildRequires: pkgconfig >= 0.20
36BuildRequires: xz
37BuildRequires: pkgconfig(libosmocore) >= 1.0.0
38BuildRequires: pkgconfig(libosmogsm) >= 1.0.0
39BuildRequires: pkgconfig(libosmovty) >= 1.0.0
40BuildRequires: pkgconfig(ortp) >= 0.22
41BuildRequires: pkgconfig(talloc)
42
43%description
44In GSM, A-bis is a BSS-internal interface link between the BTS and
45BSC. This interface allows control of the radio equipment and radio
46frequency allocation in the BTS.
47
48%package -n libosmoabis6
49Summary: Osmocom GSM A-bis interface library
50License: AGPL-3.0-or-later
51Group: System/Libraries
52
53%description -n libosmoabis6
54In the GSM system architecture, A-bis is a Base Station
55System-internal interface linking the Base Transceiver Stations (BTS)
56and Base Station Controller (BSC). This interface allows control of
57the radio equipment and radio frequency allocation in the BTS.
58
59This library contains common/shared code regarding this A-bis
60interface. It also implements drivers for mISDN and DAHDI-based E1
61cards, as well as some A-bis/IP dialects.
62
63%package -n libosmoabis-devel
64Summary: Development files for the Osmocom GSM A-bis library
65License: AGPL-3.0-or-later
66Group: Development/Libraries/C and C++
67Requires: libosmoabis6 = %version
68Requires: libosmocore-devel >= 0.3.0
69Requires: libosmogsm-devel >= 0.3.10
70
71%description -n libosmoabis-devel
72This library contains common/shared code regarding the GSM A-bis
73interface. It also implements drivers for mISDN and DAHDI-based E1
74cards, as well as some A-bis/IP dialects.
75
76This subpackage contains libraries and header files for developing
77applications that want to make use of libosmoabis.
78
79%package -n libosmotrau2
80Summary: Osmocom GSM TRAU (E1/RTP) library
81License: GPL-2.0-or-later
82Group: System/Libraries
83
84%description -n libosmotrau2
85This library implements the Transcoder and Rate Adaptation Unit (TRAU) for
86GSM systems.
87The TRAU enables the use of lower rates (32, 16 or 8 kbps) over the
88A-bis interface instead of the 64 kbps ISDN rate for which the Mobile
89Switching Center (MSC) is designed.
90
91%package -n libosmotrau-devel
92Summary: Development files for the Osmocom TRAU (E1/RTP) library
93License: GPL-2.0-or-later
94Group: Development/Libraries/C and C++
95Requires: libosmotrau2 = %version
96
97%description -n libosmotrau-devel
98This library implements the Transcoder and Rate Adaptation Unit
99(TRAU) for GSM systems.
100
101This subpackage contains libraries and header files for developing
102applications that want to make use of libosmotrau.
103
104%prep
105%setup -q
106%patch -P 1 -p1 -F2
107
108%build
109echo "%version" >.tarball-version
110autoreconf -fiv
111# FIXME: Compiler warnings with ortp 0.24.2 result in hard-errors during rpm-postbuild-checks - should be fixed upstream
112%if 0%{?sle_version}
113export CFLAGS='%{optflags} -Wno-int-conversion'
114%endif
115%configure \
116 --enable-shared \
117 --disable-static \
118 --disable-dahdi \
119 --includedir="%_includedir/%name"
120make %{?_smp_mflags}
121
122%install
123b="%buildroot"
124make %{?_smp_mflags} install DESTDIR="$b"
125find "$b/%_libdir" -type f -name "*.la" -delete
126
127%check
128make %{?_smp_mflags} check || (find . -name testsuite.log -exec cat {} +)
129
130%post -n libosmoabis6 -p /sbin/ldconfig
131%postun -n libosmoabis6 -p /sbin/ldconfig
132%post -n libosmotrau2 -p /sbin/ldconfig
133%postun -n libosmotrau2 -p /sbin/ldconfig
134
135%files -n libosmoabis6
136%defattr(-,root,root)
137%_libdir/libosmoabis.so.6*
138
139%files -n libosmoabis-devel
140%defattr(-,root,root)
141%doc COPYING
142%dir %_includedir/%name
143%dir %_includedir/%name/osmocom
144%_includedir/%name/osmocom/abis/
145%_libdir/libosmoabis.so
146%_libdir/pkgconfig/libosmoabis.pc
147
148%files -n libosmotrau2
149%defattr(-,root,root)
150%_libdir/libosmotrau.so.2*
151
152%files -n libosmotrau-devel
153%defattr(-,root,root)
154%doc COPYING
155%dir %_includedir/%name
156%dir %_includedir/%name/osmocom
157%_includedir/%name/osmocom/trau
158%_libdir/libosmotrau.so
159%_libdir/pkgconfig/libosmotrau.pc
160
161%changelog