blob: 68064ca52902f345031eb7707c178f8e8aee609f [file] [log] [blame]
Pau Espin Pedrolc313d442020-01-02 20:53:32 +01001libosmo-abis (0.8.0) unstable; urgency=medium
2
3 [ Alexander Couzens ]
4 * ipa: ipa_server_link_close() add checks of link state
5
6 [ Pau Espin Pedrol ]
7 * ipa: Allow setting local addr and port for struct ipa_client_conn
8
9 [ Harald Welte ]
10 * dahdi: Use ioctl(DAHDI_SPECIFY) instead of legacy /dev/dahdi/%u
11 * Enable DAHDI support by default; require --disable-dahdi otherwise
12
13 [ Vadim Yanitskiy ]
14 * input/ipaccess.c: propagate errors from ipa_parse_unitid()
15 * input/ipaccess.c: fix debug message on receipt of IPAC_MSGT_ID_GET
16 * e1_input.c: make reference counting get() / put() more verbose
17 * input/ipa_keepalive.c: make sure IPA keepalive FSM is registered
18
19 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 02 Jan 2020 20:53:32 +0100
20
Harald Welte30249a12019-07-21 21:32:08 +020021libosmo-abis (0.7.0) unstable; urgency=medium
22
23 [ Max ]
24 * Set local IP in ipa_server_link properly
25 * Log peer's port in accept callback
26
27 [ Harald Welte ]
28 * ipa: Make ipa_server_conn_destroy() re-entrant
29 * Add IPA keep-alive FSM implementation
30 * ipa_keepalive_fsm: Fix OSMO_IPA_KA_E_STOP allstate event
31 * ipa_keepalive_fsm: Suppress error messages for INIT -> INIT transition
32 * ipaccess.c: Avoid calling close(-1) on error path
33
34 [ Oliver Smith ]
35 * tests: use -no-install libtool flag to avoid ./lt-* scripts
36 * contrib/jenkins.sh: run "make maintainer-clean"
37
38 [ Sylvain Munaut ]
39 * rtp: Add 'autoconnect' feature to the osmo_rtp_socket
40
41 [ Eric Wild ]
42 * ipaccess: allow tcp keepalive for ipa clients
43 * add TCP_USER_TIMEOUT to keepalive
44 * extend the ipa keepalive fsm
45
46 [ Debian Mobcom Maintainers ]
47 * spelling
48
49 -- Harald Welte <laforge@gnumonks.org> Sun, 21 Jul 2019 21:32:08 +0200
50
Harald Welte176a1fb2019-01-19 22:20:47 +010051libosmo-abis (0.6.0) unstable; urgency=medium
52
53 [ Neels Hofmeyr ]
54 * fix strncpy bugs in ipaccess.c, ipa_proxy.c
55 * ipa: don't crash on missing IPA ID GET message
56
57 [ Harald Welte ]
58 * Migrate from ipa_ccm_idtag_parse to ipa_ccm_id_resp_parse()
59 * debian/rules: Don't overwrite .tarball-version
60
61 [ Pau Espin Pedrol ]
62 * ipaccess: Use osmo_fd_setup to set up callbacks
63 * ipaccess_rcvmsg: Fix bug introduced in previous commit
64 * ipa: Simplify code in ipa_client_read
65 * ipa: Simplify code in ipa_server_conn_read
66 * ipa: Allow signalling fd destroyed in ipa_client_read
67 * ipa: Allow signalling fd destroyed in ipa_server_conn_read
68 * ipaccess: Return -EBADF when closing socket in ipaccess_bts_read_cb
69 * ipaccess: Allow passing return code in e1inp_line_ops->sign_link()
70 * debian: Fix libosmoabis soname package version
71 * debian: Conflict libosmoabis6 with libosmoabis5
72 * ipacces: Log correct trx_nr during IPA GET
73 * ipaccess: Simplify handling of ipaccess e1line ts
74 * e1_input.h: Set correct type for input_signal_data->link_type
75 * osmo_ortp: Log domain and fix strings without endl char
76
77 [ Stefan Sperling ]
78 * Properly deal with sockaddr_un socket path length limitations.
79 * ensure unix socket paths are NUL-terminated for bind/connect
80
81 -- Harald Welte <laforge@gnumonks.org> Sat, 19 Jan 2019 22:20:46 +0100
82
Pau Espin Pedrol026ff452018-07-27 18:15:19 +020083libosmo-abis (0.5.1) unstable; urgency=medium
84
85 [ Pau Espin Pedrol ]
86 * ipaccess: ipaccess_rcvmsg: Drop unneeded memcpy
87 * ipaccess: Avoid using released line and bfd in ipaccess_fd_cb
88 * e1_input.c: Replace '.' in counter names with ':'
89
90 [ Stefan Sperling ]
91 * fix double-free/use-after-free of pointers in struct e1inp_line
92
93 [ Philipp Maier ]
94 * ortp: make sure the ortp scheduler is started
95 * ortp: reset rtp session on SSRC changes
96 * ortp: detect ssrc changes immediately
97 * ortp: enable scheduled mode on rtp socket creation
98 * Revert "ortp: make sure the ortp scheduler is started"
99 * Revert "ortp: enable scheduled mode on rtp socket creation"
100
101 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 18:15:18 +0200
102
Pau Espin Pedrol7b89f122018-05-03 16:12:04 +0200103libosmo-abis (0.5.0) unstable; urgency=medium
104
105 [ Max ]
106 * Use value string check from osmo-ci
107 * cosmetic: update ipaccess_bts_handle_ccm()
108 * IPA: log remote address
109
110 [ Neels Hofmeyr ]
111 * cosmetic: ipa.c: use msgb_dequeue(), drop local var
112 * jenkins: use osmo-clean-workspace.sh before and after build
113 * vty: skip installing cmds now always installed by default
114 * add --enable-sanitize config option
115 * configure: add --enable-werror
116 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
117
118 [ Alexander Couzens ]
119 * debian/rules: show testsuite.log when tests are failing
120 * unixsocket: fix a potential string overflow
121
122 [ Harald Welte ]
123 * debian/copyright: fix upstream-name
124 * Add SPDX-License-Identifier to all source files
125 * Add a new osmo_rtp_set_source_desc() function to set the RTCP SDES items
126 * debian/control: Fix Vcs-Browser
127
128 [ Pau Espin Pedrol ]
129 * contrib: jenkins.sh: Disable doxygen in libosmocore build
130 * e1_input.h: Remove dead declaration of unexistent API ipaccess_setup
131 * configure.ac: Fix condition check for RTP_SIGNAL_PTR_CAST define
132 * use osmo_init_logging2
133 * git-version-gen: Check first for new tag format
134
135 [ Stefan Sperling ]
136 * preserve 'when' flags of new osmo_fd in ipaccess_rcvmsg()
137
138 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:12:04 +0200
139
Max7f17b8c2017-08-25 16:09:48 +0200140libosmo-abis (0.4.0) unstable; urgency=medium
Holger Hans Peter Freyther64797282016-05-24 23:04:00 +0200141
142 * Move forward towards a new release.
Max7f17b8c2017-08-25 16:09:48 +0200143 * libosmo-abis API change major: add parameter to struct
144 input_signal_data
145 * libosmo-trau API change major: add parameters to rx_cb()
146 callack in osmo_ortp.h
Holger Hans Peter Freyther64797282016-05-24 23:04:00 +0200147
Max7f17b8c2017-08-25 16:09:48 +0200148 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Fri, 25 Aug 2017 16:09:46 +0200
Holger Hans Peter Freyther64797282016-05-24 23:04:00 +0200149
150libosmo-abis (0.3.2) unstable; urgency=medium
Holger Hans Peter Freyther3cef39b2015-11-03 09:40:00 +0100151
152 * Bump so version to re-link libosmovty
153
154 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Tue, 03 Nov 2015 09:42:01 +0100
155
156libosmo-abis (0.3.1) unstable; urgency=medium
Holger Hans Peter Freyther2f0dd0c2015-01-18 19:27:07 +0100157
158 * New upstream release of libosmo-abis
159
160 -- Holger Hans Peter Freyther <holger@freyther.de> Sun, 18 Jan 2015 19:26:40 +0100
161
Holger Hans Peter Freytherb6d28342014-09-08 07:29:50 +0200162libosmo-abis (0.3.0) unstable; urgency=medium
Holger Hans Peter Freytherecd0a362014-03-31 15:49:13 +0200163
164 * New upstream release of libosmo-abis
165
Holger Hans Peter Freytherb6d28342014-09-08 07:29:50 +0200166 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 08 Sep 2014 07:29:39 +0200
167
168libosmo-abis (0.2.0) unstable; urgency=medium
169
170 * New upstream release of libosmo-abis
171
172 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 08 Sep 2014 07:29:19 +0200
Holger Hans Peter Freytherecd0a362014-03-31 15:49:13 +0200173
174libosmo-abis (0.1.6) unstable; urgency=medium
Holger Hans Peter Freytherf6415ea2014-01-20 10:33:52 +0100175
176 * New upstream release of libosmo-abis
177
178 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 20 Jan 2014 10:33:36 +0100
179
Holger Hans Peter Freyther91de2d02013-12-12 11:47:39 +0100180libosmo-abis (0.1.5+git1) unstable; urgency=low
181
182 * Rebuild 0.1.5 with the right libosmocore depedency
183
184 -- Holger Hans Peter Freyther <holger@freyther.de> Thu, 12 Dec 2013 11:47:01 +0100
185
Holger Hans Peter Freyther2dfcd9e2012-11-06 13:34:34 +0100186libosmo-abis (0.1.4) unstable; urgency=low
187
188 * New upstream release
189
190 -- Holger Hans Peter Freyther <holger@freyther.de> Tue, 06 Nov 2012 13:33:45 +0100
191
Eric Butlerd11a5c12012-08-14 20:56:26 -0700192libosmo-abis (0.1.3+git3-1) precise; urgency=low
193
194 * Fix version issue.
195
196 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 20:50:50 -0700
197
Eric Butler91ffa2b2012-08-14 18:07:48 -0700198libosmo-abis (0.1.3+git3) precise; urgency=low
199
200 Created new Ubuntu package.
201
202 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 13:00:18 -0700