blob: db17338a776d6f80a94c345fa0641b7ac120defc [file] [log] [blame]
Harald Welte30249a12019-07-21 21:32:08 +02001libosmo-abis (0.7.0) unstable; urgency=medium
2
3 [ Max ]
4 * Set local IP in ipa_server_link properly
5 * Log peer's port in accept callback
6
7 [ Harald Welte ]
8 * ipa: Make ipa_server_conn_destroy() re-entrant
9 * Add IPA keep-alive FSM implementation
10 * ipa_keepalive_fsm: Fix OSMO_IPA_KA_E_STOP allstate event
11 * ipa_keepalive_fsm: Suppress error messages for INIT -> INIT transition
12 * ipaccess.c: Avoid calling close(-1) on error path
13
14 [ Oliver Smith ]
15 * tests: use -no-install libtool flag to avoid ./lt-* scripts
16 * contrib/jenkins.sh: run "make maintainer-clean"
17
18 [ Sylvain Munaut ]
19 * rtp: Add 'autoconnect' feature to the osmo_rtp_socket
20
21 [ Eric Wild ]
22 * ipaccess: allow tcp keepalive for ipa clients
23 * add TCP_USER_TIMEOUT to keepalive
24 * extend the ipa keepalive fsm
25
26 [ Debian Mobcom Maintainers ]
27 * spelling
28
29 -- Harald Welte <laforge@gnumonks.org> Sun, 21 Jul 2019 21:32:08 +0200
30
Harald Welte176a1fb2019-01-19 22:20:47 +010031libosmo-abis (0.6.0) unstable; urgency=medium
32
33 [ Neels Hofmeyr ]
34 * fix strncpy bugs in ipaccess.c, ipa_proxy.c
35 * ipa: don't crash on missing IPA ID GET message
36
37 [ Harald Welte ]
38 * Migrate from ipa_ccm_idtag_parse to ipa_ccm_id_resp_parse()
39 * debian/rules: Don't overwrite .tarball-version
40
41 [ Pau Espin Pedrol ]
42 * ipaccess: Use osmo_fd_setup to set up callbacks
43 * ipaccess_rcvmsg: Fix bug introduced in previous commit
44 * ipa: Simplify code in ipa_client_read
45 * ipa: Simplify code in ipa_server_conn_read
46 * ipa: Allow signalling fd destroyed in ipa_client_read
47 * ipa: Allow signalling fd destroyed in ipa_server_conn_read
48 * ipaccess: Return -EBADF when closing socket in ipaccess_bts_read_cb
49 * ipaccess: Allow passing return code in e1inp_line_ops->sign_link()
50 * debian: Fix libosmoabis soname package version
51 * debian: Conflict libosmoabis6 with libosmoabis5
52 * ipacces: Log correct trx_nr during IPA GET
53 * ipaccess: Simplify handling of ipaccess e1line ts
54 * e1_input.h: Set correct type for input_signal_data->link_type
55 * osmo_ortp: Log domain and fix strings without endl char
56
57 [ Stefan Sperling ]
58 * Properly deal with sockaddr_un socket path length limitations.
59 * ensure unix socket paths are NUL-terminated for bind/connect
60
61 -- Harald Welte <laforge@gnumonks.org> Sat, 19 Jan 2019 22:20:46 +0100
62
Pau Espin Pedrol026ff452018-07-27 18:15:19 +020063libosmo-abis (0.5.1) unstable; urgency=medium
64
65 [ Pau Espin Pedrol ]
66 * ipaccess: ipaccess_rcvmsg: Drop unneeded memcpy
67 * ipaccess: Avoid using released line and bfd in ipaccess_fd_cb
68 * e1_input.c: Replace '.' in counter names with ':'
69
70 [ Stefan Sperling ]
71 * fix double-free/use-after-free of pointers in struct e1inp_line
72
73 [ Philipp Maier ]
74 * ortp: make sure the ortp scheduler is started
75 * ortp: reset rtp session on SSRC changes
76 * ortp: detect ssrc changes immediately
77 * ortp: enable scheduled mode on rtp socket creation
78 * Revert "ortp: make sure the ortp scheduler is started"
79 * Revert "ortp: enable scheduled mode on rtp socket creation"
80
81 -- Pau Espin Pedrol <pespin@sysmocom.de> Fri, 27 Jul 2018 18:15:18 +0200
82
Pau Espin Pedrol7b89f122018-05-03 16:12:04 +020083libosmo-abis (0.5.0) unstable; urgency=medium
84
85 [ Max ]
86 * Use value string check from osmo-ci
87 * cosmetic: update ipaccess_bts_handle_ccm()
88 * IPA: log remote address
89
90 [ Neels Hofmeyr ]
91 * cosmetic: ipa.c: use msgb_dequeue(), drop local var
92 * jenkins: use osmo-clean-workspace.sh before and after build
93 * vty: skip installing cmds now always installed by default
94 * add --enable-sanitize config option
95 * configure: add --enable-werror
96 * jenkins.sh: use --enable-werror configure flag, not CFLAGS
97
98 [ Alexander Couzens ]
99 * debian/rules: show testsuite.log when tests are failing
100 * unixsocket: fix a potential string overflow
101
102 [ Harald Welte ]
103 * debian/copyright: fix upstream-name
104 * Add SPDX-License-Identifier to all source files
105 * Add a new osmo_rtp_set_source_desc() function to set the RTCP SDES items
106 * debian/control: Fix Vcs-Browser
107
108 [ Pau Espin Pedrol ]
109 * contrib: jenkins.sh: Disable doxygen in libosmocore build
110 * e1_input.h: Remove dead declaration of unexistent API ipaccess_setup
111 * configure.ac: Fix condition check for RTP_SIGNAL_PTR_CAST define
112 * use osmo_init_logging2
113 * git-version-gen: Check first for new tag format
114
115 [ Stefan Sperling ]
116 * preserve 'when' flags of new osmo_fd in ipaccess_rcvmsg()
117
118 -- Pau Espin Pedrol <pespin@sysmocom.de> Thu, 03 May 2018 16:12:04 +0200
119
Max7f17b8c2017-08-25 16:09:48 +0200120libosmo-abis (0.4.0) unstable; urgency=medium
Holger Hans Peter Freyther64797282016-05-24 23:04:00 +0200121
122 * Move forward towards a new release.
Max7f17b8c2017-08-25 16:09:48 +0200123 * libosmo-abis API change major: add parameter to struct
124 input_signal_data
125 * libosmo-trau API change major: add parameters to rx_cb()
126 callack in osmo_ortp.h
Holger Hans Peter Freyther64797282016-05-24 23:04:00 +0200127
Max7f17b8c2017-08-25 16:09:48 +0200128 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Fri, 25 Aug 2017 16:09:46 +0200
Holger Hans Peter Freyther64797282016-05-24 23:04:00 +0200129
130libosmo-abis (0.3.2) unstable; urgency=medium
Holger Hans Peter Freyther3cef39b2015-11-03 09:40:00 +0100131
132 * Bump so version to re-link libosmovty
133
134 -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Tue, 03 Nov 2015 09:42:01 +0100
135
136libosmo-abis (0.3.1) unstable; urgency=medium
Holger Hans Peter Freyther2f0dd0c2015-01-18 19:27:07 +0100137
138 * New upstream release of libosmo-abis
139
140 -- Holger Hans Peter Freyther <holger@freyther.de> Sun, 18 Jan 2015 19:26:40 +0100
141
Holger Hans Peter Freytherb6d28342014-09-08 07:29:50 +0200142libosmo-abis (0.3.0) unstable; urgency=medium
Holger Hans Peter Freytherecd0a362014-03-31 15:49:13 +0200143
144 * New upstream release of libosmo-abis
145
Holger Hans Peter Freytherb6d28342014-09-08 07:29:50 +0200146 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 08 Sep 2014 07:29:39 +0200
147
148libosmo-abis (0.2.0) unstable; urgency=medium
149
150 * New upstream release of libosmo-abis
151
152 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 08 Sep 2014 07:29:19 +0200
Holger Hans Peter Freytherecd0a362014-03-31 15:49:13 +0200153
154libosmo-abis (0.1.6) unstable; urgency=medium
Holger Hans Peter Freytherf6415ea2014-01-20 10:33:52 +0100155
156 * New upstream release of libosmo-abis
157
158 -- Holger Hans Peter Freyther <holger@freyther.de> Mon, 20 Jan 2014 10:33:36 +0100
159
Holger Hans Peter Freyther91de2d02013-12-12 11:47:39 +0100160libosmo-abis (0.1.5+git1) unstable; urgency=low
161
162 * Rebuild 0.1.5 with the right libosmocore depedency
163
164 -- Holger Hans Peter Freyther <holger@freyther.de> Thu, 12 Dec 2013 11:47:01 +0100
165
Holger Hans Peter Freyther2dfcd9e2012-11-06 13:34:34 +0100166libosmo-abis (0.1.4) unstable; urgency=low
167
168 * New upstream release
169
170 -- Holger Hans Peter Freyther <holger@freyther.de> Tue, 06 Nov 2012 13:33:45 +0100
171
Eric Butlerd11a5c12012-08-14 20:56:26 -0700172libosmo-abis (0.1.3+git3-1) precise; urgency=low
173
174 * Fix version issue.
175
176 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 20:50:50 -0700
177
Eric Butler91ffa2b2012-08-14 18:07:48 -0700178libosmo-abis (0.1.3+git3) precise; urgency=low
179
180 Created new Ubuntu package.
181
182 -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 13:00:18 -0700