blob: 616f96de1461d2b0f568500a5c2e653bf4002af1 [file] [log] [blame]
Harald Welte977c2332017-10-30 23:22:52 +01001#!/usr/bin/make -f
2
3# Uncomment this to turn on verbose mode.
4#export DH_VERBOSE=1
5
6DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
7DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
8VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
9
10export DEB_BUILD_MAINT_OPTIONS = hardening=+all
11
12export DEB_LDFLAGS_MAINT_STRIP = -Wl,-Bsymbolic-functions
13
14%:
15 dh $@ --with autoreconf --fail-missing
16
17override_dh_strip:
18 dh_strip --dbg-package=libgtpnl-dbg
19
20override_dh_install:
21 sed -i "/dependency_libs/ s/'.*'/''/" `find . -name '*.la'`
22 dh_install
23
24# Print test results in case of a failure
25override_dh_auto_test:
26 dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)