blob: e067596794d7313a3fe1b43fcf3e8bf0587c6513 [file] [log] [blame]
Oliver Smith2f276eb2020-05-14 11:18:39 +02001#
2# spec file for package libgtpnl
3#
4# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
5#
6# All modifications and additions to the file contributed by third parties
7# remain the property of their copyright owners, unless otherwise agreed
8# upon. The license for this file, and modifications and additions to the
9# file, is the same license as for the pristine package itself (unless the
10# license for the pristine package is not an Open Source License, in which
11# case the license is the MIT License). An "Open Source License" is a
12# license that conforms to the Open Source Definition (Version 1.9)
13# published by the Open Source Initiative.
14
15# Please submit bugfixes or comments via http://bugs.opensuse.org/
16#
17
18
19Name: libgtpnl
20Version: 1.2.1.0
21Release: 0
22Summary: GPRS tunnel configuration library
23License: GPL-2.0-or-later AND LGPL-2.1-or-later
24Group: Development/Libraries/C and C++
25URL: https://osmocom.org/projects/linux-kernel-gtp-u/wiki
26Source: %{name}-%{version}.tar.xz
27BuildRequires: libtool >= 2
28BuildRequires: pkgconfig
29BuildRequires: xz
30BuildRequires: pkgconfig(libmnl) >= 1.0.0
31
32%description
33libgtpnl wraps the genetlink-based GPRS tunnel configuration of the
34Linux kernel into a C API.
35
36%package -n libgtpnl0
37Summary: GPRS tunnel configuration library
38License: LGPL-2.1-or-later
39Group: System/Libraries
40
41%description -n libgtpnl0
42libgtpnl wraps the genetlink-based GPRS tunnel configuration of the
43Linux kernel into a C API.
44
45%package devel
46Summary: Development files for the GPRS tunnel config library
47License: GPL-2.0-or-later AND LGPL-2.1-or-later
48Group: Development/Libraries/C and C++
49Requires: libgtpnl0 = %{version}
50
51%description devel
52libgtpnl wraps the genetlink-based GPRS tunnel configuration of the
53Linux kernel into a C API.
54
55This subpackage contains libraries and header files for developing
56applications that want to make use of libgtpnl.
57
58%prep
59%setup -q
60
61%build
62echo "%{version}" >.tarball-version
63autoreconf -fi
64%configure --includedir="%{_includedir}/%{name}"
65make %{?_smp_mflags}
66
67%install
68%make_install
69find %{buildroot} -type f -name "*.la" -delete -print
70
71%check
72make %{?_smp_mflags} check || (find . -name testsuite.log -exec cat {} +)
73
74%post -n libgtpnl0 -p /sbin/ldconfig
75%postun -n libgtpnl0 -p /sbin/ldconfig
76
77%files -n libgtpnl0
78%{_libdir}/libgtpnl.so.0*
79
80%files devel
81%license COPYING
82%{_includedir}/libgtpnl/
83%{_libdir}/libgtpnl.so
84%{_libdir}/pkgconfig/*.pc
85
86%changelog