separate libosmo-mgcp-client from mgcp server code

When osmo-mgw is built --with-mgcp-transcoding, linking the mgcp library
also requires linking libgsm, even though e.g. osmo-msc never use it.
Separate the MGCP client code from the MGCP server code to avoid this dep.

The mgcp client code does use some definitions from mgcp.h and mgcp_common.c.
For simplicity, link mgcp_common.c in both libosmo-legacy-mgcp as well as
libosmo-mgcp-client. That means it is not possible to link both
libosmo-legacy-mgcp and libosmo-mgcp-client in the same binary because of
duplicate symbols, but currently that is sufficient. (An alternative would be
code dup or yet another libosmo-mgcp-common library.)

Add libosmo-mgcp-client to debian packaging.

Related: OS#2488
Change-Id: I8e0b2d2a399b77086a36606f5e427271c6242df1
diff --git a/debian/control b/debian/control
index af49dc7..6556370 100644
--- a/debian/control
+++ b/debian/control
@@ -47,3 +47,25 @@
 Multi-Arch: same
 Depends: libosmo-legacy-mgcp0 (= ${binary:Version}), ${misc:Depends}
 Description: libosmo-legacy-mgcp: Osmocom's Media Gateway server library
+
+Package: libosmo-mgcp-client0
+Section: libs
+Architecture: any
+Multi-Arch: same
+Pre-Depends: ${misc:Pre-Depends}
+Depends: ${misc:Depends}, ${shlibs:Depends}
+Description: libosmo-mgcp-client: Osmocom's Media Gateway Control Protocol client utilities
+
+Package: libosmo-mgcp-client-dbg
+Section: debug
+Architecture: any
+Multi-Arch: same
+Depends: libosmo-mgcp-client0 (= ${binary:Version}), ${misc:Depends}
+Description: libosmo-mgcp-client: Osmocom's Media Gateway Control Protocol client utilities
+
+Package: libosmo-mgcp-client-dev
+Section: libdevel
+Architecture: any
+Multi-Arch: same
+Depends: libosmo-mgcp-client0 (= ${binary:Version}), ${misc:Depends}
+Description: libosmo-mgcp-client: Osmocom's Media Gateway Control Protocol client utilities