debian: Make the package creation work on debian squeeze (stable)

the dh_autoreconf application did not honor the sourcedirectory
option back then. Override the target and call autoreconf from
the right directory.
The libdbi development package is called libdbi0-dev. Use this name
for Debian stable but it should work for Ubuntu as well.
diff --git a/debian/rules b/debian/rules
index cac108d..89f96cc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,6 +20,10 @@
 %:
 	dh --sourcedirectory=openbsc --with autoreconf $@
 
+# This is needed for debian stable (squeeze)
+override_dh_autoreconf:
+	cd openbsc && autoreconf --install --force
+
 override_dh_auto_configure:
 	echo $(VERSION) > openbsc/.tarball-version
 	dh_auto_configure --sourcedirectory=openbsc -- --enable-nat --enable-osmo-bsc