libosmocore: Avoid use --disable-detect-tls-gcc-arm-bug

Related: OS#5079
Change-Id: I74cfbc784e2330837a3b165b0f3a62dc6c4ce274
diff --git a/recipes-osmocom/libosmocore/libosmocore_git.bb b/recipes-osmocom/libosmocore/libosmocore_git.bb
index 9717511..062fb20 100644
--- a/recipes-osmocom/libosmocore/libosmocore_git.bb
+++ b/recipes-osmocom/libosmocore/libosmocore_git.bb
@@ -4,7 +4,7 @@
 SRCREV = "1.5.1"
 SRC_URI = "git://git.osmocom.org/libosmocore.git;protocol=git;tag=${SRCREV};nobranch=1"
 PV = "1.5.1+gitr${SRCPV}"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
 
 PACKAGES =+ "libosmoctrl libosmocodec libosmogb libosmogsm libosmovty osmo-arfcn osmo-auc-gen osmo-config-merge"
 FILES_libosmoctrl = "${libdir}/libosmoctrl${SOLIBS}"
@@ -36,4 +36,12 @@
 # we are not affected by the bug, we are fine with that. If the toolchain had
 # the TLS runtime bug, then we'd had to build with -O0. Can be probably dropped
 # once we move to newer toolchain.
-EXTRA_OECONF +=  "--disable-detect-tls-gcc-arm-bug"
+#EXTRA_OECONF +=  "--disable-detect-tls-gcc-arm-bug"
+# UPDATE: OS#5079: we stop using "--disable-detect-tls-gcc-arm-bug" because we
+# finally hit the TLS bug in sysmobts (osmo-bts-symo calling osmo_str_tolower()
+# which uses "static __thread char capsbuf"). As a result, the only option would
+# be to use -O0 when building libosmocore with the sysmobts toolchain. In order
+# to avoid that, we take advantage of the fact that no libosmocore multi-thread
+# process is expected to run there and simply drop all the "__thread"
+# references when building for sysmobts. That's done as a machine-specific
+# bbappend in meta-sysmocom-bsp.