misc: Modernize and call it packagegroup-

The notion of task- has been deprecated a long time ago. Call
it packagegroup now and for "packagegroup-osmocom" provide the
compability. This has not been compile tested.

The edison build will require a bbappend to provide packagegroup
now but I will do this once I need to build for Edison again.
diff --git a/recipes-osmocom/packagegroup/packagegroup-core-standalone-osmo-sdk-target.bb b/recipes-osmocom/packagegroup/packagegroup-core-standalone-osmo-sdk-target.bb
new file mode 100644
index 0000000..dd5072b
--- /dev/null
+++ b/recipes-osmocom/packagegroup/packagegroup-core-standalone-osmo-sdk-target.bb
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2007 OpenedHand Ltd.
+#
+
+DESCRIPTION = "Software Development Kit for Osmocom devices"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r5"
+
+ALLOW_EMPTY_${PN} = "1"
+
+# TODO: We need to rename this task to packagegroup but for now we
+# will need to skip this test.
+INSANE_SKIP_${PN} += "dev-deps"
+
+require packagegroup-sdk-osmo.inc
+
+PACKAGES = "${PN} ${PN}-dbg"
+
+RDEPENDS_${PN} = "\
+    packagegroup-core-standalone-sdk-target \
+    ${SDK-OSMO} \
+    ${SDK-EXTRAS}"