Add release target to Makefile

Add simple helper target to automate basic release steps:
* version bump
* prepare release commit
* git commit, tag and sign

For library projects:
* update debian/changelog from TODO-RELEASE
* cleanup TODO-RELEASE

For non-library projects:
* update debian/changelog from git log

Note: it requires bumpversion package to be installed, debian/control is
adjusted accordingly. The helper itself is installed to facilitate reuse
by other libraries.

N. B: you still have to manually adjust LIBVERSION in previous commit -
see TODO-RELEASE header for details.

Use it as follows:
make REL=minor release

The REL parameter defines which component of the version [1] to bump and
can be any of { major, minor, patch }.

[1] http://semver.org/

Change-Id: I790ceb958195b9f6cbabfe8c977dc30e2bd7414b
Related: OS#1861
diff --git a/debian/control b/debian/control
index b19448e..e266173 100644
--- a/debian/control
+++ b/debian/control
@@ -281,6 +281,7 @@
 Multi-Arch: same
 Section: libdevel
 Depends: libosmocore,
+         bumpversion,
          libtalloc-dev,
          ${misc:Depends}
 Description: Development headers for Open Source MObile COMmunications CORE library