Tag/Release version 0.10.0

It's been way too long since the last release.  Almost one year and
468 commits.

A brief summary of the changes below:

* Doxygen for libosmo{coding,gb}
* pseudotalloc for embedded builds, jenkins for arm-none-gnueabi
* --disable-doxygen, --disable-ctrl, --disable-simd
* update debian packaging
* gsm0503 coding routines
* osmo_hton[sl]
* statistics.h -> counter.h
* QCDIAG in gsmtap
* llist_{first,last}_entry()
* llist_count()
* LOGPSRC() macro
* msgb_pull_to_l2()
* msgb_printf()
* prbs
* osmo_sock_init2()
* osmo_sock_mcast_{name,loop_set,ttl_set,all_set,subscribe,ip}()
* OSMO_STRINGIFY()
* OSMO_VALUE_STRING()
* OSMO_BYTES_FOR_BITS()
* osmo_talloc_asprintf()
* osmo_sub_auth_type_name()
* osmo_sub_auth_data support for IND/SQN_MS
* osmo_fsm ctrl interface
* ctrl_handle_alloc2()
* ctrl_interface_setup_dynip2()
* OSMO_CTRL_PORT_HLR
* bssgp_tx_bvc_ptp_reset()
* gprs_ns_inst connect/remote_{ip,port}
* osmo_gprs_{ul,dl}_block_size_{bits,bytes}()
* osmo_gprs_{dl,ul}_cs_by_block_bytes()
* gprs_ns_pdu_strings[]
* more BSSGP cause values
* abis_nm_admin_name()
* AoIP support in gsm0808
* gsm_fn_as_gsmtime_str()
* osmo_dump_gsmtime()
* gsup charging support
* ipa_ccm_make_id_resp()
* ipa_ccm_make_id_resp_from_req()
* struct gsm48_gprs_susp_req
* gsm_04_14.h
* rsl measurement preprocessing related IEs
* abis_nm_event_cause_names[]
* abis_nm_sw_desc and friends
* more SYSINFO_TYPE_ values
* osmo_earfcn_bit_size_ext()
* t16lv_put()
* msgb_t16lv_put()
* tlvp_val16be()
* tlvp_val32be()
* osmo_tlvp_copy()
* osmo_tlvp_merge()
* many additional VTY nodes
* cmd_node.name member
* bitvec_set_u64()
* bitvec_rl_curbit
* ctrl_lookup_register()
* osmo_fsm_find_by_name()
* osmo_fsm_inst_find_by_name()
* osmo_fsm_inst_find_by_id()

Change-Id: Ieb5db2e910a90db780ea058b3280f2facbd68d76
diff --git a/debian/control b/debian/control
index b19448e..8ba5583 100644
--- a/debian/control
+++ b/debian/control
@@ -26,11 +26,11 @@
 Multi-Arch: foreign
 Depends: libosmocodec0 (= ${binary:Version}),
          libosmocoding0 (= ${binary:Version}),
-         libosmocore8 (= ${binary:Version}),
-         libosmogb4 (= ${binary:Version}),
-         libosmogsm7 (= ${binary:Version}),
-         libosmovty3 (= ${binary:Version}),
-         libosmoctrl0 (= ${binary:Version}),
+         libosmocore9 (= ${binary:Version}),
+         libosmogb5 (= ${binary:Version}),
+         libosmogsm8 (= ${binary:Version}),
+         libosmovty4 (= ${binary:Version}),
+         libosmoctrl1 (= ${binary:Version}),
          libosmosim0 (= ${binary:Version}),
          ${misc:Depends}
 Description: Open Source MObile COMmunications CORE library (metapackage)
@@ -109,7 +109,7 @@
  .
  This package contains the documentation for the libosmocoding library.
 
-Package: libosmocore8
+Package: libosmocore9
 Section: libs
 Architecture: any
 Multi-Arch: same
@@ -123,14 +123,14 @@
  (at least) other programs that are developed in the sphere of Free Software /
  Open Source mobile communication.
  .
- The libosmocore8 library in particular is a collection of common code used in
+ The libosmocore9 library in particular is a collection of common code used in
  various sub-projects inside the Osmocom family of projects.
 
 Package: libosmocore-doc
 Architecture: all
 Section: doc
 Depends: ${misc:Depends},
-         libosmocore8,
+         libosmocore9,
          libjs-jquery,
          libosmocodec-doc,
          libosmocoding-doc,
@@ -145,7 +145,7 @@
  .
  This package contains the documentation for the libosmocore library.
 
-Package: libosmogb4
+Package: libosmogb5
 Section: libs
 Architecture: any
 Multi-Arch: same
@@ -166,7 +166,7 @@
 Architecture: all
 Section: doc
 Depends: ${misc:Depends},
-         libosmogb4,
+         libosmogb5,
          libjs-jquery
 Description: Documentation for the Osmo GPRS Gb library
  This is part of the libosmocore "meta"-library. The libosmocore library
@@ -177,7 +177,7 @@
  .
  This package contains the documentation for the libosmogb library.
 
-Package: libosmogsm7
+Package: libosmogsm8
 Section: libs
 Architecture: any
 Multi-Arch: same
@@ -201,7 +201,7 @@
 Architecture: all
 Section: doc
 Depends: ${misc:Depends},
-         libosmogsm7,
+         libosmogsm8,
          libjs-jquery
 Description: Documentation for the Osmo GSM utility library
  This is part of the libosmocore "meta"-library. The libosmocore library
@@ -212,7 +212,7 @@
  .
  This package contains the documentation for the libosmogsm library.
 
-Package: libosmovty3
+Package: libosmovty4
 Section: libs
 Architecture: any
 Multi-Arch: same
@@ -233,7 +233,7 @@
 Architecture: all
 Section: doc
 Depends: ${misc:Depends},
-         libosmovty3,
+         libosmovty4,
          libjs-jquery
 Description: Documentation for the Osmo VTY library
  This is part of the libosmocore "meta"-library. The libosmocore library
@@ -244,7 +244,7 @@
  .
  This package contains the documentation for the libosmovty library.
 
-Package: libosmoctrl0
+Package: libosmoctrl1
 Section: libs
 Architecture: any
 Multi-Arch: same
@@ -258,7 +258,7 @@
  (at least) other programs that are developed in the sphere of Free Software /
  Open Source mobile communication.
  .
- The libosmoctrl library in particular contains an SNMP-like status interface.
+ The libosmoctrl1 library in particular contains an SNMP-like status interface.
 
 Package: libosmosim0
 Section: libs