Fixup severe build performance issues

Make variable substitution calling bumpversion and other commands
introduce by osmo-release.mk has severely slowed down builds.

Inside the makefile we could use $(eval FOO:=$(shell...)) constructs
to have variable substitution only happen once the 'release' target
is executed. However, 'ifeq' and friends don't work with such late
constructs. Let's shift all release action into a helper shell script
that is called from the Makefile instead.

This way we get the best of both worlds: No performance impact during
normal builds, and the convenience of 'make release'.

Modified-by: Max <msuraev@sysmocom.de>

Related: OS#2524

Change-Id: I98b3b5fe3db39953cea969a9dfbb75889df2e1ea
diff --git a/debian/libosmocore-dev.install b/debian/libosmocore-dev.install
index 465f933..944a7bf 100644
--- a/debian/libosmocore-dev.install
+++ b/debian/libosmocore-dev.install
@@ -3,3 +3,4 @@
 usr/lib/*/lib*.so
 usr/lib/*/lib*.la
 usr/lib/*/pkgconfig/*
+usr/bin/osmo-release.sh