libosmocore libusb integration

Osmocom applications typically use libosmocore select.[ch] event loop
code as their main event dispatch mechanism.  When they want to deal
with libusb in a non-blocking/asynchronous way, they need to integrate
libusb into that select().

The new libosmousb is doing exactly that: Providing a shared utility
library for Osmocom programs that wish to use libusb.  This is useful
for example in simtrace2 host utilitie as well as osmo-e1d.

Change-Id: I656a1a38cbb5b1f3a9145d2869d3b4d0adefcae3
Closes: OS#4299
diff --git a/debian/control b/debian/control
index cf7a853..d2c232f 100644
--- a/debian/control
+++ b/debian/control
@@ -34,6 +34,7 @@
          libosmovty4 (= ${binary:Version}),
          libosmoctrl0 (= ${binary:Version}),
          libosmosim0 (= ${binary:Version}),
+         libosmousb0 (= ${binary:Version}),
          ${misc:Depends}
 Description: Open Source MObile COMmunications CORE library (metapackage)
  The libraries provided by this package contain various utility functions.
@@ -293,6 +294,23 @@
  .
  The libosmosim library in particular contains routines for SIM card access.
 
+Package: libosmousb0
+Section: libs
+Architecture: any
+Multi-Arch: same
+Depends: ${shlibs:Depends},
+         ${misc:Depends}
+Pre-Depends: ${misc:Pre-Depends}
+Description: Osmo USB library
+ This is part of the libosmocore "meta"-library. The libosmocore library
+ contains various utility functions that were originally developed as part of
+ the OpenBSC project, but which are of a more generic nature and thus useful to
+ (at least) other programs that are developed in the sphere of Free Software /
+ Open Source mobile communication.
+ .
+ The libosmosub library in particular contains routines for USB device access
+ via libusb-1.0, integrated into the libosmocore select event loop.
+
 Package: libosmocore-dev
 Architecture: any
 Multi-Arch: same