debian: Switch to the 3.0 git format, update version, fix depends

Switch to the git format as this can generate the source directly
from the git checkout. Increase the version number to 0.1.27 as this
is the latest tag, depend on autoconf, automake and libtool and use
autoreconf when building to be able to directly build from a git
clone.
diff --git a/debian/rules b/debian/rules
index a81850a..15f78f2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,7 +12,7 @@
 CFLAGS = -Wall -g
 
 %:
-	dh $@ 
+	dh --with autoreconf $@ 
 
 #override_dh_strip:
 #	dh_strip --dbg-package=libosmocore-dbg