Enable systemd-journald log target in debian + rpm packaging

Given that all the distributions we support are shipping systemd
anyway, this will not really introduce any additional runtime package
dependencies.

Change-Id: Ib3af918cd4cc8d0ca6d228a0f2c8338534374d46
diff --git a/debian/rules b/debian/rules
index afff17f..f5b71eb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -26,7 +26,7 @@
 	dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
 
 override_dh_auto_configure:
-	dh_auto_configure -- --enable-static --disable-sctp-tests
+	dh_auto_configure -- --enable-static --disable-sctp-tests --enable-systemd-logging
 
 override_dh_clean:
 	dh_clean