Bump version: 1.0.1.143-cc72c → 1.1.0

Change-Id: I351411ca5913c8b40f23287ec7c9ebfe11bd2bb0
diff --git a/debian/changelog b/debian/changelog
index 2cdab76..5ed8fe6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,169 @@
+libosmocore (1.1.0) unstable; urgency=medium
+
+  [ Oliver Smith ]
+  * gsm_23_003.h: add GSM23003_IMEI_NUM_DIGITS_NO_CHK
+  * GSUP: deprecate osmo_gsup_get_err_msg_type()
+  * Revert "signal.c: Make non-exported tall_sigh_ctx static"
+  * Revert "ipa_ccm_idtag_parse*: Fix reported length value"
+  * GSUP: add inter-MSC handover related msgs and IEs
+
+  [ Harald Welte ]
+  * Bump version: 1.0.0 → 1.0.1
+  * gsm0408_test: Fix IMEI-SV related tests to use no more than 16 digits
+  * constrain gsm48_generate_mid() output array bounds
+  * Work around bogus gcc-8.2 array-bounds warning/error
+  * Extend gsm_04_08.h with CSFB related definitiosn form 44.018 Rel 15
+  * gsm_08_08.h: Add IEI definitions from Release 15
+  * bitvec: Add bitvec_bytes_used() function
+  * bitvec: Add bitvec_tailroom_bits() function
+  * Fix BSSMAP length generated by gsm0808_create_clear_command2()
+  * gsm0808: comment about difference of gsm0808_create_clear_command()
+  * gsm0808: Add unit tests for test_create_clear_command2()
+  * bssgp_tx_bvc_unblock(): Fix log message
+  * gprs_ns: Use gprs_ns_tx_alive() instead of gprs_ns_tx_simple()
+  * gprs_ns.c: cosmetic whitespace fixes
+  * gprs_ns: Declare gprs_ns_tx_alive*() in header file
+  * gprs_ns: Add missing NSVCI IE to NS-BLOCK-ACK message
+  * select: Call log_reset_context() before calling file descriptor callbacks
+  * NS: Don't print information about FR/GRE if not enabled!
+  * NS: Add missing NS Cause strings
+  * GPRS: Doxygen documentation for 'struct libgb_msgb_cb'
+  * gprs_ns: Add code for SNS-SIZE and SNS-CONFIG encoding
+  * NS: Factor out gprs_nsvc_start_test() and use it
+  * NS: Add support for GPRS NS IP Sub-Network-Service (SNS)
+  * gprs_ns.c: Update comment: IP SNS has recently been implemented
+  * gprs_ns: Don't use initial IP/port for anything but SNS
+  * gprs_ns_sns: Use "correct" remote IP address for local IP endpoint
+  * tests: use -no-install libtool flag to avoid ./lt-* scripts
+  * ipa_ccm_idtag_parse*: Fix reported length value
+  * socket: osmo_sock_get_name() Use "const void *" as talloc context
+  * gprs_ns_sns: Properly initialize sockaddr_in in gprs_nsvc_create_ip4()
+  * select: Rename BSC_FD_* constants to OSMO_FD_*
+  * signal.c: Fix osmo_signal_talloc_ctx_init()
+  * signal.c: Make non-exported tall_sigh_ctx static
+  * osmo_escape_str_buf: Always copy, don't return input string pointer
+  * Add _buf() functions to bypass static string buffers
+  * Add _c versions of functions that otherwise return static buffers
+  * Re-introduce declaration of gsm0808_create_handover_request_ack()
+
+  [ Neels Hofmeyr ]
+  * gsm0808: add BSSMAP Cell Identifier matching API
+  * add osmo_hexdump_buf() and test
+  * add osmo_classmark_* API
+  * osmo_fsm_state_name: make robust against NULL fi
+  * build: add missing logging_vty_test.vty to EXTRA_DIST
+  * jenkins distcheck: enable external tests
+  * osmo_fsm_inst_state_chg(): set T also for zero timeout
+  * osmo_fsm_inst_state_chg(): clamp timeout_secs to <= ~68 years
+  * add generic vty_transcript_test.c, vty_transcript_test.vty
+  * vty: enable optional-multi-choice syntax: ([one]|[two])
+  * vty: enable optional-multi-choice syntax: [(one|two)]
+  * vty: enable tab-completion for optional-multi-choice args
+  * vty telnet: consistently never change nodes upon CTRL-C
+  * vty api: add vty_out_va()
+  * doxygen: enable cross referencing everywhere
+  * doxygen: add source files as dependencies
+  * doxygen: allow manual 'make apidoc' even if --disable-doxygen
+  * add osmo_tdef API, originally adopted from osmo-bsc T_def
+  * platform independence fix: tdef range tests
+  * get_value_string(): guard against NULL
+  * fix osmo_gsm48_classmark* libosmogsm.map entries
+  * add OSMO_STRBUF_PRINTF()
+  * enlarge gsm0808 msgb headroom
+  * log: fsm: allow logging the timeout on state change
+  * fix api doc typo for osmo_plmn_name2()
+  * api doc: tweak gsm0808_cell_id_matches_list() doc
+  * represent negative T-timers as Osmocom-specific X-timers
+  * tdef_test: tweak output to prepare for a fix
+  * fix tdef_test.c: do call the function-to-test in all cases
+  * fsm: add osmo_fsm_inst_state_chg_keep_or_start_timer()
+  * add gsm0808_cell_id_from_cgi(), gsm0808_cell_id_to_cgi()
+  * osmo_gsm48_classmark_a5_name(): fix 'no-cm3' label
+  * gsm_utils.h: remove unused include of gsm_08_08.h
+  * add osmo_sockaddr_str API
+  * add osmo_use_count API
+  * add fsm_dealloc_test.c
+  * fsm: add flag to ensure osmo_fsm_inst_term() happens only once
+  * fsm: support graceful osmo_fsm_inst_term() cascades
+  * fsm_dealloc_test: no need for ST_DESTROYING
+  * make osmo_sockaddr_str_is_set() NULL-safe
+  * add osmo_str_startswith()
+  * tweak OSMO_STRBUF_APPEND(), add OSMO_STRBUF_APPEND_NOLEN()
+  * add osmo_{escape,quote}_str_buf2() for standard args ordering
+  * add identifier sanitation for setting FSM instance ids
+  * add OSMO_IMSI_BUF_SIZE
+  * GSUP: add Message Class IE
+  * BSSMAP: tweaks
+  * BSSMAP: add messages for inter-BSC and inter-MSC Handover
+  * add gsm48_decode_bcd_number2() from osmo-msc
+  * add osmo_bssap_tlv_parse2() for multiple identical T
+  * add vty_is_active()
+  * add comment to gsm_mncc_bearer_cap.speech_ver
+  * gsm48_decode_bcd_number2(): fix input len check
+  * gsm48_decode_bcd_number2(): allow avoiding deprecation
+  * osmo_gsup_decode(): properly check IMSI, avoid deprecation
+  * add gsm0808_create_handover_request_ack2 to add AoIP RTP addr
+
+  [ Max ]
+  * socket.h: add missing include
+  * Enable remote SIM protocol log level
+  * Add multipatch capability to osmo-config-merge
+  * LCLS: add string dump helpers
+  * coding: check gsm0503_rach_*() results
+  * rate_ctr_group_free(): guard against empty or NULL input
+  * BSSGP: use variable for NSEI
+
+  [ Philipp Maier ]
+  * gsm0808: Add CSFB indication IE to BSSMAP CLEAR COMMAND
+  * gsm0808_utils: fix gsm48 multirate configuration generator
+  * gsm0808_utils: fix gsm48 multirate to S-bit converter
+  * gsm_utils: fix use buf_len instead of sizeof in osmo_dump_gsmtime_buf
+
+  [ Sylvain Munaut ]
+  * protocol/gsm_04_14: Fix the OPEN LOOP message type
+  * gsm_08_08.h: Add constants for Channel Type in signalling mode
+
+  [ Vadim Yanitskiy ]
+  * gsm/gsm0480: introduce gsm0480_create_release_complete()
+  * vty/tdef_vty.c: drop redundant comparison
+  * src/signal.c: cosmetic: use talloc_zero()
+  * Doxygen: fix incorrect / missing parameter description
+  * core/linuxlist.h: fix and unify Doxygen documentation
+  * core/linuxlist.h: fix white-space and inconsistent alignment
+  * src/logging.c: fix syntax errors in Doxygen documentation
+  * core/msgb.h: fix dead msgb2 reference in msgb_eq_* helpers
+  * core/msgb.h: drop meaningless parameter of msgb_eq_* helpers
+  * src/msgb.c: fix Doxygen documentation for msgb_printf()
+  * core/msgb.h: fix incorrect Doxygen parameter description
+  * Doxygen: fix documentation of rate_ctr_for_each_counter()
+  * src/rate_ctr.c: drop some incorrect \ref references
+  * Doxygen: fix documentation of osmo_timer_setup()
+  * logging_gsmtap.c: document all params of log_target_create_gsmtap()
+  * src/gsmtap_util.c: fix possible memleak in gsmtap_source_init()
+  * gsm_03_40.h: define max SM-TP-UDL (User-Data-Length) values
+  * vty/talloc_ctx_vty.c: allocate walk_cb_params on stack, not heap
+  * vty/talloc_ctx_vty.c: use REG_NOSUB flag of regcomp()
+  * gsm_utils.c: fix Doxygen description for gsm_get_octet_len()
+  * Fix incorrect buffer size calculation
+  * gb/gprs_ns_sns.c: fix incorrect sizeof() calculation
+  * gsm/gsm_utils.c: indicate intentional fall-through
+  * application.c: drop wrong \references of osmo_init_ignore_signals()
+  * bitcomp.c: fix missing Doxygen group closing tag
+  * gsm/gsm_utils.h: fix argument type of gsm_chan_t_name()
+
+  [ Pau Espin Pedrol ]
+  * rsl: Support PDCH in rsl_chan_nr_str
+  * ipa: Document ipa_ccm_idtag_parse_off and fix ipa_ccm_idtag_parse
+  * ipa: Fix ipa_ccm_id_resp_parse on big endian systems
+
+  [ Karl Koscher ]
+  * Fix build on non-glibc systems
+
+  [ Alexander Couzens ]
+  * add osmo_stat_item_inc/osmo_stat_item_dec to set it relative
+
+ -- Pau Espin Pedrol <pespin@sysmocom.de>  Tue, 07 May 2019 18:36:51 +0200
+
 libosmocore (1.0.1) unstable; urgency=medium
 
   [ Max ]