Changes to the Debian packaging files
diff --git a/debian/rules b/debian/rules
index 6b44c5b..cb59406 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,27 +1,15 @@
 #!/usr/bin/make -f
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+export DEB_HOST_MULTIARCH
 
-BUILDDIR = build
+%:
+	dh $@ --with python2 --parallel
 
-# secondly called by launchpad
-build:
-	mkdir $(BUILDDIR);
-	cd $(BUILDDIR); cmake -DCMAKE_INSTALL_PREFIX=../debian/tmp/usr ..
-	make -C $(BUILDDIR)
+override_dh_auto_configure:
+	dh_auto_configure -- -DLIB_SUFFIX="/$(DEB_HOST_MULTIARCH)" -DPythonLibs_FIND_VERSION:STRING="2.7" -DPYTHON_EXECUTABLE:STRING="/usr/bin/python"
 
-# thirdly called by launchpad
-binary: binary-indep binary-arch
+override_dh_auto_install:
+	dh_auto_install
+	rm -f debian/gr-gsm/usr/lib/python2.7/dist-packages/grgsm/*pyc
+	rm -f debian/gr-gsm/usr/lib/python2.7/dist-packages/grgsm/*pyo
 
-binary-indep:
-	# nothing to be done
-
-binary-arch:
-	cd $(BUILDDIR); cmake -P cmake_install.cmake
-	mkdir debian/tmp/DEBIAN
-	dpkg-gencontrol -pgr-gsm
-	dpkg --build debian/tmp ..
-
-# firstly called by launchpad
-clean:
-	rm -rf $(BUILDDIR)
-
-.PHONY: binary binary-arch binary-indep clean